Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036728
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2017-08-28 14:552017-09-21 16:49
ReporterJONHMView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revision2174cbb90a5a
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2017-06-21
Regression introduced in release3.0PR17Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/bdca94625dbf67b7e9dbf54f7535f6f22b499b14 [^]
Triggers an Emergency PackNo
Summary

0036728: Error displaying in selector picklist a field based in a non-primitive derived property

DescriptionAn error is thrown when using a selector that is configured to display a field in the picklist which is based in a non-primitive derived property, i.e., a property resolved through property navigation which points to a reference.
Steps To Reproduce- As System Administrator
1) Open window "Reference" and select 'Product (by Price and Warehouse)'
2) Switch to [Defined Selector] tab and then to [Defined Selector Field] subtab
3) Create a new record:
  Name: Product2
  Property: productPrice.product
  Show in picklist: YES

- As F&B International Group Admin
4) Open "Sales Order" window and create a new record from 'Alimentos y Supermercados, S.A' bussiness partner
5) Create a new line and open the 'Product' selector picklist

--> It shows the following error in the log:
ERROR org.openbravo.service.json.DefaultJsonDataService - java.lang.NullPointerException
    at org.openbravo.service.json.DataToJsonConverter.toJsonObject(DataToJsonConverter.java:219)
    at org.openbravo.service.json.DataToJsonConverter.toJsonObjects(DataToJsonConverter.java:144)
    at org.openbravo.service.json.DefaultJsonDataService.fetch(DefaultJsonDataService.java:301)
    at org.openbravo.service.datasource.DefaultDataSourceService.fetch(DefaultDataSourceService.java:85)
    at org.openbravo.service.datasource.DefaultDataSourceService.fetch(DefaultDataSourceService.java:78)
    at org.openbravo.service.datasource.DataSourceServlet.doFetch(DataSourceServlet.java:285)
    at org.openbravo.service.datasource.DataSourceServlet.doPost(DataSourceServlet.java:843)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:650)
        ...

TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00367373.0PR17Q3 closedcaristu Error displaying in selector picklist a field based in a non-primitive derived property 
depends on backport 00367393.0PR17Q2.3 closedcaristu Error displaying in selector picklist a field based in a non-primitive derived property 
depends on backport 00367403.0PR17Q1.4 closedcaristu Error displaying in selector picklist a field based in a non-primitive derived property 
caused by defect 0036268 closedcaristu Product Complete selector does not show some fields on picklist 
related to defect 0036929 closedcaristu SelectorPickListFieldsDataSourceTest test is not being executed in CI 

-  Notes
(0098698)
hgbot (developer)
2017-08-29 13:03

Repository: erp/devel/pi
Changeset: 2174cbb90a5a77d9ee8d3d0140a14bbda8093223
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Aug 29 13:02:40 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/2174cbb90a5a77d9ee8d3d0140a14bbda8093223 [^]

fixes bug 36728: Can't use fields based on some properties in selector picklist

With the fix for issue 0036268 the selector fields based on derived properties that are shown in the picklist are sent as 'extra properties' in order to calculate them properly.

The problem is that the fix was not complete when the derived properties were not primitive. In that case the DataToJsonConverter class was not calculating properly the referenced property.

Now that kind of properties are calculated properly.

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/DataToJsonConverter.java
---
(0098703)
caristu (developer)
2017-08-29 14:33

Added a new test into TestLink[1], to test that derived properties which are not primitive can be displayed on a selector drop-down list.

[1] https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-10730 [^]
(0098724)
alostale (developer)
2017-08-30 10:26

code reviewed

tested as described in steps and also related issue
(0098732)
hgbot (developer)
2017-08-30 13:58

Repository: erp/devel/pi
Changeset: d1b171923e5e080b2da6bb20c74db06d6c8a3b76
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Aug 30 13:57:11 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/d1b171923e5e080b2da6bb20c74db06d6c8a3b76 [^]

related to issue 36728: added test case

---
A src-test/src/org/openbravo/test/datasource/SelectorPickListFieldsDataSourceTest.java
---
(0098734)
hgbot (developer)
2017-08-30 14:10

Repository: erp/devel/pi
Changeset: b9227826b5dc80b718b8ef83f49fe1d1dd4d432d
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Aug 30 14:10:12 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b9227826b5dc80b718b8ef83f49fe1d1dd4d432d [^]

related to issue 36728: improved test to check that properties are not empty

---
M src-test/src/org/openbravo/test/datasource/SelectorPickListFieldsDataSourceTest.java
---
(0099339)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test
(0099347)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test
(0099348)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-08-28 14:55 JONHM New Issue
2017-08-28 14:55 JONHM Assigned To => platform
2017-08-28 14:55 JONHM Modules => Core
2017-08-28 14:55 JONHM Triggers an Emergency Pack => No
2017-08-28 14:59 JONHM Steps to Reproduce Updated View Revisions
2017-08-29 08:14 JONHM Steps to Reproduce Updated View Revisions
2017-08-29 12:35 caristu Summary Error displaying picklist when some of its 'defined selector field' has a OBUISEL_Selector reference => Error displaying in selector picklist a field based a non-primitive derived property
2017-08-29 12:35 caristu Description Updated View Revisions
2017-08-29 12:35 caristu Relationship added caused by 0036268
2017-08-29 12:37 caristu Regression date => 2017-06-21
2017-08-29 12:37 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/bdca94625dbf67b7e9dbf54f7535f6f22b499b14 [^]
2017-08-29 12:37 caristu Assigned To platform => caristu
2017-08-29 12:38 caristu Status new => scheduled
2017-08-29 12:38 caristu Regression level => Packaging and release
2017-08-29 13:03 hgbot Checkin
2017-08-29 13:03 hgbot Note Added: 0098698
2017-08-29 13:03 hgbot Status scheduled => resolved
2017-08-29 13:03 hgbot Resolution open => fixed
2017-08-29 13:03 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/2174cbb90a5a77d9ee8d3d0140a14bbda8093223 [^]
2017-08-29 13:12 caristu Status resolved => new
2017-08-29 13:12 caristu Resolution fixed => open
2017-08-29 13:12 caristu Status new => scheduled
2017-08-29 13:12 caristu Status scheduled => resolved
2017-08-29 13:12 caristu Resolution open => fixed
2017-08-29 13:32 caristu Summary Error displaying in selector picklist a field based a non-primitive derived property => Error displaying in selector picklist a field based in a non-primitive derived property
2017-08-29 13:37 caristu Review Assigned To => alostale
2017-08-29 13:51 caristu Regression level Packaging and release => Production - Confirmed Stable
2017-08-29 14:33 caristu Note Added: 0098703
2017-08-29 14:36 caristu Description Updated View Revisions
2017-08-29 14:36 caristu Steps to Reproduce Updated View Revisions
2017-08-30 10:26 alostale Note Added: 0098724
2017-08-30 10:26 alostale Status resolved => closed
2017-08-30 10:26 alostale Fixed in Version => 3.0PR17Q4
2017-08-30 13:58 hgbot Checkin
2017-08-30 13:58 hgbot Note Added: 0098732
2017-08-30 14:10 hgbot Checkin
2017-08-30 14:10 hgbot Note Added: 0098734
2017-08-30 18:49 dmitry_mezentsev Regression introduced in release => 3.0PR17Q1
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099339
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099347
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099348
2017-09-22 14:32 caristu Relationship added related to 0036929


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker