Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036605
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2017-08-04 12:322018-01-03 12:38
ReporteralostaleView Statuspublic 
Assigned Toinigosanchez 
PriorityhighResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revisiond51b35c667bc
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036605: unneeded datasource requests opening alert management window

DescriptionWhen Alert Management window is opened, 10 requests to datasource are performed:

* 4 to define them
* 6 to get actual alerts in different statuses
  - New: 1
  - Acknowledged: 1
  - Suppressed: 2
  - Solved: 2
Steps To Reproduce-Open Alert Management window from top bar
  -> check requests (see attached image)
  
Proposed SolutionMust have:
  * Remove duplicates for Suppressed and Solved

Nice to have:
  * Are the 4 definition requests required? All of them are for the same datasource; so, at most, 1 could be done and share the result
  * Is any definition request needed at all? Couldn't we just define statically in JavaScript?
  * By default only New and Pending are sections are displayed, could we request the collapsed sections lazily only when opened? Note that Alert count is displayed even if collapsed
TagsPerformance
Attached Filespng file icon Selection_207.png [^] (38,187 bytes) 2017-08-04 12:32

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0037161 acknowledgedplatform Extra DS calls in Alert Management window when refreshing after expand/collapse a section 
related to defect 0035838 closedinigosanchez Bad performance in alert window when having +20000 records in ad_alert and many of them are solved 

-  Notes
(0100015)
hgbot (developer)
2017-10-24 10:39

Repository: erp/devel/pi
Changeset: d51b35c667bc73dd1be71dcb8c3427766a617157
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Tue Oct 24 10:25:47 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/d51b35c667bc73dd1be71dcb8c3427766a617157 [^]

Fixed issue 36605: unneeded datasource requests opening alert management window

The problem was when Alert Management window was opened, 10 requests to datasource were performed.
In order to improve this situation, several actions have been done. Firts, the 4 calls of the datasource
definition are removed. Now, the datasource is defined statically. Thisthat Alert Management window is
not working good. Also, two of the duplicate request are removed.

Besides, when the Alert Management window is closed and the four grids are removed, now the datasources
are destroyed too in order to avoid having several instances for the same datasources every time that
Alerts windowd is reopened. Now, every grid removes their own datasource.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/alert-management/ob-alert-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/alert-management/ob-alert-management-view.js
---
(0100025)
alostale (developer)
2017-10-24 13:31

reopening, refresh is not working as expected:
-4 requests expected (one for each status), only 2 performed
-some caught exception while requesting at REFRESH_BUTTON_PROPERTIES callbackEnableButton
(0100053)
hgbot (developer)
2017-10-25 12:22

Repository: erp/devel/pi
Changeset: 0c21b43d56ad66d88a7a839a47e66f690b2c1967
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Wed Oct 25 12:10:15 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/0c21b43d56ad66d88a7a839a47e66f690b2c1967 [^]

Related with the issue 36605: Refresh is not working as expected

Refresh is not working as expected in Alert Management window. The problem was that a
partial solution of the issue was pushed by mistake. Now the problem of the refresh is
fixed. When a refresh is launched, 4 request are performed (one for each status).

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/alert-management/ob-alert-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/alert-management/ob-alert-management-view.js
---
(0100060)
inigosanchez (developer)
2017-10-25 12:45

A minor issue has been found 0037161 while testing the current issue.
(0100087)
hgbot (developer)
2017-10-27 08:25

Repository: erp/devel/pi
Changeset: 59eb88d7928951fa84dfbb144b66a879574a802e
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Oct 27 08:24:25 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/59eb88d7928951fa84dfbb144b66a879574a802e [^]

related to bug 36605: unneeded datasource requests in alert management window

  Removed unneeded parameter in getSectionHeader.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/alert-management/ob-alert-management-view.js
---
(0100088)
alostale (developer)
2017-10-27 08:31

reviewed + tested
(0101343)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test
(0101347)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test
(0101348)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-08-04 12:32 alostale New Issue
2017-08-04 12:32 alostale Assigned To => platform
2017-08-04 12:32 alostale Modules => Core
2017-08-04 12:32 alostale Triggers an Emergency Pack => No
2017-08-04 12:32 alostale Status new => acknowledged
2017-08-04 12:32 alostale File Added: Selection_207.png
2017-08-04 12:33 alostale Summary unneeded datasource requests opening alert window => unneeded datasource requests opening alert management window
2017-08-04 12:33 alostale Description Updated View Revisions
2017-08-04 12:33 alostale Steps to Reproduce Updated View Revisions
2017-08-04 12:33 alostale Tag Attached: Performance
2017-08-04 12:34 alostale Relationship added related to 0035838
2017-08-04 14:32 shuehner Issue Monitored: shuehner
2017-10-02 17:45 inigosanchez Status acknowledged => scheduled
2017-10-02 17:45 inigosanchez Assigned To platform => inigosanchez
2017-10-24 10:39 hgbot Checkin
2017-10-24 10:39 hgbot Note Added: 0100015
2017-10-24 10:39 hgbot Status scheduled => resolved
2017-10-24 10:39 hgbot Resolution open => fixed
2017-10-24 10:39 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d51b35c667bc73dd1be71dcb8c3427766a617157 [^]
2017-10-24 10:40 inigosanchez Review Assigned To => alostale
2017-10-24 13:31 alostale Note Added: 0100025
2017-10-24 13:31 alostale Status resolved => new
2017-10-24 13:31 alostale Resolution fixed => open
2017-10-25 12:22 hgbot Checkin
2017-10-25 12:22 hgbot Note Added: 0100053
2017-10-25 12:45 inigosanchez Note Added: 0100060
2017-10-25 12:45 inigosanchez Relationship added related to 0037161
2017-10-25 12:46 inigosanchez Status new => scheduled
2017-10-25 12:47 inigosanchez Status scheduled => resolved
2017-10-25 12:47 inigosanchez Fixed in Version => pi
2017-10-25 12:47 inigosanchez Resolution open => fixed
2017-10-25 12:47 inigosanchez Fixed in Version pi =>
2017-10-27 08:25 hgbot Checkin
2017-10-27 08:25 hgbot Note Added: 0100087
2017-10-27 08:31 alostale Note Added: 0100088
2017-10-27 08:31 alostale Status resolved => closed
2017-10-27 08:31 alostale Fixed in Version => 3.0PR18Q1
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101343
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101347
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101348


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker