Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036501
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2017-07-15 18:172017-09-22 10:20
ReportershuehnerView Statuspublic 
Assigned Toshuehner 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revision272b6763698c
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036501: Remove unused & old export.sample.data.old & import.sample.data.old

DescriptionMid 2013 the sampledata import & export was rewritten completely to no longer be bases on 'Export Client & 'Import Client' which do not have good performance for bigger datasets.
Instead sampledata export & import is since then based on dbsourcemanager code.

In that rewrite the old code to export & import sampledata using the single xml old code was kept as
ant export.sample.data.old
ant import.sample.data.old

Just for safety in case bigger trouble with the new system come up.

As now >= 4 years have passed it is time to remove that old unused code.

Note:
This is just about sampledata export & import: The process for 'Export Client' & 'Import Client' from the GUI is kept.
Steps To Reproduce-
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0036923 closedshuehner api-changes related to unused code removal 
depends on design defect 0032688 acknowledgedplatform remove unused resources 
Not all the children of this issue are yet resolved or closed.

-  Notes
(0099442)
hgbot (developer)
2017-09-21 23:11

Repository: erp/devel/pi
Changeset: 272b6763698c217f3476b27ed87a98ca13bd4903
Author: Stefan Hühner <stefan.huehner <at> openbravo.com>
Date: Fri Sep 15 17:15:38 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/272b6763698c217f3476b27ed87a98ca13bd4903 [^]

Fixed 36501. Remove unused export.sample.data.old and import.sample.data.old

Thsoe targets were kept when rewriting sampledata in 2013 completely. As 4
years have passed since then it is time to remove that old unused code.

This removes:
- ant export.sample.data.old
- ant import.sample.data.old
  - allowing to remove the disableCheckReferencedOrganizations property which is
    now unused.
- Remove both java classes implementing those tasks and one shared super-class
  ReferenceDataTask as it is not used anywhere else.

Note: This ReferenceDataTask class had one text-reference for a single constant
in some commented out testing code. -> Replace that usage with direct string as
no need to keep the java class around just for that.

---
M build.xml
M src-test/src/org/openbravo/test/xml/ClientExportImportTest.java
M src/build.xml
R src/org/openbravo/service/db/ExportReferenceDataTask.java
R src/org/openbravo/service/db/ImportReferenceDataTask.java
R src/org/openbravo/service/db/ReferenceDataTask.java
---
(0099470)
alostale (developer)
2017-09-22 10:20

reviewed

- Issue History
Date Modified Username Field Change
2017-07-15 18:17 shuehner New Issue
2017-07-15 18:17 shuehner Assigned To => shuehner
2017-07-15 18:17 shuehner Modules => Core
2017-07-15 18:17 shuehner Triggers an Emergency Pack => No
2017-07-15 18:29 shuehner Relationship added depends on 0032688
2017-09-21 23:06 shuehner Relationship added related to 0036923
2017-09-21 23:11 hgbot Checkin
2017-09-21 23:11 hgbot Note Added: 0099442
2017-09-21 23:11 hgbot Status new => resolved
2017-09-21 23:11 hgbot Resolution open => fixed
2017-09-21 23:11 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/272b6763698c217f3476b27ed87a98ca13bd4903 [^]
2017-09-21 23:13 shuehner Review Assigned To => alostale
2017-09-21 23:13 shuehner Fixed in Version => 3.0PR17Q4
2017-09-22 10:20 alostale Note Added: 0099470
2017-09-22 10:20 alostale Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker