Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036483
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 07. Sales managementmajoralways2017-07-12 12:362017-07-21 08:33
ReporterngarciaView Statuspublic 
Assigned Tocollazoandy4 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q2.2
StatusclosedFix in branchFixed in SCM revisionb743e992b91a
ProjectionnoneETAnoneTarget Version3.0PR17Q2.2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2016-11-18
Regression introduced in release3.0PR17Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/7232cc0b37a99b4ed3f897372b1e97bcb2fe84a5#l10.73 [^]
Triggers an Emergency PackNo
Summary

0036483: Cannot add some sales order lines to goods shipments after upgrading to 3.0PR17Q1 as a modulescript set the order as isdelivered

DescriptionCannot add some sales order lines to goods shipments after upgrading to 3.0PR17Q1 as a modulescript set the order as isdelivered

The problem happens when sum(qtyordered) = sum(qtydelivered)
Steps To ReproduceIn a version previous to 3.0PR17Q1:
   As group admin role:
      Create a sales order
      Add -2 units of a product
      Add 2 units of another product
      Complete it
      Create a Goods Shipment header and check you can select the order in Create Lines From
      Do not select it

   As system admin role:
      Upgrade the instance to 3.0PR17Q1 (or later)
   
   As group admin role:
      Go to Goods Shipment header and check you cannot select the order in Create Lines From
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0036476 closedcollazoandy4 Cannot add some sales order lines to goods shipments after upgrading to 3.0PR17Q1 as a modulescript set the order as isdelivered 

-  Notes
(0098165)
hgbot (developer)
2017-07-21 08:31

Repository: erp/backports/3.0PR17Q2.2
Changeset: b743e992b91abb5717c950bffdc91bde125c7d21
Author: Armaignac <collazoandy4 <at> gmail.com>
Date: Tue Jul 18 11:06:02 2017 -0400
URL: http://code.openbravo.com/erp/backports/3.0PR17Q2.2/rev/b743e992b91abb5717c950bffdc91bde125c7d21 [^]

Fixes issue 36483: Cannot add some sales order lines to goods shipments after
upgrading to 3.0PR17Q1 as a modulescript set the order as isdelivered

Cannot add some sales order lines to goods shipments because the modulescript
set the order as isdelivered when the order contains lines with negative qtyordered
and the sum(qtyordered) = sum(qtydelivered)

Now the update only happend when the order don't have a line where
QTYORDERED <> QTYDELIVERED.

Because the NOT EXISTS change the check to issotrx field now is made in the main
query because a wrong evaluation in the subquery happends when issotrx = 'N' and
NOT EXISTS

---
M src-db/database/model/functions/M_INOUT_POST.xml
M src-util/modulescript/build/classes/org/openbravo/modulescript/UpdateQtyDeliveredData.class
M src-util/modulescript/src/org/openbravo/modulescript/UpdateQtyDelivered_data.xsql
---
(0098168)
vmromanos (developer)
2017-07-21 08:33

Code review + testing OK

- Issue History
Date Modified Username Field Change
2017-07-12 22:19 collazoandy4 Type defect => backport
2017-07-12 22:19 collazoandy4 Target Version => 3.0PR17Q2.2
2017-07-20 16:03 vmromanos Regression level => Production - Confirmed Stable
2017-07-20 16:03 vmromanos Regression date => 2016-11-18
2017-07-20 16:03 vmromanos Regression introduced in release => 3.0PR17Q1
2017-07-20 16:03 vmromanos Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/7232cc0b37a99b4ed3f897372b1e97bcb2fe84a5#l10.73 [^]
2017-07-21 08:31 hgbot Checkin
2017-07-21 08:31 hgbot Note Added: 0098165
2017-07-21 08:31 hgbot Status scheduled => resolved
2017-07-21 08:31 hgbot Resolution open => fixed
2017-07-21 08:31 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR17Q2.2/rev/b743e992b91abb5717c950bffdc91bde125c7d21 [^]
2017-07-21 08:33 vmromanos Review Assigned To => vmromanos
2017-07-21 08:33 vmromanos Note Added: 0098168
2017-07-21 08:33 vmromanos Status resolved => closed
2017-07-21 08:33 vmromanos Fixed in Version => 3.0PR17Q2.2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker