Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036455
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2017-07-11 11:082017-09-21 16:49
ReporterngarciaView Statuspublic 
Assigned Tocollazoandy4 
PriorityurgentResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revision6a599106f399
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036455: Cannot complete a goods shipment if the related sales order line has a stock reservation in draft status

DescriptionCannot complete a goods shipment if the related sales order line has a stock reservation in draft status
Steps To ReproduceAs group admin role:
   Set the Enable Stock Reservations preference to Y

   Log out and log in

   Create a sales order
   Add a product with stock to it
   Complete it
   Click on Manage Stock and reserve it
   Click again on manage stock and remove the reservation
   Go to Stock Reservation window and check a reservation in draft status and related with the sales order line exists
   Create a Goods Shipment header
   Select the previously created sales order in Create Lines From process
   Try to complete the Goods Shipment and check the following error is raised:
      'This action is not supported'

   Go to Stock Reservation window, remove the record in draft status and check you can complete the Goods Shipment now
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
has duplicate defect 0032408 closedcollazoandy4 Reservation header associated to a sales order line should be removed when the line is deleted 

-  Notes
(0098158)
collazoandy4 (developer)
2017-07-20 23:50

Test Plan
 As group admin role:
   Set the Enable Stock Reservations preference to Y
   Log out and log in

   Go to Sales order window and create a new record for Alimentos y Supermercados, S.A bp
     Create a new record in Lines tab:
       Product: Cerveza Ale 0,5L, Ordered Quantity: 10
     Complete the order
     Click on Manage Stock and reserve it
     Check in Stock reservation window a new record was created with
       Product: Cerveza Ale 0,5L, Ordered: 10, Reserverd qty: 10, Released: 0 and related to the orderline
     Click again on manage stock and remove the reservation
     Check the reservation was remove from Stock reservation window
   Go to Goods Shipment window and create a new record for Alimentos y Supermercados, S.A bp
     Select the previously created sales order in Create Lines From process
     Complete the the Goods Shipment and check the no error is raised
(0098220)
hgbot (developer)
2017-07-26 11:27

Repository: erp/devel/pi
Changeset: 6a599106f3992eb33f11feb8024119501f98854b
Author: Armaignac <collazoandy4 <at> gmail.com>
Date: Thu Jul 20 10:41:52 2017 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/6a599106f3992eb33f11feb8024119501f98854b [^]

Fixes issue 36455: Cannot complete a shipment if related to a draft reservation

When a reservation was removed from Manage Reservation process in Sales Order,
the reservation keeps the association with the line and Not support operation
exception was raised because the reservation changes from DR to CL.

Now the Manage Reservation process in Sales Order removes the reservation
if the reservation has no lines.

Also the c_orderline2_trg only closes reservations in CO and HO status.

---
M src-db/database/model/triggers/C_ORDERLINE2_TRG.xml
M src/org/openbravo/common/actionhandler/ManageReservationActionHandler.java
---
(0098221)
aferraz (developer)
2017-07-26 11:28

Code review + Testing OK
(0099285)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-07-11 11:08 ngarcia New Issue
2017-07-11 11:08 ngarcia Assigned To => Triage Finance
2017-07-11 11:08 ngarcia Modules => Core
2017-07-11 11:08 ngarcia Triggers an Emergency Pack => No
2017-07-11 11:08 ngarcia Issue Monitored: networkb
2017-07-11 14:00 aferraz Assigned To Triage Finance => collazoandy4
2017-07-11 16:01 collazoandy4 Status new => scheduled
2017-07-20 23:50 collazoandy4 Note Added: 0098158
2017-07-26 11:27 hgbot Checkin
2017-07-26 11:27 hgbot Note Added: 0098220
2017-07-26 11:27 hgbot Status scheduled => resolved
2017-07-26 11:27 hgbot Resolution open => fixed
2017-07-26 11:27 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/6a599106f3992eb33f11feb8024119501f98854b [^]
2017-07-26 11:28 aferraz Review Assigned To => aferraz
2017-07-26 11:28 aferraz Note Added: 0098221
2017-07-26 11:28 aferraz Status resolved => closed
2017-07-26 11:28 aferraz Fixed in Version => 3.0PR17Q4
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099285
2017-12-26 09:27 vmromanos Relationship added has duplicate 0032408


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker