Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036436
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementminorhave not tried2017-07-06 13:352017-09-21 16:49
ReportershuehnerView Statuspublic 
Assigned ToTriage Finance 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revisionb4290824ae05
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036436: Avoid using Vector<Object> when only single type of data is used in the list (functional part)

DescriptionVector<Object> or any other of Object only make sense when planning to save several types of data inside the list.

When only stores i.e. Strings or objects of some other single class it does not make sense to use Vector<Object>:
- as no benefit
- harder to read + debug
- need extra casts when retrieving data

So this issue is about fixing simple cases which break this.

Note: Cases are selected as:
a.) simply fixable
b.) causing issues in latest release of some external code-checking tool (checkerframework)
Steps To Reproduce-
TagsNo tags attached.
Attached Filesdiff file icon vector-object-functional.diff [^] (20,344 bytes) 2017-07-06 13:39 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0036437 closedshuehner Avoid using Vector<Object> when only single type of data is used in the list (platform part) 

-  Notes
(0097910)
shuehner (administrator)
2017-07-06 13:39

Note: Patch is only compile tested locally.

While all changes are very simple please verify.

Note: I used diamond operator (available since java7) when changing types to simplify code.
(0097954)
hgbot (developer)
2017-07-07 14:03

Repository: erp/devel/pi
Changeset: b4290824ae054a573ce184ec5afc6f71871f609f
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Fri Jul 07 10:43:24 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b4290824ae054a573ce184ec5afc6f71871f609f [^]

Fixed issue 36436: Avoid using Vector<Object> for single type of data

Changeset pushed on Stefan's behalf

---
M modules/org.openbravo.financial.paymentreport/src/org/openbravo/financial/paymentreport/erpCommon/ad_reports/PaymentReport.java
M src/org/openbravo/erpCommon/ad_process/CreateTaxReport.java
M src/org/openbravo/erpCommon/ad_reports/ReportTrialBalance.java
M src/org/openbravo/erpCommon/businessUtility/AccountTree.java
M src/org/openbravo/erpCommon/businessUtility/COAUtility.java
---
(0097956)
vmromanos (developer)
2017-07-07 14:03

Code review OK
(0099250)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-07-06 13:35 shuehner New Issue
2017-07-06 13:35 shuehner Assigned To => Triage Finance
2017-07-06 13:35 shuehner Modules => Core
2017-07-06 13:35 shuehner Triggers an Emergency Pack => No
2017-07-06 13:39 shuehner File Added: vector-object-functional.diff
2017-07-06 13:39 shuehner Note Added: 0097910
2017-07-06 13:44 shuehner Relationship added related to 0036437
2017-07-07 10:38 vmromanos Status new => scheduled
2017-07-07 14:03 hgbot Checkin
2017-07-07 14:03 hgbot Note Added: 0097954
2017-07-07 14:03 hgbot Status scheduled => resolved
2017-07-07 14:03 hgbot Resolution open => fixed
2017-07-07 14:03 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b4290824ae054a573ce184ec5afc6f71871f609f [^]
2017-07-07 14:03 vmromanos Review Assigned To => vmromanos
2017-07-07 14:03 vmromanos Note Added: 0097956
2017-07-07 14:03 vmromanos Status resolved => closed
2017-07-07 14:03 vmromanos Fixed in Version => 3.0PR17Q4
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099250


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker