Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036421
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2017-07-05 17:422019-03-28 14:55
ReporterngarciaView Statuspublic 
Assigned Toalostale 
PriorityhighResolutionfixedFixed in Version3.0PR19Q2
StatusclosedFix in branchFixed in SCM revision674d467c1b3b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036421: Financial Account records are not filtered by name if the filter contains "-"

DescriptionFinancial Account records are not filtered by name if the filter contains "-"
Steps To ReproduceAs group admin role:
   Go to Financial Account window
   Check the following records exist on it:
      Bank - Account 1
      Bank - Account 2
   Select Bank - Account 2, right click on it and Use as filter
   Check both accounts are shown
   If the problem is not reproducible, clean the filters with the funnel icon, refresh the grid and repeat the process in order to force the call to the server

   Remove the "-" from the filter and check the filter is correctly applied in that case
TagsNo tags attached.
Attached Files? file icon qa-pi-aum-pgsql-AUMRTVd010-build311-text.ParseException __ 29-01-2019 13_05_27.avi [^] (2,823,788 bytes) 2019-01-29 17:56

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0020643 closedguilleaer fillters columns does not work when there are records with the character "-" 
related to defect 0025361 closedalostale Unneeded queries when filtering 
related to design defect 0025211 closedAugustoMauch Filter by selected value in FK uses identifier instead of ID 
related to defect 00235303.0MP23 closedmtaal Filtering with a multiple value is not working properly 
has duplicate defect 0039873 closedplatform Filter not working after 'Fund Transfer' Process 
related to defect 0040057 closedmarkmm82 qa-pi-aum and qa-pi-returnto suites fail 

-  Notes
(0097880)
caristu (developer)
2017-07-05 18:06

The problem is on the following line[1]. Following the steps to reproduce when this line is reached the condition is true and the filter value is being split by the "-".

Thus, the query is filtering just by "%Bank%", and the two records matching this are returned.

[1] https://code.openbravo.com/erp/devel/pi/file/b06cf6616ecc/modules/org.openbravo.service.json/src/org/openbravo/service/json/AdvancedQueryBuilder.java#l795 [^]
(0109113)
hgbot (developer)
2019-01-23 13:49

Repository: erp/devel/pi
Changeset: 674d467c1b3b3f30fc083bd34795d5fa84792fe3
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Jan 23 13:40:27 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/674d467c1b3b3f30fc083bd34795d5fa84792fe3 [^]

fixed bug 36421: can't filter compound identifiers using "-" in filter

  When filterin a compound identifier or any property being part of a compound
  identifier using an expression including "-" character, everything after it got
  removed.

  This is no longer necessary as it was includeded at the very beginning when AQB
  didn't include proper joins to the identifiers, now they are included so it is
  not necessary to remove anything from the filter expression.

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/AdvancedQueryBuilder.java
---
(0109114)
hgbot (developer)
2019-01-23 13:49

Repository: erp/devel/pi
Changeset: 31cca65027c8177f32e8164388a50a1dbdcfbe1b
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Jan 23 13:48:18 2019 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/31cca65027c8177f32e8164388a50a1dbdcfbe1b [^]

related to bug 36421: minor code cleanup

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/AdvancedQueryBuilder.java
---
(0109313)
inaki_garcia (reporter)
2019-01-29 17:56

Same issue has arised in the "Return to Vendor Shipment"'s "Pick/Edit Lines" popup since this fix has been applied, which requires
of a more general solution. The jobs failing are qa-pi-aum and qa-pi-returnto, with the AUMRTVd010 and RTVd010 tests respectively,
and both with Postgres and Oracle DBs.

A video has been attached with the execution of build #311 of qa-pi-aum-pgsql. The value '13 - 29-01-2019 - -125.40' is inputted in
the timestamp 05:11, moment at which the value '13' is expected to be filtered.
(0109319)
alostale (developer)
2019-01-30 09:38

It is working as expected, those test cases should be fixed, it is reported as a separate issue 0040057.
(0109441)
caristu (developer)
2019-02-01 15:11

Code reviewed + tested OK.
(0110756)
hudsonbot (developer)
2019-03-28 14:55

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test
(0110757)
hudsonbot (developer)
2019-03-28 14:55

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b2fbc1588df4 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-07-05 17:42 ngarcia New Issue
2017-07-05 17:42 ngarcia Assigned To => platform
2017-07-05 17:42 ngarcia Modules => Core
2017-07-05 17:42 ngarcia Triggers an Emergency Pack => No
2017-07-05 17:42 ngarcia Issue Monitored: networkb
2017-07-05 17:44 ngarcia Steps to Reproduce Updated View Revisions
2017-07-05 17:55 RenateNieuwkoop Issue Monitored: RenateNieuwkoop
2017-07-05 18:00 ngarcia Relationship added related to 0020643
2017-07-05 18:02 caristu Relationship added related to 0025361
2017-07-05 18:06 caristu Note Added: 0097880
2017-07-05 18:07 caristu Relationship added related to 0025211
2017-07-06 09:13 alostale Status new => acknowledged
2019-01-23 13:36 alostale Relationship added has duplicate 0039873
2019-01-23 13:49 hgbot Checkin
2019-01-23 13:49 hgbot Note Added: 0109113
2019-01-23 13:49 hgbot Status acknowledged => resolved
2019-01-23 13:49 hgbot Resolution open => fixed
2019-01-23 13:49 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/674d467c1b3b3f30fc083bd34795d5fa84792fe3 [^]
2019-01-23 13:49 hgbot Checkin
2019-01-23 13:49 hgbot Note Added: 0109114
2019-01-25 09:08 caristu Review Assigned To => caristu
2019-01-25 09:08 caristu Assigned To platform => alostale
2019-01-29 17:56 inaki_garcia Note Added: 0109313
2019-01-29 17:56 inaki_garcia Status resolved => new
2019-01-29 17:56 inaki_garcia Resolution fixed => open
2019-01-29 17:57 inaki_garcia File Added: qa-pi-aum-pgsql-AUMRTVd010-build311-text.ParseException __ 29-01-2019 13_05_27.avi
2019-01-30 09:18 alostale Status new => acknowledged
2019-01-30 09:18 alostale Status acknowledged => scheduled
2019-01-30 09:38 alostale Note Added: 0109319
2019-01-30 09:38 alostale Status scheduled => resolved
2019-01-30 09:38 alostale Resolution open => fixed
2019-01-30 09:38 alostale Relationship added related to 0040057
2019-02-01 14:05 caristu Relationship added related to 0023530
2019-02-01 15:11 caristu Note Added: 0109441
2019-02-01 15:11 caristu Status resolved => closed
2019-02-01 15:11 caristu Fixed in Version => 3.0PR19Q2
2019-03-28 14:55 hudsonbot Checkin
2019-03-28 14:55 hudsonbot Note Added: 0110756
2019-03-28 14:55 hudsonbot Checkin
2019-03-28 14:55 hudsonbot Note Added: 0110757


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker