Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036404
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2017-07-04 17:192017-09-21 16:49
ReporterngarciaView Statuspublic 
Assigned Tocollazoandy4 
PriorityurgentResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revision89e9cb7c60dc
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036404: Numbers in Receivables Aging Schedule and Payables Aging Schedule are exported to Excel as strings

DescriptionNumbers in Receivables Aging Schedule and Payables Aging Schedule are exported to Excel as strings
Steps To ReproduceAs group admin role:
   Go to Receivables Aging Schedule
   Export to Excel
   Open the file and check the number values are exported with an apostrophe

   Go to Payables Aging Schedule
   Export to Excel
   Open the file and check the number values are exported with an apostrophe
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0031710 closedcollazoandy4 Review XLS reports to apply cell type when required 

-  Notes
(0097923)
collazoandy4 (developer)
2017-07-07 02:14

Test Plan
 As F&B International Group role
   Go to Payables Aging Schedule window set As Of Date field to 01-01-2015
     Clic on Export to Excel button
     Open the generated excel document and check that the numbers are no longer exported with an apostrophe
     Close the generated option and set Show Details field to Y
     Clic on Export to Excel button
     Open the generated excel document and check that the numbers are no longer exported with an apostrophe
   Go to Receivables Aging Schedule window set As Of Date field to 01-01-2015
     Clic on Export to Excel button
     Open the generated excel document and check that the numbers are no longer exported with an apostrophe
     Close the generated option and set Show Details field to Y
     Clic on Export to Excel button
     Open the generated excel document and check that the numbers are no longer exported with an apostrophe
     Close the generated option and set Show Doubtful Deb to Y
     Clic on Export to Excel button
     Open the generated excel document and check that the numbers are no longer exported with an apostrophe
     Close the generated option and set Show Details field to N
     Clic on Export to Excel button
     Open the generated excel document and check that the numbers are no longer exported with an apostrophe
(0098023)
hgbot (developer)
2017-07-11 17:48

Repository: erp/devel/pi
Changeset: 33b542f18c2839ac900fb863cc1bfdca6f3d8ef8
Author: Armaignac <collazoandy4 <at> gmail.com>
Date: Mon Jul 10 17:14:46 2017 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/33b542f18c2839ac900fb863cc1bfdca6f3d8ef8 [^]

Fixes issue 36404: Numbers in Receivables Aging Schedule and Payables Aging
Schedule are exported to Excel as strings

The fields defined in jasper report contains a format method call causing the
cell value be of string type

All the format calls was removed and the field now specified the cell value type
and the output format by the jasper patternExpression specification.

---
M src/org/openbravo/erpCommon/ad_reports/AgingScheduleDetailXLS.jrxml
M src/org/openbravo/erpCommon/ad_reports/AgingScheduleDetailXLSDoubtfulDebt.jrxml
M src/org/openbravo/erpCommon/ad_reports/AgingScheduleXLS.jrxml
---
(0098024)
aferraz (developer)
2017-07-11 17:49

Code review + Testing OK
(0098030)
vmromanos (developer)
2017-07-12 08:19
edited on: 2017-07-12 08:25

Reopen as the solution is wrong.

You can't use a fixed pattern because the amount format depends on the concrete instance. For example, some instances have '.' as a decimal separator, and others use the ','.

You must use the AMOUNTFORMAT parameter for amounts and QUANTITYFORMAT for quantities:

Example (from ReportPurchaseOrder.jrxml):
<parameter name="AMOUNTFORMAT" class="java.text.DecimalFormat" isForPrompting="false"/>
<patternExpression><![CDATA[$P{AMOUNTFORMAT}.toPattern()]]></patternExpression>

(0098125)
hgbot (developer)
2017-07-19 11:37

Repository: erp/devel/pi
Changeset: 4ffa25fd381c92edb392fcd3040f65414b5de904
Author: Armaignac <collazoandy4 <at> gmail.com>
Date: Mon Jul 17 12:15:51 2017 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/4ffa25fd381c92edb392fcd3040f65414b5de904 [^]

Fixes issue 36404: Numbers in Receivables Aging Schedule and Payables Aging
Schedule are exported to Excel as strings

The fields defined in jasper report contains a format method call causing the
cell value be of string type

All the format calls was removed and the field now specified the cell value type
and the output format by the jasper patternExpression specification.

---
M src/org/openbravo/erpCommon/ad_reports/AgingScheduleDetailXLS.jrxml
M src/org/openbravo/erpCommon/ad_reports/AgingScheduleDetailXLSDoubtfulDebt.jrxml
M src/org/openbravo/erpCommon/ad_reports/AgingScheduleXLS.jrxml
---
(0098126)
hgbot (developer)
2017-07-19 11:38

Repository: erp/devel/pi
Changeset: 89e9cb7c60dc95656d0ed192d8f99d5411f87b67
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Wed Jul 19 11:38:14 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/89e9cb7c60dc95656d0ed192d8f99d5411f87b67 [^]

Fixes issue 36404: Code review improvements

Replaced new BigDecimal("0") by BigDecimal.ZERO as in the original fix

---
M src/org/openbravo/erpCommon/ad_reports/AgingScheduleDetailXLS.jrxml
M src/org/openbravo/erpCommon/ad_reports/AgingScheduleDetailXLSDoubtfulDebt.jrxml
---
(0098127)
vmromanos (developer)
2017-07-19 11:38

Code review + testing OK
(0099271)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test
(0099278)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test
(0099279)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-07-04 17:19 ngarcia New Issue
2017-07-04 17:19 ngarcia Assigned To => Triage Finance
2017-07-04 17:19 ngarcia Modules => Core
2017-07-04 17:19 ngarcia Triggers an Emergency Pack => No
2017-07-04 17:20 ngarcia Relationship added related to 0031710
2017-07-04 17:20 ngarcia Issue Monitored: networkb
2017-07-04 18:19 aferraz Assigned To Triage Finance => collazoandy4
2017-07-05 22:57 collazoandy4 Status new => scheduled
2017-07-07 02:14 collazoandy4 Note Added: 0097923
2017-07-11 17:48 hgbot Checkin
2017-07-11 17:48 hgbot Note Added: 0098023
2017-07-11 17:48 hgbot Status scheduled => resolved
2017-07-11 17:48 hgbot Resolution open => fixed
2017-07-11 17:48 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/33b542f18c2839ac900fb863cc1bfdca6f3d8ef8 [^]
2017-07-11 17:49 aferraz Review Assigned To => aferraz
2017-07-11 17:49 aferraz Note Added: 0098024
2017-07-11 17:49 aferraz Status resolved => closed
2017-07-11 17:49 aferraz Fixed in Version => 3.0PR17Q4
2017-07-12 08:19 vmromanos Note Added: 0098030
2017-07-12 08:19 vmromanos Status closed => new
2017-07-12 08:19 vmromanos Resolution fixed => open
2017-07-12 08:19 vmromanos Fixed in Version 3.0PR17Q4 =>
2017-07-12 08:25 vmromanos Note Edited: 0098030 View Revisions
2017-07-19 10:22 vmromanos Status new => scheduled
2017-07-19 11:37 hgbot Checkin
2017-07-19 11:37 hgbot Note Added: 0098125
2017-07-19 11:37 hgbot Status scheduled => resolved
2017-07-19 11:37 hgbot Resolution open => fixed
2017-07-19 11:37 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/33b542f18c2839ac900fb863cc1bfdca6f3d8ef8 [^] => http://code.openbravo.com/erp/devel/pi/rev/4ffa25fd381c92edb392fcd3040f65414b5de904 [^]
2017-07-19 11:38 hgbot Checkin
2017-07-19 11:38 hgbot Note Added: 0098126
2017-07-19 11:38 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/4ffa25fd381c92edb392fcd3040f65414b5de904 [^] => http://code.openbravo.com/erp/devel/pi/rev/89e9cb7c60dc95656d0ed192d8f99d5411f87b67 [^]
2017-07-19 11:38 vmromanos Review Assigned To aferraz => vmromanos
2017-07-19 11:38 vmromanos Note Added: 0098127
2017-07-19 11:38 vmromanos Status resolved => closed
2017-07-19 11:38 vmromanos Fixed in Version => 3.0PR17Q4
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099271
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099278
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099279


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker