Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036322
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 03. Procurement managementmajoralways2017-06-23 10:402017-06-26 10:39
ReporterAtulOpenbravoView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q2.1
StatusclosedFix in branchFixed in SCM revisiona4ec1334a4cb
ProjectionnoneETAnoneTarget Version3.0PR17Q2.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2017-01-31
Regression introduced in release3.0PR17Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/c22eb99a6d5c155eec980d7ff3b08990ff849032 [^]
Triggers an Emergency PackNo
Summary

0036322: Create Lines P&E window in Purchase Order does not respond to select other record after selecting any of the record

DescriptionWhen using Create Lines P&E window for selecting products, after selecting any of the record and entering Quantity, window does not respond to select other record. After closing the window and trying to re-open it does not open. Then after it is not possible to even add lines using form or grid view in Lines Tab.
Steps To Reproduce- Login as F&B International Group Admin
- Navigate to Purchase Order window and create record for any business partner.
- Using Create Lines button try to select records from P&E window.
- Enter Quantity.
- Try to select other record.
- Realize that any other record could not selected. Window does not respond.
- Close P&E window.
- Again click on Create Lines.
- Realize that window does not open.
- Try to create line record using Grid or Form view.
- Record cannot be created any more.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0036320 closedcaristu Create Lines P&E window in Purchase Order does not respond to select other record after selecting any of the record 

-  Notes
(0097628)
hgbot (developer)
2017-06-26 08:15

Repository: erp/backports/3.0PR17Q2.1
Changeset: a4ec1334a4cb9377c146fa41d39fcabe68c62152
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Jun 26 08:13:59 2017 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR17Q2.1/rev/a4ec1334a4cb9377c146fa41d39fcabe68c62152 [^]

fixes bug 36322: Create Lines P&E grid gets freezed under some circumstances

  When moving to a record in a P&E leaving the current record without filling all the mandatory fields, the P&E got freezed due to an infinite loop.

  This was caused due to the changes introduced with the fix for the issue 0034824, which prevents to leave the current record if not all the mandatory fields are filled. Being in a P&E grid which does not allow inserts, that change causes an infinite loop in Smartclient. Thi is because the hideInlineEditor flow is never completed, which makes the cellEditMethod being called continuolsy.

  As the change for issue 0034824 was intended for P&E grids in which records can be added, this change ensures that the default action executed in hideInlineEditor are cancelled just for that kind of grids. This allows to keep the behavior fixed on issue 0034824 and fixes the problem for the rest of the P&E grids.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-pick-and-execute-grid.js
---
(0097642)
AugustoMauch (developer)
2017-06-26 10:39

Code reviewed and verified in [1]@a4ec1334a4cb

[1] https://code.openbravo.com/erp/backports/3.0PR17Q2.1 [^]

- Issue History
Date Modified Username Field Change
2017-06-23 11:31 caristu Type defect => backport
2017-06-23 11:31 caristu Target Version => 3.0PR17Q2.1
2017-06-23 16:31 caristu Assigned To platform => caristu
2017-06-26 08:15 hgbot Checkin
2017-06-26 08:15 hgbot Note Added: 0097628
2017-06-26 08:15 hgbot Status scheduled => resolved
2017-06-26 08:15 hgbot Resolution open => fixed
2017-06-26 08:15 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR17Q2.1/rev/a4ec1334a4cb9377c146fa41d39fcabe68c62152 [^]
2017-06-26 08:16 caristu Review Assigned To => inigosanchez
2017-06-26 10:39 AugustoMauch Note Added: 0097642
2017-06-26 10:39 AugustoMauch Status resolved => closed
2017-06-26 10:39 AugustoMauch Fixed in Version => 3.0PR17Q2.1
2017-06-26 10:39 AugustoMauch Review Assigned To inigosanchez => AugustoMauch


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker