Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036272
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementminoralways2017-06-19 11:132017-09-21 16:49
ReportermaiteView Statuspublic 
Assigned Tomarkmm82 
PriorityhighResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revision2db97bde87bf
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036272: "End year close" process is grouping by record_id2 so accounting information is difficult to understand

Description"Closing entry" information is grouped by accounting dimension information (which is right) but it is also grouped by record_id2 information (which is wrong). This is not causing error in calculating the final balance for an account but it difficult to understand numbers shown in general ledger report
Steps To Reproduce1. Register Sales Invoice for "Alimentos y Supermercados". Process and Post it
2. Run "Add payment" process from sales invoice and process payment.
3. Access related Financial Account and post transaction (so invoice is not an open balance)
4. Register Sales Invoice for "Alimentos y Supermercados". Process and Post it (do not register payment so invoice is an open balance)
5. Access "End year close" window and close year
6. Run "General Ledger Report" and realize that 2 lines with description "Closing entry" has been created because process is grouping by record_id2 value
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0097685)
markmm82 (developer)
2017-06-26 22:06
edited on: 2017-07-03 18:52

Test Plan 1:
1. Register Sales Invoice for "Alimentos y Supermercados". Process and Post it
2. Run "Add payment" process from sales invoice and process payment.
3. Access related Financial Account and post transaction (so invoice is not an open balance)
4. Register Sales Invoice for "Alimentos y Supermercados". Process and Post it (do not register payment so invoice is an open balance)
5. Access "End year close" window and close year
6. Run "General Ledger Report" and realize that only 1 line with description "Closing entry" has been created.

(0097809)
hgbot (developer)
2017-07-03 19:39

Repository: erp/devel/pi
Changeset: 2db97bde87bf2e562666d5c6b9b2ad11421e248b
Author: Mark <markmm82 <at> gmail.com>
Date: Mon Jun 26 15:07:39 2017 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/2db97bde87bf2e562666d5c6b9b2ad11421e248b [^]

Fixes issue 36272: "End year close" process is grouping by record_id2

The "End year close" process was grouping by record_id2 so it was making more
difficult to understand numbers shown in general ledger report.

To fix it, all references to RECORD_ID2 were removed from EndYearCloseUtility_data.xsql.

---
M src/org/openbravo/erpCommon/businessUtility/EndYearCloseUtility.java
M src/org/openbravo/erpCommon/businessUtility/EndYearCloseUtility_data.xsql
---
(0097810)
aferraz (developer)
2017-07-03 19:40

Code review + Testing OK
(0099228)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-06-19 11:13 maite New Issue
2017-06-19 11:13 maite Assigned To => Triage Finance
2017-06-19 11:13 maite Modules => Core
2017-06-19 11:13 maite Triggers an Emergency Pack => No
2017-06-19 11:14 maite Issue Monitored: networkb
2017-06-23 20:33 markmm82 Assigned To Triage Finance => markmm82
2017-06-23 20:33 markmm82 Status new => scheduled
2017-06-26 22:06 markmm82 Note Added: 0097685
2017-07-03 18:52 aferraz Note Edited: 0097685 View Revisions
2017-07-03 19:39 hgbot Checkin
2017-07-03 19:39 hgbot Note Added: 0097809
2017-07-03 19:39 hgbot Status scheduled => resolved
2017-07-03 19:39 hgbot Resolution open => fixed
2017-07-03 19:39 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/2db97bde87bf2e562666d5c6b9b2ad11421e248b [^]
2017-07-03 19:40 aferraz Review Assigned To => aferraz
2017-07-03 19:40 aferraz Note Added: 0097810
2017-07-03 19:40 aferraz Status resolved => closed
2017-07-03 19:40 aferraz Fixed in Version => 3.0PR17Q4
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099228


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker