Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036235
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementminoralways2017-06-12 16:332017-09-21 16:49
Reportercollazoandy4View Statuspublic 
Assigned Tocollazoandy4 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revision99f19c555118
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036235: NPE in SL_ProductionPlan_WRPhase_Quantity callout when updating production quantity in Production Plan tab

DescriptionNPE in SL_ProductionPlan_WRPhase_Quantity callout when updating production quantity in Production Plan tab
Steps To ReproduceAs group admin role:
   Create another record in Product window:
      SearchKey/Name: BomProduct
      Bill Of Materials: Y
      Stocked: Yes
      Create a new record in Bill of Materials tab:
         BOM Product: FirstProduct
      Create another record in Bill of Material tab:
         BOM Product: Cerveza Ale 0,5L
      Clic on Verify BOM
   Go to Bill Of Materials Production window and create a new record:
      Name: Issue
      Create a new record in Production Plan tab:
        Product: BomProduct
        Production Quantity: 2
   Check a NPE is shown in the console:
     java.lang.NullPointerException at org.openbravo.erpCommon.ad_callouts.SL_ProductionPlan_WRPhase_Quantity.execute(SL_ProductionPlan_WRPhase_Quantity.java:46)
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0036061 closedcollazoandy4 Bill Of Materials Production is creating an entry in Product - Transactions tab (M_TRANSACTION) for a non stocked product 
has duplicate defect 0029954 closedaferraz NPE while creating a Production Plan in Bill of Materials Production 

-  Notes
(0097742)
collazoandy4 (developer)
2017-06-28 21:05

As group admin role:
   Create a new record in Product window:
      SearchKey/Name: BomProduct
      Bill Of Materials: Y
      Stocked: Yes
      Create another record in Bill of Material tab:
         BOM Product: Cerveza Ale 0,5L
      Clic on Verify BOM
   Go to Bill Of Materials Production window and create a new record:
      Name: Issue
      Create a new record in Production Plan tab:
        Product: BomProduct
        Production Quantity: 2
   Check no error is shown in the console
(0097831)
hgbot (developer)
2017-07-04 12:10

Repository: erp/devel/pi
Changeset: 99f19c55511812c3426c58ed9221596a5539bdde
Author: Armaignac <collazoandy4 <at> gmail.com>
Date: Wed Jun 28 14:43:54 2017 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/99f19c55511812c3426c58ed9221596a5539bdde [^]

Fixes issue 36235: NPE in SL_ProductionPlan_WRPhase_Quantity callout

A NPE is raise when updating production quantity in Production Plan tab because
WorkRequirementOperation is null.

A null check was added to prevent raise the exception.

---
M src/org/openbravo/erpCommon/ad_callouts/SL_ProductionPlan_WRPhase_Quantity.java
---
(0097832)
hgbot (developer)
2017-07-04 12:10

Repository: erp/devel/pi
Changeset: a24ae7e02b62266688a2607081ec60c8d0c77225
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Tue Jul 04 12:09:05 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/a24ae7e02b62266688a2607081ec60c8d0c77225 [^]

Related to issue 36235: Code review improvements

Run callout if strmWRPhase is not empty.

---
M src/org/openbravo/erpCommon/ad_callouts/SL_ProductionPlan_WRPhase_Quantity.java
---
(0097833)
aferraz (developer)
2017-07-04 12:11

Code review + Testing OK
(0099233)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test
(0099234)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-06-12 16:33 collazoandy4 New Issue
2017-06-12 16:33 collazoandy4 Assigned To => Triage Finance
2017-06-12 16:33 collazoandy4 Modules => Core
2017-06-12 16:33 collazoandy4 Triggers an Emergency Pack => No
2017-06-12 19:09 collazoandy4 Relationship added related to 0036061
2017-06-13 09:11 aferraz Summary NPE en el callout SL_ProductionPlan_WRPhase_Quantity, al setear el production quantity en el tab Production Plan => NPE in SL_ProductionPlan_WRPhase_Quantity callout when updating production quantity in Production Plan tab
2017-06-13 09:11 aferraz Description Updated View Revisions
2017-06-28 21:04 collazoandy4 Status new => scheduled
2017-06-28 21:05 collazoandy4 Note Added: 0097742
2017-06-28 21:05 collazoandy4 Assigned To Triage Finance => collazoandy4
2017-07-04 12:10 hgbot Checkin
2017-07-04 12:10 hgbot Note Added: 0097831
2017-07-04 12:10 hgbot Status scheduled => resolved
2017-07-04 12:10 hgbot Resolution open => fixed
2017-07-04 12:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/99f19c55511812c3426c58ed9221596a5539bdde [^]
2017-07-04 12:10 hgbot Checkin
2017-07-04 12:10 hgbot Note Added: 0097832
2017-07-04 12:11 aferraz Review Assigned To => aferraz
2017-07-04 12:11 aferraz Note Added: 0097833
2017-07-04 12:11 aferraz Status resolved => closed
2017-07-04 12:11 aferraz Fixed in Version => 3.0PR17Q4
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099233
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099234
2017-09-28 09:54 aferraz Relationship added has duplicate 0029954


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker