Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036218
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajorhave not tried2017-06-09 11:452017-06-26 12:18
Reporterranjith_qualiantech_comView Statuspublic 
Assigned Toranjith_qualiantech_com 
PrioritynormalResolutionno change requiredFixed in Version
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036218: Receipt Overpayment validation is not working consistently

DescriptionIf the receipt is paid with 2 non-cash payment methods(One configured with "No Overpayment"), its possible to complete the receipt with overpayment in the below case
Steps To ReproduceNote: Credit card is configured as "not overpayment" === 0

1. Having voucher configured to allow change/overpayment
2. Add a product with value 18.90
3. Pay 10 with voucher (allowed to change)
4. pay 10 with credit card (Not allowed change = 0)
5. It is not possible because card is not allowed to overpay
however doing the following
1. Having voucher configured to allow change/overpayment
2. Add a product with value 18.90
3. Pay 10 with credit card (Not allowed change = 0)
4. pay 10 with voucher (allowed to change)
5. You can complete the overpayment because it is assumed by voucher.

In both above scenarios the behavior should be equal
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0097470)
hgbot (developer)
2017-06-19 08:16

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 74530820a0bc85f4ea9ffeea5f00f71fe74b86fc
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Mon Jun 19 11:45:36 2017 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/74530820a0bc85f4ea9ffeea5f00f71fe74b86fc [^]

Related to issue 36218 : Validate overpayment in all receipt payments instead of selected payments

* Validate all non-cash receipt Payments to check the overpayment exists
* Refactored Code

---
M web/org.openbravo.retail.posterminal/js/pointofsale/view/payment.js
---
(0097471)
hgbot (developer)
2017-06-19 08:16

Repository: tools/automation/pi-mobile
Changeset: db180f9139811b10045fce66662f59c49dc50dd7
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Mon Jun 19 11:42:51 2017 +0530
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/db180f9139811b10045fce66662f59c49dc50dd7 [^]

Verifies issue 36218 : Added automated test 'I36218_ValidateOverpaymentWithReceiptPayments'

---
A src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/receipts/I36218_ValidateOverpaymentWithReceiptPayments.java
---
(0097645)
hgbot (developer)
2017-06-26 11:37

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: e2d393c61d4518af6ed7cd2876869cd76bf2f821
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Mon Jun 26 15:04:41 2017 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e2d393c61d4518af6ed7cd2876869cd76bf2f821 [^]

Related to issue 36218 : Backed out changeset due to functionality issue
Backed out changeset: 74530820a0bc

---
M web/org.openbravo.retail.posterminal/js/pointofsale/view/payment.js
---
(0097646)
hgbot (developer)
2017-06-26 11:38

Repository: tools/automation/pi-mobile
Changeset: 6e86373873a64d218d14db14bc0278d04265f489
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Mon Jun 26 15:01:39 2017 +0530
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/6e86373873a64d218d14db14bc0278d04265f489 [^]

Related to issue 36218 : Backed out changeset: db180f913981

---
R src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/receipts/I36218_ValidateOverpaymentWithReceiptPayments.java
---
(0097647)
marvintm (developer)
2017-06-26 12:18

After discussing with the team, we have concluded that finally no change was necessary. It's correct that the overpayment is only checked on the current (last) payment. All changes have been reverted and no further action is needed.

- Issue History
Date Modified Username Field Change
2017-06-09 11:45 ranjith_qualiantech_com New Issue
2017-06-09 11:45 ranjith_qualiantech_com Assigned To => ranjith_qualiantech_com
2017-06-09 11:45 ranjith_qualiantech_com Triggers an Emergency Pack => No
2017-06-16 12:50 ranjith_qualiantech_com Status new => scheduled
2017-06-19 08:16 hgbot Checkin
2017-06-19 08:16 hgbot Note Added: 0097470
2017-06-19 08:16 hgbot Checkin
2017-06-19 08:16 hgbot Note Added: 0097471
2017-06-19 08:18 ranjith_qualiantech_com Status scheduled => resolved
2017-06-19 08:18 ranjith_qualiantech_com Resolution open => fixed
2017-06-26 11:37 hgbot Checkin
2017-06-26 11:37 hgbot Note Added: 0097645
2017-06-26 11:38 hgbot Checkin
2017-06-26 11:38 hgbot Note Added: 0097646
2017-06-26 12:17 marvintm Status resolved => new
2017-06-26 12:17 marvintm Resolution fixed => open
2017-06-26 12:18 marvintm Review Assigned To => marvintm
2017-06-26 12:18 marvintm Note Added: 0097647
2017-06-26 12:18 marvintm Status new => closed
2017-06-26 12:18 marvintm Resolution open => no change required


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker