Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036207
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersminorhave not tried2017-06-08 14:282017-09-21 16:49
ReporteralostaleView Statuspublic 
Assigned Tomarkmm82 
PrioritylowResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revisionf9cb3834e165
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036207: Finance: EntityPersistenceEventObserver validations has a high log level

DescriptionEntity validations created extending EntityPersistenceEventObserver, when the validation fails an exception is thrown, and it is registered in the openbravo log file. These kind of exceptions are functional validations and should not be registered in the openbravo log with a high level
Steps To ReproduceFor example to make fail the validation implemented in org.openbravo.retail.posterminal.event.ProductEventHandler, try to create a product with type "Service" and checked "Show stock". The validation appears and the record cannot be saved. Observe the openbravo log a exception is registered.
Proposed SolutionThe infrastructure does not log anything by default. The problem is some of these observers are throwing OBException, which by default log stack traces.

Candidates to check:

$ find -name *.java | xargs grep "extends.*EntityPersistenceEventObserver" -l | xargs grep OBException -l | sort


== Functional ==
./modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/event/FIN_FinaccTransactionEventListener.java
./modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/event/FIN_PaymentEventListener.java
./modules/org.openbravo.client.application/src/org/openbravo/client/application/event/AcctSchemaEventHandler.java
./modules/org.openbravo.client.application/src/org/openbravo/client/application/event/LocationSettingsHandler.java
./src/org/openbravo/event/ConversionRateEventHandler.java
./src/org/openbravo/event/DocTypeEventHandler.java
./src/org/openbravo/event/GLJournalLineEventHandler.java
./src/org/openbravo/event/InvoiceTaxEventHandler.java
./src/org/openbravo/event/MInOutLineEventHandler.java
./src/org/openbravo/event/OrderDiscountEventHandler.java
./src/org/openbravo/event/PeriodEventHandler.java
./src/org/openbravo/event/ProductAumEventHandler.java
./src/org/openbravo/event/ProductCharacteristicEventHandler.java
./src/org/openbravo/event/ProductEventHandler.java
./src/org/openbravo/event/ProductionLineEventHandler.java
./src/org/openbravo/event/ServiceOrderLineEventHandler.java
./src/org/openbravo/event/ServicePriceRuleRangeEventHandler.java
./src/org/openbravo/event/SimpleGLJournalEventHandler.java
./src/org/openbravo/event/UOMConversionEventHandler.java


== Platform ==
./modules/org.openbravo.client.application/src/org/openbravo/client/application/attachment/AttachmentConfigEventHandler.java
./modules/org.openbravo.client.application/src/org/openbravo/client/application/attachment/AttachmentMetadataEventHandler.java
./modules/org.openbravo.client.application/src/org/openbravo/client/application/event/FieldHandler.java
./modules/org.openbravo.client.application/src/org/openbravo/client/application/event/NoteEventHandler.java
./modules/org.openbravo.client.application/src/org/openbravo/client/application/event/RoleAccessUniqueHandler.java
./modules/org.openbravo.client.application/src/org/openbravo/client/application/event/TableEventHandler.java
./modules/org.openbravo.client.application/src/org/openbravo/client/application/event/TableTreeEventHandler.java
./modules/org.openbravo.client.application/src/org/openbravo/client/application/event/WindowPersonalizationEventHandler.java
./src/org/openbravo/event/ADTableEventHandler.java
./src/org/openbravo/event/ProcessRequestEventHandler.java

== Retail ==
./modules/org.openbravo.mobile.core/src/org/openbravo/mobile/core/servercontroller/MultiServerPreferenceEventHandler.java
./modules/org.openbravo.mobile.core/src/org/openbravo/mobile/core/servercontroller/ServerStateBackgroundEventHandler.java
./modules/org.openbravo.retail.discounts/src/org/openbravo/retail/discounts/event/MOfferEventHandler.java
./modules/org.openbravo.retail.discounts/src/org/openbravo/retail/discounts/event/MOfferProductEventHandler.java
./modules/org.openbravo.retail.posterminal/src/org/openbravo/retail/posterminal/event/ADOrgWarehouseEventHandler.java
./modules/org.openbravo.retail.posterminal/src/org/openbravo/retail/posterminal/event/AppPaymentEventHandler.java
./modules/org.openbravo.retail.posterminal/src/org/openbravo/retail/posterminal/event/PaymentMethodEventHandler.java
./modules/org.openbravo.retail.posterminal/src/org/openbravo/retail/posterminal/event/PaymentMethodTypeEventHandler.java
./modules/org.openbravo.retail.posterminal/src/org/openbravo/retail/posterminal/event/ProductEventHandler.java
./modules/org.openbravo.retail.posterminal/src/org/openbravo/retail/posterminal/event/TerminalTypePaymentMethodEventHandler.java
./modules/org.openbravo.retail.posterminal/src/org/openbravo/retail/posterminal/importprocess/POSImportEntryProcessor.java
./modules/org.openbravo.retail.posterminal/src/org/openbravo/retail/posterminal/PaymentMethodHandler.java
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0036183 closedplatform Platform: EntityPersistenceEventObserver validations has a high log level 
related to design defect 0036527 closedalostale OBException should not log itself by default 
blocks design defect 0036162 acknowledgedplatform clean up openbravo.log 

-  Notes
(0098197)
alostale (developer)
2017-07-24 12:08

After changing default behavior for OBException (0036527), review none of them should be actually logged.
(0098606)
hgbot (developer)
2017-08-23 11:33

Repository: erp/devel/pi
Changeset: f9cb3834e16557fb3e2c2bd62b3aac86b1f39808
Author: Mark <markmm82 <at> gmail.com>
Date: Mon Aug 21 15:43:39 2017 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/f9cb3834e16557fb3e2c2bd62b3aac86b1f39808 [^]

Fixes issue 36207: EntityPersistenceEventObserver validations has high log

Entity validations created extending EntityPersistenceEventObserver, when the
validation fails an exception is thrown, and it is registered in the openbravo
log file. These kind of exceptions are functional validations and should not be
registered in the openbravo log with a high level.

The problem is some of observers are throwing OBException, which by default log
stack traces.

Since 3.0PR17Q4 OBExceptions doesn't logs exceptions with stack trace by default
when a new OBException is thrown, this fix specify the second parameter of
OBException constructor as true to just logs not functional validations.

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/event/FIN_FinaccTransactionEventListener.java
M src/org/openbravo/event/ServiceOrderLineEventHandler.java
---
(0098607)
aferraz (developer)
2017-08-23 11:34

Code review OK
(0099320)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-06-08 14:28 alostale New Issue
2017-06-08 14:28 alostale Assigned To => Triage Finance
2017-06-08 14:28 alostale Modules => Core
2017-06-08 14:28 alostale Triggers an Emergency Pack => No
2017-06-08 14:28 alostale Issue generated from 0036183
2017-06-08 14:28 alostale Relationship added related to 0036183
2017-06-08 14:33 alostale Relationship added blocks 0036162
2017-06-08 14:35 alostale Proposed Solution updated
2017-07-24 12:06 alostale Relationship added related to 0036527
2017-07-24 12:08 alostale Note Added: 0098197
2017-08-07 18:05 markmm82 Assigned To Triage Finance => markmm82
2017-08-07 18:05 markmm82 Status new => scheduled
2017-08-23 11:33 hgbot Checkin
2017-08-23 11:33 hgbot Note Added: 0098606
2017-08-23 11:33 hgbot Status scheduled => resolved
2017-08-23 11:33 hgbot Resolution open => fixed
2017-08-23 11:33 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/f9cb3834e16557fb3e2c2bd62b3aac86b1f39808 [^]
2017-08-23 11:34 aferraz Review Assigned To => aferraz
2017-08-23 11:34 aferraz Note Added: 0098607
2017-08-23 11:34 aferraz Status resolved => closed
2017-08-23 11:34 aferraz Fixed in Version => 3.0PR17Q4
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099320


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker