Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036151
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2017-05-31 13:452017-09-26 15:25
ReportervmromanosView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revisionacafcefbd0ae
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036151: organization selector in process definition don't filter by role's org access

DescriptionThe organization selectors (OBUISEL_Selector Reference) in Process definition don't seem to apply the automatic filter over the role's org access and show by default all the records available in the client.
Steps To ReproduceCreate a new Reference:
* Name = My org
* OBUISEL_Selector Reference
Defined Selector:
* Table = Organization
* Selector Template

Create a new Reference:
* Name = My bp
* OBUISEL_Selector Reference
Defined Selector:
* Table = BusinessPartner
* Selector Template


Create a new Process Definition:
* UI pattern = Report
* Data access level = client/org
* Enter any class
Enter parameter "Organization":
* Mandatory = N
* DBColumnName = "inpAdOrgId" <- this makes other params to be treated as subordinate for it
* OBUISEL_Selector Reference
* Link to "My org"
Enter parameter "Business Partner":
* Mandatory = N
* OBUISEL_Selector Reference
* Link to "My bp"

Create a new menu entry and link it to the process definition.

Add the process definition to role "F&B España - Procurement", which only has access to Spanish organizations.

Login with the role "F&B España - Procurement" and launch the process definition created before
Check organization selector shows all the organization. It's wrong, it should show only spanish orgs
Check business partner selector wrongly shows US business partners in case in organization selector US org is picked.
TagsNo tags attached.
Attached Filespng file icon 36151_role.png [^] (45,840 bytes) 2017-05-31 13:50


png file icon 36151_org.png [^] (24,030 bytes) 2017-05-31 13:50

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0035124 closedinigosanchez Selectors in Process Definition invoked from menu show only records of organizations in the context organization's natural tree 
related to defect 0035401 acknowledgedplatform OBSelectorFilterSelectItem should try to retrieve ad_org_id field 
related to feature request 0033035 closedairaceburu New filters in Purchase Order Report 
related to defect 00365983.0PR17Q4 closedinigosanchez Process Definition for multirecord sets only one organization in filter parameters 
related to defect 0036863 closedcaristu Custom Query Organization selectors information changes depending on the selected organization 
related to defect 0036877 closedaferraz Organization selector in Purchase Order Report should restrict the organizations that can be displayed 
related to defect 00380393.0PR18Q2 closedjarmendariz Organization filtering issues in Process Definition selectors 

-  Notes
(0099104)
hgbot (developer)
2017-09-18 12:30

Repository: erp/devel/pi
Changeset: acafcefbd0ae1c2a35fe8073323ee4f14904432f
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Sep 18 12:28:51 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/acafcefbd0ae1c2a35fe8073323ee4f14904432f [^]

fixes bug 36151: org selector in process definition don't filter by role access

  - When filtering by organization, if the organization (ORG_PARAMETER) if not specified, then filter the results taking into account just the readable organizations of the role
  - When the organization is specified, then add in the filter all the organizations in the natural tree of the specified organization but restrict to those which can be directly (not derived) accessed by the role. In the case of organization selectors, do not apply this criteria but return the readable organizations of the role

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/AdvancedQueryBuilder.java
---
(0099165)
hgbot (developer)
2017-09-20 09:41

Repository: erp/devel/pi
Changeset: 16a1e0e90f6c1eaa8545ef6d026b51da69fdb8c7
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Sep 20 09:21:47 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/16a1e0e90f6c1eaa8545ef6d026b51da69fdb8c7 [^]

related to bug 36151: take into account the access level to include the * org

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/AdvancedQueryBuilder.java
---
(0099166)
caristu (developer)
2017-09-20 09:45

In order to test the issue the new Purchase Order Report[1] can be used.

[1] https://issues.openbravo.com/view.php?id=33035 [^]
(0099405)
hudsonbot (developer)
2017-09-21 16:50

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test
(0099419)
hudsonbot (developer)
2017-09-21 16:50

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test
(0099459)
alostale (developer)
2017-09-22 09:29

reviewed + tested
(0099492)
hgbot (developer)
2017-09-22 14:22

Repository: erp/devel/pi
Changeset: d91644da48fa51a49d2ccb5b8cde8d19179035e3
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Sep 22 14:02:09 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/d91644da48fa51a49d2ccb5b8cde8d19179035e3 [^]

related to issue 36151, 36863: added test case

---
M src-test/src/org/openbravo/test/AllWebserviceTests.java
A src-test/src/org/openbravo/test/datasource/OrganizationSelectorDataSourceTest.java
---
(0099500)
hgbot (developer)
2017-09-22 16:41

Repository: erp/devel/pi
Changeset: fa752d4ed9d1c74ef2628b90edb068b408479afb
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Sep 22 16:22:23 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/fa752d4ed9d1c74ef2628b90edb068b408479afb [^]

related to bug 36151,36863: remove test case from suite due to failure in CI

---
M src-test/src/org/openbravo/test/AllWebserviceTests.java
---
(0099515)
caristu (developer)
2017-09-25 10:34

Repository: erp/devel/pi
Changeset: e638c65868bc
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Sep 25 10:13:24 2017 +0200
URL: https://code.openbravo.com/erp/devel/pi/rev/e638c65868bc [^]

related to issues 36151, 36863 : code review improvements for test case

---
M src-test/src/org/openbravo/test/AllWebserviceTests.java
M src-test/src/org/openbravo/test/datasource/OrganizationSelectorDataSourceTest.java
---
(0099531)
hgbot (developer)
2017-09-25 12:28
edited on: 2017-09-25 12:29

Repository: erp/devel/pi
Changeset: c8c81f25f650ad164d74f0ec8675d0e4f043b54d
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Sep 25 12:08:56 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/c8c81f25f650ad164d74f0ec8675d0e4f043b54d [^]

related to issue 36151: some readable orgs were excluded

  When the _org parameter is set, the organization filter must be the intersection between the natural tree of the specified organization in that parameter and the readable organizations of the context role

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/AdvancedQueryBuilder.java
---

(0099541)
alostale (developer)
2017-09-25 13:11

reviewed + tested
(0099547)
hgbot (developer)
2017-09-25 13:58

Repository: erp/devel/pi
Changeset: 2d57578de53ea9f94d6ce0e49d4e2f4a3ea71bf4
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Sep 25 13:39:52 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/2d57578de53ea9f94d6ce0e49d4e2f4a3ea71bf4 [^]

related to issue 36151: added test case

  Added a new test case to check that the different collections that can be retrieved using the OBContext class are always returned in a new instance.

---
M src-test/src/org/openbravo/test/AllAntTaskTests.java
M src-test/src/org/openbravo/test/AllQuickAntTaskTests.java
M src-test/src/org/openbravo/test/AllTests.java
M src-test/src/org/openbravo/test/AntTaskTests.java
A src-test/src/org/openbravo/test/security/OBContextCollectionsTest.java
---
(0099553)
hudsonbot (developer)
2017-09-25 14:30

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d8fd6d1ecc14 [^]
Maturity status: Test
(0099558)
hudsonbot (developer)
2017-09-25 14:30

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d8fd6d1ecc14 [^]
Maturity status: Test
(0099590)
hudsonbot (developer)
2017-09-26 15:25

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8fa643b4437e [^]
Maturity status: Test
(0099593)
hudsonbot (developer)
2017-09-26 15:25

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8fa643b4437e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-05-31 13:45 vmromanos New Issue
2017-05-31 13:45 vmromanos Assigned To => platform
2017-05-31 13:45 vmromanos Modules => Core
2017-05-31 13:45 vmromanos Triggers an Emergency Pack => No
2017-05-31 13:50 vmromanos File Added: 36151_role.png
2017-05-31 13:50 vmromanos File Added: 36151_org.png
2017-05-31 13:51 vmromanos File Added: 36151_org_tabledir.png
2017-05-31 14:33 alostale Relationship added related to 0035124
2017-06-02 11:22 alostale Summary Selectors in process definition don't filter by role's org access => organization selector in process definition don't filter by role's org access
2017-06-02 11:22 alostale Description Updated View Revisions
2017-06-02 11:22 alostale Steps to Reproduce Updated View Revisions
2017-06-02 11:23 alostale File Deleted: 36151_org_tabledir.png
2017-06-02 11:23 alostale Relationship added related to 0035401
2017-06-02 11:23 alostale Status new => acknowledged
2017-08-10 10:21 alostale Relationship added related to 0036598
2017-09-12 10:09 caristu Assigned To platform => caristu
2017-09-12 10:09 caristu Status acknowledged => scheduled
2017-09-15 09:19 caristu Relationship added related to 0036863
2017-09-18 12:30 hgbot Checkin
2017-09-18 12:30 hgbot Note Added: 0099104
2017-09-18 12:30 hgbot Status scheduled => resolved
2017-09-18 12:30 hgbot Resolution open => fixed
2017-09-18 12:30 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/acafcefbd0ae1c2a35fe8073323ee4f14904432f [^]
2017-09-18 12:31 caristu Review Assigned To => alostale
2017-09-18 12:41 caristu Note Added: 0099105
2017-09-18 12:41 caristu Relationship added related to 0033035
2017-09-18 13:44 caristu Relationship added related to 0036877
2017-09-20 09:41 hgbot Checkin
2017-09-20 09:41 hgbot Note Added: 0099165
2017-09-20 09:44 caristu Note Deleted: 0099105
2017-09-20 09:45 caristu Note Added: 0099166
2017-09-21 16:50 hudsonbot Checkin
2017-09-21 16:50 hudsonbot Note Added: 0099405
2017-09-21 16:50 hudsonbot Checkin
2017-09-21 16:50 hudsonbot Note Added: 0099419
2017-09-22 09:29 alostale Note Added: 0099459
2017-09-22 09:29 alostale Status resolved => closed
2017-09-22 09:29 alostale Fixed in Version => 3.0PR17Q4
2017-09-22 14:22 hgbot Checkin
2017-09-22 14:22 hgbot Note Added: 0099492
2017-09-22 16:41 hgbot Checkin
2017-09-22 16:41 hgbot Note Added: 0099500
2017-09-25 10:34 caristu Note Added: 0099515
2017-09-25 12:28 hgbot Checkin
2017-09-25 12:28 hgbot Note Added: 0099531
2017-09-25 12:28 caristu Status closed => new
2017-09-25 12:28 caristu Resolution fixed => open
2017-09-25 12:28 caristu Fixed in Version 3.0PR17Q4 =>
2017-09-25 12:28 caristu Status new => scheduled
2017-09-25 12:28 caristu Status scheduled => resolved
2017-09-25 12:28 caristu Resolution open => fixed
2017-09-25 12:29 caristu Note Edited: 0099531 View Revisions
2017-09-25 13:11 alostale Note Added: 0099541
2017-09-25 13:11 alostale Status resolved => closed
2017-09-25 13:11 alostale Fixed in Version => 3.0PR17Q4
2017-09-25 13:58 hgbot Checkin
2017-09-25 13:58 hgbot Note Added: 0099547
2017-09-25 14:30 hudsonbot Checkin
2017-09-25 14:30 hudsonbot Note Added: 0099553
2017-09-25 14:30 hudsonbot Checkin
2017-09-25 14:30 hudsonbot Note Added: 0099558
2017-09-26 15:25 hudsonbot Checkin
2017-09-26 15:25 hudsonbot Note Added: 0099590
2017-09-26 15:25 hudsonbot Checkin
2017-09-26 15:25 hudsonbot Note Added: 0099593
2018-03-05 12:57 vmromanos Relationship added related to 0038039


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker