Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036103
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformminorhave not tried2017-05-25 10:162017-06-15 12:22
ReporteralostaleView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q2.1
StatusclosedFix in branchFixed in SCM revisiona71e9f9e791a
ProjectionnoneETAnoneTarget Version3.0PR17Q2.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036103: applying dataset fails if it contains properties not present in the target system

DescriptionIf a dataset contains information for properties that are not present in the instance that is being imported to, it fails.

This situation can occur if Dataset was exported from a version that had that properties but the instance it's imported in is in a different version.

Steps To Reproduce1. Revert patch for 0036092
2. Follow steps in 0036092
Proposed SolutionIn most of the cases those properties are properly defaulted, not relevant or even with null value. It would be better not to fail but just to warn in log and continue.

Note also the opposite case was already correctly ignored: this is, entity in target instance defining some properties the dataset has not because it was exported in a version they didn't exist.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0036097 closedalostale applying dataset fails if it contains properties not present in the target system 

-  Notes
(0097413)
hgbot (developer)
2017-06-15 11:19

Repository: erp/backports/3.0PR17Q2.1
Changeset: a71e9f9e791abe67c3c8787f5cd876a9c1c3f0a0
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Jun 15 11:18:01 2017 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR17Q2.1/rev/a71e9f9e791abe67c3c8787f5cd876a9c1c3f0a0 [^]

fixes issue 36103: dataset fails if it has properties not in target system
  Trying to apply a dataset with information for properties not present in target
  instance failed.

  Now in this case the property is just ignored and the process continues.

---
M src/org/openbravo/dal/xml/XMLEntityConverter.java
---
(0097419)
AugustoMauch (developer)
2017-06-15 12:18

Code reviewed and verified

- Issue History
Date Modified Username Field Change
2017-05-25 12:42 alostale Type defect => backport
2017-05-25 12:42 alostale Target Version => 3.0PR17Q2.1
2017-05-25 12:45 alostale Review Assigned To => caristu
2017-06-15 11:19 hgbot Checkin
2017-06-15 11:19 hgbot Note Added: 0097413
2017-06-15 11:19 hgbot Status scheduled => resolved
2017-06-15 11:19 hgbot Resolution open => fixed
2017-06-15 11:19 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/78f84b2b36fccfcba18ccd75271a2acc436ddb01 [^] => http://code.openbravo.com/erp/backports/3.0PR17Q2.1/rev/a71e9f9e791abe67c3c8787f5cd876a9c1c3f0a0 [^]
2017-06-15 11:19 caristu Assigned To alostale => caristu
2017-06-15 11:19 caristu Review Assigned To caristu => AugustoMauch
2017-06-15 12:18 AugustoMauch Note Added: 0097419
2017-06-15 12:18 AugustoMauch Status resolved => closed
2017-06-15 12:22 AugustoMauch Fixed in Version => 3.0PR17Q2.1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker