Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035862
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Retail Modules] Web POSmajoralways2017-04-27 13:262017-06-19 12:59
ReporterjorgewederagoView Statuspublic 
Assigned Tojorge-garcia 
PriorityurgentResolutionfixedFixed in VersionRR17Q1.2
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget VersionRR17Q1.2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0035862: When applying more than 2 discounts to the same line the information about them is generated wrongly.

DescriptionIf you apply more than 2 discounts to the same line and finish the transaction, if you go to the ERP and check the information related to them you will see that the values are not correctly generated so the information stored in the database is not correct.
Steps To Reproduce1.- In the ERP go to discounts and promotions and generate (for eg) 4 Discretionary Fixed Amount discounts.
2.- In WebPOS buy something and apply all the discounts to it.
3.- Finish the transaction
4.- Go to the ERP to the Sales order window, select the order and line and check the values in Base Gross Unit Price displayed in discounts and promotions.
Proposed SolutionThe following code seems wrong since it applies twice the discounts due accumulators.

base = line.get('price');
        _.forEach(line.get('promotions') || [], function (discount) {
          var discountAmt = discount.actualAmt || discount.amt || 0;
          discount.basePrice = base;
          discount.unitDiscount = OB.DEC.div(discountAmt, line.get('qtyToApplyDisc') || line.get('qty'));
          totalDiscount = OB.DEC.add(totalDiscount, discountAmt);
          base = OB.DEC.sub(base, totalDiscount);
        }, this);
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0035858pi closedjorge-garcia When applying more than 2 discounts to the same line the information about them is generated wrongly. 

-  Notes
(0097406)
jorge-garcia (developer)
2017-06-15 09:51

Fixed by the changeset
https://code.openbravo.com/retail/backports/3.0RR17Q1.2/org.openbravo.retail.posterminal/rev/97ca44ced104 [^]

- Issue History
Date Modified Username Field Change
2017-04-27 13:45 marvintm Type defect => backport
2017-04-27 13:45 marvintm Target Version pi => RR17Q1.2
2017-06-14 08:52 jorge-garcia Assigned To Retail => jorge-garcia
2017-06-15 09:51 jorge-garcia Note Added: 0097406
2017-06-15 09:51 jorge-garcia Status scheduled => resolved
2017-06-15 09:51 jorge-garcia Resolution open => fixed
2017-06-19 12:59 marvintm Review Assigned To => marvintm
2017-06-19 12:59 marvintm Status resolved => closed
2017-06-19 12:59 marvintm Fixed in Version => RR17Q1.2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker