Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035690
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Modules] Remittancemajorhave not tried2017-04-04 17:032017-04-25 19:41
ReporterSandrahuguetView Statuspublic 
Assigned Tomarkmm82 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionbaf30ae1a259
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Regression date
Regression introduced by commit
Regression level
Review Assigned Toaferraz
Regression introduced in release
Summary

0035690: Performance of Select Payments P&E grid should be improved

DescriptionLoad payments P&E grid from select payments process takes around 6s in a hgvol enviroment.
Steps To Reproduce-Login in the ERP
-Go to Remittance
-Create new header
-Click on 'Select Payments', notice that select payments P&E grid takes around 6s in a hgvol enviroment
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0035664 closedmarkmm82 Openbravo ERP Performance of Add Multiple Payments P&E grid should be improved 
related to defect 0024540 closededuardo_Argal Modules The financial account in which is deposited the remittance is wrong 
related to defect 0024583 closedSandrahuguet Modules Protested Payment can not be included in other Remittance using "Select Payments" process 

-  Notes
(0096106)
markmm82 (developer)
2017-04-21 15:42

Test Plan:
-Login in the ERP
-Go to Remittance
-Create new header
-Click on 'Select Payments', notice that select payments P&E grid load substancially faster in a hgvol enviroment
(0096170)
hgbot (developer)
2017-04-25 17:57

Repository: erp/mods/org.openbravo.module.remittance
Changeset: baf30ae1a2596bfb89617bc1bae9d0b092d0be5b
Author: Mark <markmm82 <at> gmail.com>
Date: Thu Apr 20 13:31:50 2017 -0400
URL: http://code.openbravo.com/erp/mods/org.openbravo.module.remittance/rev/baf30ae1a2596bfb89617bc1bae9d0b092d0be5b [^]

Fixes issue 35690: Performance of Select Payments P&E grid should be improved

Load payments P&E grid from select payments process takes around 6s in a hgvol
environment.

To improve the performance was changed the HQL clause to avoid that Hibernate
generates a SQL query with a cross join with the fin_payment table, because the
only reason of ask for the isReceipt value of the payment.

It was improved by including it as a new column isreceipt in the REM_PAYMENT_V
view, and then using it in the HQL.

---
M src-db/database/model/views/REM_PAYMENT_V.xml
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_TAB.xml
---
(0096171)
hgbot (developer)
2017-04-25 17:57

Repository: erp/mods/org.openbravo.module.remittance
Changeset: 8fcf3481d9a8e3a0ce71898d05fc70d504f75a84
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Tue Apr 25 13:48:07 2017 +0200
URL: http://code.openbravo.com/erp/mods/org.openbravo.module.remittance/rev/8fcf3481d9a8e3a0ce71898d05fc70d504f75a84 [^]

Related to issue 35690: Run Synchronize Terminology

---
M src-db/database/sourcedata/AD_COLUMN.xml
---
(0096179)
hgbot (developer)
2017-04-25 19:23

Repository: erp/mods/org.openbravo.module.remittance
Changeset: f4d779cf38af33abc2011f58375d7e4a5b970c25
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Tue Apr 25 19:22:48 2017 +0200
URL: http://code.openbravo.com/erp/mods/org.openbravo.module.remittance/rev/f4d779cf38af33abc2011f58375d7e4a5b970c25 [^]

Related to issue 35690: Fix Select Payments HQL where clause after running ST

---
M src-db/database/sourcedata/AD_TAB.xml
---
(0096180)
hgbot (developer)
2017-04-25 19:41

Repository: erp/mods/org.openbravo.module.remittance
Changeset: 65d612883d6a4172d5ecd20955ff3d798043c7fd
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Tue Apr 25 19:38:52 2017 +0200
URL: http://code.openbravo.com/erp/mods/org.openbravo.module.remittance/rev/65d612883d6a4172d5ecd20955ff3d798043c7fd [^]

Related to issue 35690: Update module version

---
M src-db/database/sourcedata/AD_MODULE.xml
---
(0096181)
aferraz (developer)
2017-04-25 19:41

Code review + Testing OK

- Issue History
Date Modified Username Field Change
2017-04-04 17:03 Sandrahuguet New Issue
2017-04-04 17:03 Sandrahuguet Assigned To => Triage Finance
2017-04-04 17:03 Sandrahuguet Relationship added depends on 0035664
2017-04-04 17:03 Sandrahuguet Relationship deleted depends on 0035664
2017-04-04 17:03 Sandrahuguet Relationship added related to 0035664
2017-04-04 17:04 Sandrahuguet Resolution time => 1493071200
2017-04-04 19:38 aferraz Assigned To Triage Finance => markmm82
2017-04-06 16:24 markmm82 Status new => scheduled
2017-04-11 16:35 aferraz Relationship added related to 0024540
2017-04-11 16:35 aferraz Relationship added related to 0024583
2017-04-21 15:42 markmm82 Note Added: 0096106
2017-04-25 17:57 hgbot Checkin
2017-04-25 17:57 hgbot Note Added: 0096170
2017-04-25 17:57 hgbot Status scheduled => resolved
2017-04-25 17:57 hgbot Resolution open => fixed
2017-04-25 17:57 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/mods/org.openbravo.module.remittance/rev/baf30ae1a2596bfb89617bc1bae9d0b092d0be5b [^]
2017-04-25 17:57 hgbot Checkin
2017-04-25 17:57 hgbot Note Added: 0096171
2017-04-25 17:57 hgbot Checkin
2017-04-25 17:57 hgbot Note Added: 0096172
2017-04-25 18:30 aferraz Review Assigned To => aferraz
2017-04-25 18:30 aferraz Note Added: 0096174
2017-04-25 18:30 aferraz Status resolved => closed
2017-04-25 19:23 hgbot Checkin
2017-04-25 19:23 hgbot Note Added: 0096179
2017-04-25 19:41 hgbot Checkin
2017-04-25 19:41 hgbot Note Added: 0096180
2017-04-25 19:41 aferraz Note Deleted: 0096174
2017-04-25 19:41 aferraz Note Deleted: 0096172
2017-04-25 19:41 aferraz Note Added: 0096181


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker