Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035499
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2017-03-13 19:082017-03-25 01:51
ReportermaiteView Statuspublic 
Assigned Tomcobas 
PriorityurgentResolutionfixedFixed in Version3.0PR17Q2
StatusclosedFix in branchFixed in SCM revision39528c7e2870
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0035499: Currency conversion problem when product is configured as "Book Using Purchase Order Price"

DescriptionPurchase Order's currency is not considered when posting a goods receipt referring product defined as "Book Using Purchase Order Price"
Steps To Reproduce1. Create new price list in MXN currency for "España" organization. Create pricelist version. Add "Telefonia" product and set price of 5
2. Register Purchase Order for "España" organization using previous price list, so document's currency is MXN. Add line with "Telefonia" productm qty=1 and process
3. Register Goods REceipt for "España" organization. Run "Create liens from" process and select rpevious order. Process. Try to post receipt and "Document currency cannot be converted to the Accounting Schema currency."
4. Access Conversion Rate window and define conversion between EUR and USD for document's date and rate=2
5. Access Goods REceipt and realize that you are able to post it and accounting entry is generated using rate=2. This is not correct as no rate defined between MXN and USD is defined. However process is using conversion between EUR and USD which is not correct
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0023061 closededuardo_Argal Goods Receipt accounting is wrong when using breakdown records and product configured as "Book Using Purchase Order Price" 
related to feature request 0022574 closeddmiguelez Add Possibility to Post a Goods Receipt Transaction using Purchase Order Price 
related to defect 0035566 closedmcobas Currency conversion problem in Matched Inv when product is configured as "Book Using Purchase Order Price" 

-  Notes
(0095471)
mcobas (developer)
2017-03-21 14:35

1. Create new Price List in MXN currency for "España" organization.
2. Create Price List Version. Add "Telefonia" Product and set price of 5.
3. Configure "Telefonia" Product as "Expense type" and "Book using Purchase Order price".
4. Register Purchase Order for "España" Organization using previous Price List, so document's currency is MXN.
   4.1 Add line with "Telefonia" productm qty=1 and process.
5. Register Goods Receipt for "España" Organization.
   5.1 Run "Create liens from" process and select previous Order and Process.
   5.2 Run "Post" process.
   5.3 Notice that a message is show: "Document currency cannot be converted to the Accounting Schema currency.".
6. Access Conversion Rate window and define conversion between EUR and USD for document's date and rate=2.
7. Access to the previous Goods Receipt and run "Post" process.
   7.1 Notice that a message is show: "Document currency cannot be converted to the Accounting Schema currency.".
8. Access Conversion Rate window and define conversion between MXN and USD for document's date and rate=2.
9. Access to the previous Goods Receipt and run "Post" process.
10. Notice that open a new screen named "Journal Entries Report" which shows the ledger entries created for the document.
(0095541)
hgbot (developer)
2017-03-23 17:38

Repository: erp/devel/pi
Changeset: 39528c7e28706e6eec2ef6c74302fb54dc54a0c8
Author: Miguel <martencobasmiguel <at> gmail.com>
Date: Mon Mar 20 12:51:51 2017 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/39528c7e28706e6eec2ef6c74302fb54dc54a0c8 [^]

Fixes issue 35499: Currency conversion problem when posting a Goods Receipt.

This problem is caused because when posting a Goods Receipt related to a
Purchase Order and referring product defined as
"Book Using Purchase Order Price", is taking into account the Currency of the
Legal Organization to which Goods Receipt document belongs in exchange
for the Purchase Order.

To correct this error, is takes into account the Currency of the Purchase Order
related with the lines of the Goods Receipt, in the posting process.

---
M src/org/openbravo/erpCommon/ad_forms/DocInOut.java
M src/org/openbravo/erpCommon/ad_forms/DocLineInOut_data.xsql
---
(0095543)
hgbot (developer)
2017-03-23 17:38

Repository: erp/devel/pi
Changeset: b1948c9bd671794f5e2d452694f056d66984b16c
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Thu Mar 23 17:37:27 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/b1948c9bd671794f5e2d452694f056d66984b16c [^]

Related to issue 35499 & Related to issue 35566: Code review improvements

Get currency from order line only in case product is defined as Book Using Purchase Order Price.

---
M src/org/openbravo/erpCommon/ad_forms/DocInOut.java
M src/org/openbravo/erpCommon/ad_forms/DocLineInOut_data.xsql
M src/org/openbravo/erpCommon/ad_forms/DocMatchInv.java
---
(0095545)
aferraz (developer)
2017-03-23 17:40

Code review + Testing OK
(0095574)
hudsonbot (developer)
2017-03-25 01:51

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a169bf5db5fd [^]
Maturity status: Test
(0095576)
hudsonbot (developer)
2017-03-25 01:51

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a169bf5db5fd [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-03-13 19:08 maite New Issue
2017-03-13 19:08 maite Assigned To => Triage Finance
2017-03-13 19:08 maite Modules => Core
2017-03-13 19:08 maite Triggers an Emergency Pack => No
2017-03-13 19:08 maite Issue Monitored: networkb
2017-03-14 17:09 markmm82 Assigned To Triage Finance => mcobas
2017-03-15 17:16 mcobas Status new => scheduled
2017-03-20 10:43 maite Relationship added related to 0035566
2017-03-21 14:35 mcobas Note Added: 0095471
2017-03-23 13:16 aferraz Relationship added related to 0023061
2017-03-23 16:41 aferraz Relationship added related to 0022574
2017-03-23 17:38 hgbot Checkin
2017-03-23 17:38 hgbot Note Added: 0095541
2017-03-23 17:38 hgbot Status scheduled => resolved
2017-03-23 17:38 hgbot Resolution open => fixed
2017-03-23 17:38 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/39528c7e28706e6eec2ef6c74302fb54dc54a0c8 [^]
2017-03-23 17:38 hgbot Checkin
2017-03-23 17:38 hgbot Note Added: 0095543
2017-03-23 17:40 aferraz Review Assigned To => aferraz
2017-03-23 17:40 aferraz Note Added: 0095545
2017-03-23 17:40 aferraz Status resolved => closed
2017-03-23 17:40 aferraz Fixed in Version => 3.0PR17Q2
2017-03-25 01:51 hudsonbot Checkin
2017-03-25 01:51 hudsonbot Note Added: 0095574
2017-03-25 01:51 hudsonbot Checkin
2017-03-25 01:51 hudsonbot Note Added: 0095576


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker