Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035436
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2017-03-06 12:462017-03-15 14:18
ReportermalsasuaView Statuspublic 
Assigned Tojorge-garcia 
PrioritynormalResolutionfixedFixed in VersionRR17Q2
StatusclosedFix in branchFixed in SCM revision63bad4d3013f
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression levelProduction - Confirmed Stable
Regression date2016-01-13
Regression introduced in releaseRR16Q2
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/df9f4b6ce7c2bfa7ec5cfa0379417e054fcf9401 [^]
Triggers an Emergency PackNo
Summary

0035436: WEBPOS Session is expired

Descriptionthe session is expired in WEBPOS although preference "Web POS Session Timeout" is configured with value 0
Steps To Reproducein backend
- preference "Web POS Session Timeout" -> value 0
(change the session timeout of tomcat to 1 minute):
as system administrator:
- window: AD Implementation Mapping:
 . record: Timeout
 . tab: parameter: timeout
    . change from 60 to 1
(compile and restart tomcat)

in WEBPOS:
. do login
(wait 1 minute)
. search a receipt:
message is displayed:
"The connection was restored. However, in the meantime, your session timed out. You must login again now to ensure proper synchronization. Your pending tickets will be saved."

Error: session timeout should not be expired
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0035527RR17Q1.1 closedjorge-garcia WEBPOS Session is expired 
depends on backport 0035528RR16Q4.3 closedjorge-garcia WEBPOS Session is expired 
caused by feature request 0031803RR16Q2 closedranjith_qualiantech_com The terminal auto-lock should have its own preference 

-  Notes
(0095013)
hgbot (developer)
2017-03-15 08:58

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 63bad4d3013f6bb51ddb166252512190085cad1c
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Thu Mar 09 15:17:56 2017 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/63bad4d3013f6bb51ddb166252512190085cad1c [^]

Fixed issue 35436: WEBPOS Session is expired

The solution is to reimplement a request to the backend for WebPOS session.
This request is not done if the preference sessionTimeout is set or the
preference OBPOS_SessionExpiration is set to ‘Y’.

---
M src/org/openbravo/retail/posterminal/term/Terminal.java
M web/org.openbravo.retail.posterminal/js/login/model/login-model.js
---
(0095028)
jorge-garcia (developer)
2017-03-15 12:48

Reopened to create backports

- Issue History
Date Modified Username Field Change
2017-03-06 12:46 malsasua New Issue
2017-03-06 12:46 malsasua Assigned To => Retail
2017-03-06 12:46 malsasua Resolution time => 1489359600
2017-03-06 12:46 malsasua Triggers an Emergency Pack => No
2017-03-06 12:46 malsasua Regression level => Production - Confirmed Stable
2017-03-06 13:35 eugeni Issue Monitored: eugeni
2017-03-08 10:12 jorge-garcia Status new => scheduled
2017-03-08 10:12 jorge-garcia Assigned To Retail => jorge-garcia
2017-03-08 13:31 jorge-garcia Regression date => 2016-01-13
2017-03-08 13:31 jorge-garcia Regression introduced in release => RR16Q2
2017-03-08 13:31 jorge-garcia Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/df9f4b6ce7c2bfa7ec5cfa0379417e054fcf9401 [^]
2017-03-08 13:32 jorge-garcia Relationship added caused by 0031803
2017-03-15 08:58 hgbot Checkin
2017-03-15 08:58 hgbot Note Added: 0095013
2017-03-15 08:58 hgbot Status scheduled => resolved
2017-03-15 08:58 hgbot Resolution open => fixed
2017-03-15 08:58 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/63bad4d3013f6bb51ddb166252512190085cad1c [^]
2017-03-15 12:48 jorge-garcia Note Added: 0095028
2017-03-15 12:48 jorge-garcia Status resolved => new
2017-03-15 12:48 jorge-garcia Resolution fixed => open
2017-03-15 12:50 jorge-garcia Status new => scheduled
2017-03-15 12:51 jorge-garcia Status scheduled => resolved
2017-03-15 12:51 jorge-garcia Fixed in Version => RR17Q2
2017-03-15 12:51 jorge-garcia Resolution open => fixed
2017-03-15 14:18 marvintm Review Assigned To => marvintm
2017-03-15 14:18 marvintm Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker