Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035427
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2017-03-03 12:532017-09-21 16:49
ReporterdmiguelezView Statuspublic 
Assigned Tomarkmm82 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revisionbce3ce144ae4
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0035427: Conversion of Valuation is not correct in Pareto Product Report

DescriptionConversion in Pareto Product Report is not correct.

The conversion of the currencies is not the same as in the Valued Stock Report.
The problem is that the total valuation is converted to the currency today, instead of converting each Transaction in the day it happened
Steps To ReproduceLaunch Pareto Product Report for:
* Org: US
* Currency: EUR

Launch Valued Stock Report for:
* Org: US
* Date: Today
*Currency: EUR

Check that the valuation of the Stock is different between both reports and this is a bug, it must be the same.
TagsNo tags attached.
Attached Filesdiff file icon proposed_fix.diff [^] (1,506 bytes) 2017-03-03 12:53 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0032493 closedvmromanos Pareto Product Report takes too long in an environment with big amount of data 

-  Notes
(0098510)
markmm82 (developer)
2017-08-15 20:02

Test Plan:
As Group Admin
- Launch Pareto Product Report for:
  Org: US
  Currency: EUR

- Launch Valued Stock Report for:
  Org: US
  Date: Today
  Currency: EUR

Check that the valuation of the Stock is the same in both reports.
(0098639)
hgbot (developer)
2017-08-25 08:52

Repository: erp/devel/pi
Changeset: bce3ce144ae4668ad29da2a5c3104395411767e1
Author: Mark <markmm82 <at> gmail.com>
Date: Mon Aug 21 19:09:24 2017 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/bce3ce144ae4668ad29da2a5c3104395411767e1 [^]

Fixes issue 35427: Conversion of Valuation not correct in Pareto Product Report

The conversion of the currencies in Pareto Product Report is not the same as in the
Valued Stock Report. The problem is that the total valuation is converted to the
currency for today, instead of converting each Transaction in the day it happened.

This fix uses the transaction's date instead of the current date to convert
the valuation. Also is grouped by transaction's accounting date to have an homegeneous
behaviour like in CostingUtils.getCurrentValuedStock() and CostAdjustmentUtils.
getValuedStockOnTransactionDate() methods.

---
M src/org/openbravo/erpCommon/ad_reports/ReportParetoProduct_data.xsql
---
(0098644)
aferraz (developer)
2017-08-25 09:13

Code review + Testing OK
(0099326)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-03-03 12:53 dmiguelez New Issue
2017-03-03 12:53 dmiguelez Assigned To => Triage Finance
2017-03-03 12:53 dmiguelez File Added: proposed_fix.diff
2017-03-03 12:53 dmiguelez Modules => Core
2017-03-03 12:53 dmiguelez Triggers an Emergency Pack => No
2017-03-03 12:53 dmiguelez Relationship added related to 0032493
2017-08-07 18:03 markmm82 Assigned To Triage Finance => markmm82
2017-08-07 18:04 markmm82 Status new => scheduled
2017-08-15 20:02 markmm82 Note Added: 0098510
2017-08-25 08:52 hgbot Checkin
2017-08-25 08:52 hgbot Note Added: 0098639
2017-08-25 08:52 hgbot Status scheduled => resolved
2017-08-25 08:52 hgbot Resolution open => fixed
2017-08-25 08:52 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/bce3ce144ae4668ad29da2a5c3104395411767e1 [^]
2017-08-25 09:13 aferraz Review Assigned To => aferraz
2017-08-25 09:13 aferraz Note Added: 0098644
2017-08-25 09:13 aferraz Status resolved => closed
2017-08-25 09:13 aferraz Fixed in Version => 3.0PR17Q4
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099326


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker