Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035384
TypeCategorySeverityReproducibilityDate SubmittedLast Update
design defect[Openbravo ERP] 07. Sales managementmajoralways2017-02-28 16:522017-09-21 16:49
ReporteregoitzView Statuspublic 
Assigned Tomarkmm82 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revisionea7a25da9285
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0035384: Add logs on debug on the costing process and costing migration process to track the time invested on each part

DescriptionIt is needed to have a way to identify the time required to execute each time.
That is a feature to analyze performance problems and make a better diagnosis
Steps To Reproducen/a
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00324583.0PR16Q2 closedmarkmm82 It is necessary to add log information in process executed when Validating Costing Rule 
related to feature request 0024008 newdmiguelez It would be fine to have any kind of information about the evolution of the Costing Migration Process 
related to defect 0036675 closedmarkmm82 [Costing Migration Process]: Transactions related with closing inventory lines do not have an entry in Transaction Cost tab 

-  Notes
(0096480)
aferraz (developer)
2017-05-09 10:34

We can include log in:

Costing Background Process:
- How many transactions have been processed: we already have this info available for debug here.
- How many transactions are pending to process.
- Estimated time to finish the execution based on current numbers: although it is very difficult to estimate the time in costing when working with cost adjustments, we can re-estimate it in each batch of calculated transactions and give at least an approximation.
- What part of the process is being executed at the moment: although costing calculation involves many different java classes, we can add several log to heavier steps (cost adjustments), which are the ones that give more information.
- Show this info in UI: we could add this log to Process Log field inside Process Request window, but I think it's better to have it in openbravo.log file due to the big size of it.

Costing Migration Process:
- What part of the process is being executed at the moment.
(0097794)
hgbot (developer)
2017-07-03 12:44

Repository: erp/devel/pi
Changeset: ea7a25da92859e2d7ee9238ba66c6e6d916f00d6
Author: Mark <markmm82 <at> gmail.com>
Date: Wed Jun 21 16:23:42 2017 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/ea7a25da92859e2d7ee9238ba66c6e6d916f00d6 [^]

Fixes issue 35384: Add logs on costing background and costing migration process

To analyze performance problems and make a better diagnosis was needed to have a
way to identify the time required to execute each process.

To take this feature included into the Costing Background Process and Costing Migration
Process, some logs were added in the most critical parts of the code to log relevant
information of the processing status like:
- How many transactions have been processed.
- How many transactions are pending to process.
- Estimated time to finish the execution based on current numbers.
- What part of the process is being executed at the moment.

---
M src/org/openbravo/costing/CostAdjustmentProcess.java
M src/org/openbravo/costing/CostingAlgorithm.java
M src/org/openbravo/costing/CostingBackground.java
M src/org/openbravo/costing/CostingMigrationProcess.java
---
(0097795)
hgbot (developer)
2017-07-03 12:45

Repository: erp/devel/pi
Changeset: b3da3000ba8d8cbd4101950cfcaddc7600db94f8
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Fri Jun 23 11:25:32 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b3da3000ba8d8cbd4101950cfcaddc7600db94f8 [^]

Related to issue 35384: Code review improvements

---
M src/org/openbravo/costing/CostAdjustmentProcess.java
M src/org/openbravo/costing/CostingBackground.java
M src/org/openbravo/costing/CostingMigrationProcess.java
---
(0097796)
aferraz (developer)
2017-07-03 13:00

Code review + Testing OK
(0097801)
aferraz (developer)
2017-07-03 14:22

Documentation:
http://wiki.openbravo.com/wiki/Costing_Background_and_Costing_Migration_processes_log [^]
(0099224)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test
(0099225)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-02-28 16:52 egoitz New Issue
2017-02-28 16:52 egoitz Assigned To => Triage Finance
2017-02-28 16:52 egoitz Modules => Core
2017-02-28 16:52 egoitz Triggers an Emergency Pack => No
2017-05-08 10:03 aferraz Relationship added related to 0032458
2017-05-09 10:34 aferraz Note Added: 0096480
2017-05-09 12:35 aferraz Relationship added related to 0024008
2017-06-19 18:16 markmm82 Assigned To Triage Finance => markmm82
2017-06-19 18:16 markmm82 Status new => scheduled
2017-07-03 12:44 hgbot Checkin
2017-07-03 12:44 hgbot Note Added: 0097794
2017-07-03 12:44 hgbot Status scheduled => resolved
2017-07-03 12:44 hgbot Resolution open => fixed
2017-07-03 12:44 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ea7a25da92859e2d7ee9238ba66c6e6d916f00d6 [^]
2017-07-03 12:45 hgbot Checkin
2017-07-03 12:45 hgbot Note Added: 0097795
2017-07-03 13:00 aferraz Review Assigned To => aferraz
2017-07-03 13:00 aferraz Note Added: 0097796
2017-07-03 13:00 aferraz Status resolved => closed
2017-07-03 13:00 aferraz Fixed in Version => 3.0PR17Q4
2017-07-03 14:22 aferraz Note Added: 0097801
2017-08-24 10:52 aferraz Relationship added related to 0036675
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099224
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099225


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker