Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035124
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2017-02-01 11:232017-03-15 20:20
ReportervmromanosView Statuspublic 
Assigned Toinigosanchez 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q2
StatusclosedFix in branchFixed in SCM revisionff888dbe2c3a
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0035124: Selectors in Process Definition invoked from menu show only records of organizations in the context organization's natural tree

DescriptionThe selectors inside a Process Definition show only records of organizations in the context organization's natural tree.
This is wrong and they should show any record.
Steps To ReproduceCreate a process definition. UI Pattern = Report
Create a parameter with reference = OBUISEL_Selector Reference, and Reference Search Key = Financial Account Selector
Create a menu entry linked to this process definition.

Login with Openbravo/openbravo, which by default set RegiĆ³n Norte as context organization.
Go to the Process Definition and try to select any record. Only Spanish related Financial accounts are shown (caja and cuenta de banco). This is wrong, it should show all the financial accounts.

Now change the context organization to *.
Go to the Process Definition and try to select any record. Verify all the financial accounts are shown, which is OK.

Now change the context organization to FB US.
Go to the Process Definition and try to select any record. Only US related financial accounts are shown. This is wrong, it should show all the financial accounts.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0035214 closedinigosanchez Dropdowns of multi selector are not opening when included in a process 
related to defect 0035401 acknowledgedplatform OBSelectorFilterSelectItem should try to retrieve ad_org_id field 
related to defect 0036151 closedcaristu organization selector in process definition don't filter by role's org access 
related to defect 00365983.0PR17Q4 closedinigosanchez Process Definition for multirecord sets only one organization in filter parameters 
related to defect 0039441 closedplatform Organization Selector is not showing data from Organization 
blocks feature request 0035130 closedrqueralta Integrate module Cashflow Forecast into Openbravo 3 distribution 

-  Notes
(0093989)
inigosanchez (developer)
2017-02-01 15:27

This issue is not related with DataSourceEntityAccess project.
(0094679)
hgbot (developer)
2017-03-02 10:31

Repository: erp/devel/pi
Changeset: ff888dbe2c3a51c0a28a6512cd8a57d9af5ba27e
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Wed Mar 01 16:25:57 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/ff888dbe2c3a51c0a28a6512cd8a57d9af5ba27e [^]

Fixed issue 35124: Selectors in process def show only records of context org

The problem was that selectors inside a Process Definition show only records of
organizations in the context organization's natural tree. This was wrong because
selector should displayed records filtered by writable organizations and their
natural trees.

In order to fix this problem two changes have been done. On one hand, context
organization is not send anymore from selectors. On the other hand, Advanced
query builder manages properly this situation (selectors that can't send
organization. e.g.Selector in process definition,...).

Now, the problem has been fixed by taking into account writable organizations
instead of context organization.

---
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/templates/application-js.ftl
M modules/org.openbravo.service.json/src/org/openbravo/service/json/AdvancedQueryBuilder.java
M modules/org.openbravo.service.json/src/org/openbravo/service/json/DefaultJsonDataService.java
M modules/org.openbravo.service.json/src/org/openbravo/service/json/JsonConstants.java
M modules/org.openbravo.userinterface.selector/web/org.openbravo.userinterface.selector/js/ob-selector-item.js
---
(0094716)
alostale (developer)
2017-03-03 09:35

code reviewed

Tested with role with access to all orgs and with a role with access to only to Spain branch. When invoking from menu (after 0035130 it can be tested with Cashflow Forecast Report) the expected orgs are displayed, all in unlimted role, only spain ones with limited. When process definition works as a button, it still takes the one from the parent record it was called from.
(0095247)
hudsonbot (developer)
2017-03-15 20:20

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-02-01 11:23 vmromanos New Issue
2017-02-01 11:23 vmromanos Assigned To => platform
2017-02-01 11:23 vmromanos Modules => Core
2017-02-01 11:23 vmromanos Triggers an Emergency Pack => No
2017-02-01 11:25 vmromanos Steps to Reproduce Updated View Revisions
2017-02-01 11:38 inigosanchez Status new => scheduled
2017-02-01 11:38 inigosanchez Assigned To platform => inigosanchez
2017-02-01 14:29 inigosanchez Assigned To inigosanchez => platform
2017-02-01 14:29 inigosanchez Status scheduled => acknowledged
2017-02-01 14:52 vmromanos Relationship added blocks 0035130
2017-02-01 15:27 inigosanchez Note Added: 0093989
2017-02-01 15:27 inigosanchez Description Updated View Revisions
2017-02-06 14:49 inigosanchez Assigned To platform => inigosanchez
2017-02-06 14:49 inigosanchez Status acknowledged => scheduled
2017-02-10 09:09 alostale Relationship added related to 0035214
2017-03-01 17:46 inigosanchez Relationship added related to 0035401
2017-03-02 10:27 inigosanchez Review Assigned To => alostale
2017-03-02 10:31 hgbot Checkin
2017-03-02 10:31 hgbot Note Added: 0094679
2017-03-02 10:31 hgbot Status scheduled => resolved
2017-03-02 10:31 hgbot Resolution open => fixed
2017-03-02 10:31 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ff888dbe2c3a51c0a28a6512cd8a57d9af5ba27e [^]
2017-03-03 09:20 alostale Summary Selectors in Process Definition show only records of organizations in the context organization's natural tree => Selectors in Process Definition invoked from menu show only records of organizations in the context organization's natural tree
2017-03-03 09:35 alostale Note Added: 0094716
2017-03-03 09:35 alostale Status resolved => closed
2017-03-03 09:35 alostale Fixed in Version => 3.0PR17Q2
2017-03-15 20:20 hudsonbot Checkin
2017-03-15 20:20 hudsonbot Note Added: 0095247
2017-05-31 14:33 alostale Relationship added related to 0036151
2017-08-30 12:50 inigosanchez Relationship added related to 0036598
2018-10-11 18:15 JONHM Relationship added causes 0039441
2018-10-16 16:58 caristu Relationship deleted causes 0039441
2018-10-16 16:58 caristu Relationship added related to 0039441


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker