Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035030
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2017-01-23 11:202017-01-23 11:24
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision77df75e01258
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0035030: API change: ADCS is no longer Serializable

DescriptionProject for 0034975, changes scope of ADCS from Session to Application. While session scoped beans require to be Serializable, Application scoped ones don't, therefore ADCS is no longer Serializable.

The risk of this change to create regressions is none, as even it was formally Serializable, in practice, because DAL objects are cached it was not.
Steps To Reproduce-
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks feature request 00349753.0PR17Q2 closedalostale change scope of ADCS to ApplicationScoped 

-  Notes
(0093767)
alostale (developer)
2017-01-23 11:24

incorrect commit message:

Edit Delete Make Private
Repository: erp/devel/api-checks
Changeset: 77df75e012585f8bdbf0bd62e43d92b5911253c8
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Jan 23 11:22:05 2017 +0100
URL: http://code.openbravo.com/erp/devel/api-checks/rev/77df75e012585f8bdbf0bd62e43d92b5911253c8 [^] [^]

fixed issue 34975: change scope of ADCS to ApplicationScoped

---
M java/reference/java.japi.gz
---

- Issue History
Date Modified Username Field Change
2017-01-23 11:20 alostale New Issue
2017-01-23 11:20 alostale Assigned To => platform
2017-01-23 11:20 alostale Modules => Core
2017-01-23 11:20 alostale Triggers an Emergency Pack => No
2017-01-23 11:20 alostale Assigned To platform => alostale
2017-01-23 11:20 alostale Relationship added blocks 0034975
2017-01-23 11:20 alostale Tag Attached: Approved
2017-01-23 11:24 alostale Note Added: 0093767
2017-01-23 11:24 alostale Status new => scheduled
2017-01-23 11:24 alostale Status scheduled => resolved
2017-01-23 11:24 alostale Fixed in SCM revision => http://code.openbravo.com/erp/devel/api-checks/rev/77df75e012585f8bdbf0bd62e43d92b5911253c8 [^]
2017-01-23 11:24 alostale Resolution open => fixed
2017-01-23 11:24 alostale Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker