Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034915
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2017-01-11 12:542017-09-21 16:49
ReporterpsanjuanView Statuspublic 
Assigned Tomarkmm82 
PriorityurgentResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revision8d326d353610
ProjectionnoneETAnoneTarget Version
OSLinux 64 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionProfessional ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0034915: Sales Dimensional Report does not show any value if Organization field is empty.

DescriptionSales Dimensional Report does not show any value if Organization field is empty.
Steps To ReproduceIn livebuilds (pi).
Go to sales order window and create a new one for F&B España, Alimentos y Supermercados business partner dated on current date.
Add a line, select a product and book the order.

Go to Sales Dimensional report and enter below data:
From date = To date = current date
Dimensions = Product
Currency = EUR

Launch the report in HTML format. Verify that a warning is shown saying:
No data has been found. Please ensure that the selected filter options are correct.

Do not change anything in the report but just add F&B España organization.
Launch the report in HTML format.
Verify that sales order just created is shown.

Proposed SolutionReport should be shown regardless a given organization is selected as Organization is not a mandatory filter option.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0098636)
markmm82 (developer)
2017-08-24 15:45

Sales Dimensional Report

Test Plan 1 - Testing sales order created for a legal organization
As Group Admin:
  Go to sales order window and create a new one for F&B España, Alimentos y Supermercados business partner dated on current date.
  Add a line, select a product and book the order.

  Go to Sales Dimensional report and enter below data:
    From date = To date = current date
    Dimensions = Product
    Currency = EUR
    Organization = Empty

  Launch the report in HTML format. Verify that you can't execute it because the organization field is mandatory and can't be empty. Check an error message is shown explaining that and cursor has focused in Organization Field:
    "Error:
     This field is needed and it cannot be blank"


  Do not change anything in the report but just add F&B España organization.
  Launch the report in HTML format.
  Verify that sales order just created is shown again.

  Change in report to * organization.
  Launch the report in HTML format.
  Verify that sales order just created is shown again.

  Select in report España Norte or España Sur organization.
  Launch the report in HTML format.
  Verify that report is empty, and sales order just created is not shown.

  Select in report any organization of F&B US, Inc or its childs.
  Launch the report in HTML format.
  Verify that report is empty, and sales order just created is not shown.



Repeat test on the following dimensional reports and notice they have a similar behaviour:
  Sales Invoice Dimensional Report
  Purchase Dimensional Report
  Goods Receipts Dimensional Report
  Goods Shipment Dimensional Report
  Purchase Invoice Dimensional Report

Sales Invoice Dimensional Report Legacy can't be excecuted in current pi. An error message is shown:
  "You can't use this report because your instance is migrated to new cost engine"
(0098659)
hgbot (developer)
2017-08-25 14:28

Repository: erp/devel/pi
Changeset: 8d326d3536104e80d738fdc14ad19dddf77a7cf2
Author: Mark <markmm82 <at> gmail.com>
Date: Wed Aug 23 12:17:49 2017 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/8d326d3536104e80d738fdc14ad19dddf77a7cf2 [^]

Fixes issue 34915: Dimensional Reports does not show values if Org is empty

When Dimensional Reports were executed did not show any value if Organization field
was empty. When no organization was selected the session's organization and it childs
were taken by default to filter results. It implies that if you had selected a non
legal organization in the session, then reports were ignoring records from it parent
and brothers.

To set homogeneous the behaviour in all these reports, the organization field has been
set as required and different than blank.
When any organization is selected then an error message is shown explaining it.

---
M src/org/openbravo/erpCommon/ad_reports/ReportInvoiceVendorDimensionalAnalysesFilterJR.html
M src/org/openbravo/erpCommon/ad_reports/ReportMaterialDimensionalAnalysesFilterJR.html
M src/org/openbravo/erpCommon/ad_reports/ReportPurchaseDimensionalAnalysesFilterJR.html
M src/org/openbravo/erpCommon/ad_reports/ReportSalesDimensionalAnalyzeJRFilter.html
M src/org/openbravo/erpCommon/ad_reports/ReportShipmentDimensionalAnalyzeJRFilter.html
---
(0098660)
hgbot (developer)
2017-08-25 14:28

Repository: erp/devel/pi
Changeset: 4cfe283d85a70486b0b059ea31e617f6a217791a
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Fri Aug 25 14:18:39 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/4cfe283d85a70486b0b059ea31e617f6a217791a [^]

Related to issue 34915: Set Organization field mandatory in UI

---
M src/org/openbravo/erpCommon/ad_reports/ReportInvoiceVendorDimensionalAnalysesFilterJR.html
M src/org/openbravo/erpCommon/ad_reports/ReportMaterialDimensionalAnalysesFilterJR.html
M src/org/openbravo/erpCommon/ad_reports/ReportPurchaseDimensionalAnalysesFilterJR.html
M src/org/openbravo/erpCommon/ad_reports/ReportSalesDimensionalAnalyzeJRFilter.html
M src/org/openbravo/erpCommon/ad_reports/ReportShipmentDimensionalAnalyzeJRFilter.html
---
(0098661)
aferraz (developer)
2017-08-25 14:30

Code review + Testing OK
(0099331)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test
(0099332)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-01-11 12:54 psanjuan New Issue
2017-01-11 12:54 psanjuan Assigned To => Triage Finance
2017-01-11 12:54 psanjuan Modules => Core
2017-01-11 12:54 psanjuan Triggers an Emergency Pack => No
2017-08-15 20:03 markmm82 Assigned To Triage Finance => markmm82
2017-08-15 20:03 markmm82 Status new => scheduled
2017-08-15 20:04 markmm82 Note Added: 0098511
2017-08-23 18:06 markmm82 Note Deleted: 0098511
2017-08-24 15:45 markmm82 Note Added: 0098636
2017-08-25 14:28 hgbot Checkin
2017-08-25 14:28 hgbot Note Added: 0098659
2017-08-25 14:28 hgbot Status scheduled => resolved
2017-08-25 14:28 hgbot Resolution open => fixed
2017-08-25 14:28 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/8d326d3536104e80d738fdc14ad19dddf77a7cf2 [^]
2017-08-25 14:28 hgbot Checkin
2017-08-25 14:28 hgbot Note Added: 0098660
2017-08-25 14:30 aferraz Review Assigned To => aferraz
2017-08-25 14:30 aferraz Note Added: 0098661
2017-08-25 14:30 aferraz Status resolved => closed
2017-08-25 14:30 aferraz Fixed in Version => 3.0PR17Q4
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099331
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099332


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker