Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034791
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2016-12-20 18:402016-12-23 08:56
ReporterJONHMView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q1
StatusclosedFix in branchFixed in SCM revision6352395146ac
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0034791: Reports are printed with null values when parent Organization's address is empty

DescriptionReports are printed with null values when parent Organization's address is empty
Steps To Reproduce-As F&B Admin role:
1) Open [Organization] window and select record "F&B España, S.A"
2) Switch to "Information" tab and delete the address line.
3) Then, create a new line in the same tab, with address empty and save the record.
4) Open [Sales Order] window and create a new Sales Order (Business Partner: Alimentos y Supermercados S.A.) FOR ORGANIZATION "F&B España - Region Norte"
5) And also create a new line for that Sales Order (Agua sin gas 1L)
6) Finally, press "Print" button of the toolbar. Select "No, just print it" and open the downloaded report.

--> Notice that every numeric value is null
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0092892)
hgbot (developer)
2016-12-21 09:59

Repository: erp/devel/pi
Changeset: 6352395146ac87517192a912da873bb93654495d
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Dec 21 09:57:25 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/6352395146ac87517192a912da873bb93654495d [^]

fixes issue 34791: Null values in reports if parent org address is empty

The standard reports make use of the applyCountryDateFormat and getCountryNumberFormat utility methods to format dates and numbers. These methods obtain the formats from the Location Settings defined for the organization's country whose id is received as parameter.

In case the organization received from this methods does not have a country (address) defined, then these methods were failing silently. Since now, if the organization does not have an address defined properly, these methods are using the default formats.

---
M src/org/openbravo/erpCommon/utility/Utility.java
---
(0092893)
caristu (developer)
2016-12-21 10:08

Note that the standard reports are using the Location Settings of the first legal entity in the natural tree (starting from the document's organization) to format the final document.

In case someone needs to use the Location Settings of the document's organization, then the .jrxml template should be modified.
(0092923)
hudsonbot (developer)
2016-12-21 20:51

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/abc21394bfb8 [^]
Maturity status: Test
(0092961)
alostale (developer)
2016-12-23 08:56

code reviewed + tested

- Issue History
Date Modified Username Field Change
2016-12-20 18:40 JONHM New Issue
2016-12-20 18:40 JONHM Assigned To => platform
2016-12-20 18:40 JONHM Modules => Core
2016-12-20 18:40 JONHM Triggers an Emergency Pack => No
2016-12-21 09:37 alostale Assigned To platform => Triage Finance
2016-12-21 09:43 caristu Assigned To Triage Finance => caristu
2016-12-21 09:59 hgbot Checkin
2016-12-21 09:59 hgbot Note Added: 0092892
2016-12-21 09:59 hgbot Status new => resolved
2016-12-21 09:59 hgbot Resolution open => fixed
2016-12-21 09:59 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/6352395146ac87517192a912da873bb93654495d [^]
2016-12-21 10:08 caristu Note Added: 0092893
2016-12-21 10:08 caristu Review Assigned To => alostale
2016-12-21 20:51 hudsonbot Checkin
2016-12-21 20:51 hudsonbot Note Added: 0092923
2016-12-23 08:56 alostale Note Added: 0092961
2016-12-23 08:56 alostale Status resolved => closed
2016-12-23 08:56 alostale Fixed in Version => 3.0PR17Q1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker