Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033669
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2016-08-10 10:282016-08-30 10:54
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR16Q4
StatusclosedFix in branchFixed in SCM revisioneec30a5fcdf4
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0033669: Unneeded datasource request after opening a window with a summary function on a child tab

DescriptionUnneeded datasource request after opening a window with a summary function on a child tab
Steps To ReproduceHaving the instance active:

1) Go to the [Sales Invoice] window, move to the [Lines] tab and add a summary function for any column of the grid.
2) Close the window
3) Open the [Sales Invoice] window again, and notice that an additional datasource requests is done in order to try to retrieve the value for the summary function added in step 1)
Proposed SolutionThis call should be prevented when opening the window. In this case no record is selected in the header, so this call will never calculate a value.
TagsPerformance
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0033618 closedcaristu Unneeded datasource requests after creating a new record in grid view having summary functions 
related to defect 0033588 closedcaristu Datasource Request done having a summary function with lazy filtering enabled 
related to defect 0033626 closedNaroaIriarte Unneeded datasource request after cancelling a newly created record in grid view having summary functions 

-  Notes
(0088955)
hgbot (developer)
2016-08-10 14:25

Repository: erp/devel/pi
Changeset: eec30a5fcdf4a15290c2a07936ae8e3dcb8cfc2d
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Aug 10 14:24:36 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/eec30a5fcdf4a15290c2a07936ae8e3dcb8cfc2d [^]

fixes issue 33669: Extra DS call after opening window with summaries on subtabs

An unneeded datasource request was being fired after opening a window having summary functions on a child tab. This was caused because the getSummaryRow() is invoked when drawing the window components. If the summaryRow is already generated at this point, the summaries are recalculated by Smartclient.
In this case, the request is not needed, because the summaries in the child tab will never have any value as no record is selected on the parent.
To prevent this extra request, the grid now checks in the getSummaryRow() whether it is located in a child view and in this case, if the parent grid is being loaded, then the request will not be fired.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
---
(0089055)
hudsonbot (developer)
2016-08-11 18:40

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/edaa05b1fb18 [^]
Maturity status: Test
(0089539)
alostale (developer)
2016-08-30 10:52

code reviewed and tested

- Issue History
Date Modified Username Field Change
2016-08-10 10:28 caristu New Issue
2016-08-10 10:28 caristu Assigned To => caristu
2016-08-10 10:28 caristu Modules => Core
2016-08-10 10:28 caristu Triggers an Emergency Pack => No
2016-08-10 10:28 caristu Relationship added related to 0033618
2016-08-10 10:29 caristu Relationship added related to 0033588
2016-08-10 14:25 hgbot Checkin
2016-08-10 14:25 hgbot Note Added: 0088955
2016-08-10 14:25 hgbot Status new => resolved
2016-08-10 14:25 hgbot Resolution open => fixed
2016-08-10 14:25 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/eec30a5fcdf4a15290c2a07936ae8e3dcb8cfc2d [^]
2016-08-10 14:25 caristu Review Assigned To => alostale
2016-08-10 14:25 caristu Issue Monitored: alostale
2016-08-10 14:26 caristu Relationship added related to 0033626
2016-08-11 18:40 hudsonbot Checkin
2016-08-11 18:40 hudsonbot Note Added: 0089055
2016-08-30 10:52 alostale Note Added: 0089539
2016-08-30 10:52 alostale Status resolved => closed
2016-08-30 10:52 alostale Fixed in Version => 3.0PR16Q4
2016-08-30 10:54 alostale Tag Attached: Performance


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker