Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033407
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 04. Warehouse managementcriticalalways2016-06-30 13:452016-07-01 14:30
ReporterVictorVillarView Statuspublic 
Assigned Todmiguelez 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q3
StatusclosedFix in branchFixed in SCM revisionf2a3f94930f2
ProjectionnoneETAnoneTarget Version3.0PR16Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0033407: Not possible to launch the costing background process because manual costing registers

DescriptionNot possible to launch the costing background process because manual costing registers
Steps To ReproduceNot possible to launch the costing background process because manual costing registers

it seems that this statement costing.getInventoryTransaction().XXX fails.

Example:

1) line 407 CostingUtils.java

2) different lines in CostAdjustmentUtils.java

if (costing != null
        && costing.getTotalMovementQuantity() != null
        && (!costingRule.isBackdatedTransactionsFixed() || trx.getMovementDate().after(
            costing.getInventoryTransaction().getMovementDate()))) {

TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00333913.0PR16Q4 closeddmiguelez Not possible to launch the costing background process because manual costing registers 

-  Notes
(0088155)
hgbot (developer)
2016-07-01 14:28

Repository: erp/backports/3.0PR16Q3
Changeset: f2a3f94930f2e3a80338e463446cffe8919c0156
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Fri Jul 01 09:51:44 2016 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR16Q3/rev/f2a3f94930f2e3a80338e463446cffe8919c0156 [^]

Fixes issue 33407: Error in Costing Background due to manual costing records

Do not take into account manually inserted Costing Entries when calculating the current Stock or the current valued Stock.
Also, centralize conditions into one boolean variable.

---
M src/org/openbravo/costing/CostAdjustmentUtils.java
M src/org/openbravo/costing/CostingUtils.java
---
(0088157)
aferraz (developer)
2016-07-01 14:30

Code review + Testing OK

- Issue History
Date Modified Username Field Change
2016-07-01 12:01 aferraz Type defect => backport
2016-07-01 12:01 aferraz Target Version => 3.0PR16Q3
2016-07-01 14:28 hgbot Checkin
2016-07-01 14:28 hgbot Note Added: 0088155
2016-07-01 14:28 hgbot Status scheduled => resolved
2016-07-01 14:28 hgbot Resolution open => fixed
2016-07-01 14:28 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR16Q3/rev/f2a3f94930f2e3a80338e463446cffe8919c0156 [^]
2016-07-01 14:30 aferraz Review Assigned To => aferraz
2016-07-01 14:30 aferraz Note Added: 0088157
2016-07-01 14:30 aferraz Status resolved => closed
2016-07-01 14:30 aferraz Fixed in Version => 3.0PR16Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker