Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032880
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Openbravo ERP] A. Platformminorhave not tried2016-05-06 09:412016-06-17 19:37
ReporterinigosanchezView Statuspublic 
Assigned Toinigosanchez 
PrioritynormalResolutionfixedFixed in Version3.0PR16Q3
StatusclosedFix in branchFixed in SCM revision58bacde3f953
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032880: Instance Activation window should displayed information about WS calls, CU and active POS terminals.

DescriptionInstance Activation window should displayed extra information in an activated instance:
* Number of calls to web services at current day.
* Current concurrent users.
* Active POS terminals.
Steps To Reproduce-
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
duplicate of feature request 0031110 closedplatform It would be nice to be able to check web service calls per day from UI 
related to defect 0032881 closedinigosanchez API change because a method is added. 
related to design defect 0035994 closedcaristu Web service calls should not create ad_session entries being in an instance with unlimited web service calls 

-  Notes
(0086243)
hgbot (developer)
2016-05-06 10:19

Repository: erp/devel/api-checks
Changeset: bdd2ee7c833d74fd77ad93e98745086c0f23a36a
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Fri May 06 10:02:24 2016 +0200
URL: http://code.openbravo.com/erp/devel/api-checks/rev/bdd2ee7c833d74fd77ad93e98745086c0f23a36a [^]

Fixes issue 32881: API change for issue 32880

getAdditionalMessage() method has been added in
ModuleLicenseRestrictions interface.

---
M java/reference/java.japi.gz
---
(0086245)
hgbot (developer)
2016-05-06 10:22

Repository: erp/devel/pi
Changeset: 58bacde3f953c10bb7e8935ac84eaf5d87f586b8
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Fri May 06 10:09:56 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/58bacde3f953c10bb7e8935ac84eaf5d87f586b8 [^]

Fixed issue 32880: Instance Activation window should displayed extra info

Instance Activation window should displayed extra information in an
activated instance:
* Number of calls to web services at current day.
* Current concurrent users.
* Active POS terminals.

---
M src-db/database/sourcedata/AD_MESSAGE.xml
M src/org/openbravo/erpCommon/obps/ActivationKey.java
M src/org/openbravo/erpCommon/obps/ModuleLicenseRestrictions.java
---
(0086246)
hgbot (developer)
2016-05-06 10:23

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 2a2795e0c714edb9802a060aabb2c894b81a02af
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Fri May 06 10:17:09 2016 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/2a2795e0c714edb9802a060aabb2c894b81a02af [^]

Related with issue 32880: Retrieves the number of active pos terminals

Retrieves the number of active pos terminals to be displayed in Instance
Activation window.

---
M src-db/database/sourcedata/AD_MESSAGE.xml
M src/org/openbravo/retail/posterminal/security/POSLicenseRestrictions.java
---
(0086372)
inigosanchez (developer)
2016-05-11 12:26

Added in testlink in [IAI] Information in Activation Instance:
* [IAIa] CU information > [IAIa010] Unlimited CU.
* [IAIa] CU information > [IAIa020] Limited CU.
* [IAIb] WS calls information > [IAIb010] Unlimited WS.
* [IAIb] WS calls information > [IAIb020] Limited WS.
* [IAIc] WebPOS terminals information > [IAIc010] No WebPOS info.
* [IAIc] WebPOS terminals information > [IAIc020] Active WebPOS.
(0086585)
alostale (developer)
2016-05-20 08:01

reviewed: https://docs.google.com/spreadsheets/d/1UVtZYRbl9Vefg_PXm5rnkjyzALghksw6zYGacCkdaWo/edit#gid=0 [^]
(0087527)
hudsonbot (developer)
2016-06-17 19:37

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/0dc7be081b1c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-05-06 09:41 inigosanchez New Issue
2016-05-06 09:41 inigosanchez Assigned To => inigosanchez
2016-05-06 09:41 inigosanchez Modules => Core
2016-05-06 09:41 inigosanchez Triggers an Emergency Pack => No
2016-05-06 09:53 inigosanchez Relationship added related to 0032881
2016-05-06 10:17 inigosanchez Status new => scheduled
2016-05-06 10:19 hgbot Checkin
2016-05-06 10:19 hgbot Note Added: 0086243
2016-05-06 10:22 hgbot Checkin
2016-05-06 10:22 hgbot Note Added: 0086245
2016-05-06 10:22 hgbot Status scheduled => resolved
2016-05-06 10:22 hgbot Resolution open => fixed
2016-05-06 10:22 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/58bacde3f953c10bb7e8935ac84eaf5d87f586b8 [^]
2016-05-06 10:23 hgbot Checkin
2016-05-06 10:23 hgbot Note Added: 0086246
2016-05-08 23:45 inigosanchez Review Assigned To => alostale
2016-05-11 12:26 inigosanchez Note Added: 0086372
2016-05-20 08:01 alostale Note Added: 0086585
2016-05-20 08:01 alostale Status resolved => closed
2016-05-20 08:01 alostale Fixed in Version => 3.0PR16Q3
2016-06-17 19:37 hudsonbot Checkin
2016-06-17 19:37 hudsonbot Note Added: 0087527
2016-11-08 17:00 maite Relationship added duplicate of 0031110
2017-05-18 09:17 caristu Relationship added related to 0035994


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker