Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032695
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Cash upmajoralways2016-04-18 17:132016-05-17 09:49
ReportermalsasuaView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityhighResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision956b855189e8
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionRR16Q1SCM revision 
Review Assigned Tomigueldejuana
Regression levelProduction - QA Approved
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032695: incorrect organization is used when cashup is processed from Errors While Importing window

Descriptionwhen a cashup is processed from Errors While Importing window, the organization used is the organization of user connected, not the organization related to the terminal
Steps To Reproducein backend
. go to Open/close period control
 close the periods to 2016 -> so, the orders and cashups will not be processed and they will be stored in "Errors While Importing" window

in webpos
. do and process a receipt
. do a cashup

in backend (loged with organization *)
. go to Open/close period control
 open the periods to 2016
. go to Errors While Importing window -> previous receipt and cashup are displayed
 process receipt -> it is OK
 process cashup -> error is returned:
org.hibernate.StaleStateException: Batch update returned unexpected row count from update [0]; actual row count: 0; expected: 1
...

The error is returned because the cashup is processed using * organization (organization of user connected) not the organization related to the terminal
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0032790RR16Q2 closedranjith_qualiantech_com incorrect organization is used when cashup is processed from Errors While Importing window 
depends on backport 0032791RR16Q1.2 closedranjith_qualiantech_com incorrect organization is used when cashup is processed from Errors While Importing window 

-  Notes
(0086072)
hgbot (developer)
2016-04-29 11:49

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 956b855189e810632e1723dcc95df5e616788f7b
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Fri Apr 29 15:18:49 2016 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/956b855189e810632e1723dcc95df5e616788f7b [^]

Fixes issue 32695 : Adding Organization info to Cashup data while processing cash close

Organization info added to Cashup Info in Cashup Model "objToSend", So it will be accessed during cash close process

---
M web/org.openbravo.retail.posterminal/js/utils/cashUpReportUtils.js
---
(0086486)
migueldejuana (developer)
2016-05-17 09:49

Tested and reviewed in ec98fed2ca51

- Issue History
Date Modified Username Field Change
2016-04-18 17:13 malsasua New Issue
2016-04-18 17:13 malsasua Assigned To => Retail
2016-04-18 17:13 malsasua Regression level => Production - QA Approved
2016-04-18 17:13 malsasua Triggers an Emergency Pack => No
2016-04-18 19:57 eugeni Issue Monitored: eugeni
2016-04-19 18:59 Orekaria Status new => acknowledged
2016-04-26 16:12 Orekaria Status acknowledged => scheduled
2016-04-26 16:12 Orekaria Assigned To Retail => ranjith_qualiantech_com
2016-04-29 11:49 hgbot Checkin
2016-04-29 11:49 hgbot Note Added: 0086072
2016-04-29 11:49 hgbot Status scheduled => resolved
2016-04-29 11:49 hgbot Resolution open => fixed
2016-04-29 11:49 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/956b855189e810632e1723dcc95df5e616788f7b [^]
2016-05-17 09:49 migueldejuana Review Assigned To => migueldejuana
2016-05-17 09:49 migueldejuana Note Added: 0086486
2016-05-17 09:49 migueldejuana Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker