Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032563
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSminoralways2016-03-31 12:402016-06-04 11:48
ReporterxabiermerinoView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityhighResolutionfixedFixed in VersionRR16Q3
StatusclosedFix in branchFixed in SCM revision24f900d3a01c
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomigueldejuana
Regression levelProduction - Confirmed Stable
Regression date2015-07-03
Regression introduced in releaseRR15Q4
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/464633dd387fd0cd4fb468d2bd62b368f5170b34 [^]
Triggers an Emergency PackNo
Summary

0032563: [SERQA 861] JS Error when you do an initial count without Cash payment method

DescriptionIf you configurate a POS Terminal withou payment method of Cash type an JS error appears when you execute an Initial Count
Steps To Reproduce*** Reproduced in Retail with modules
0.- Log into Web POS with vallblanca user and do a Cash Up
1.- As Openbravo Admin go to the backend (live builds)
2.- Go to POS Terminal Type and select VBS POS Terminal
3.- Go to Payment Method tab and select USA Cash
4.- Uncheck Cash field
5.- Go to Preference window and create a new one:
    5.1.- Property: Web POS payment Cash
    5.2.- Value: N
    5.3.- Client: White valley group
    5.4.- Organization: Vall Blanca Store
    5.5.- User: Vall Blanca Store User
6.- Log into Web POS with vallblanca user and try to do an Initial Count
TagsSER-QA
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0030551 closedjorge-garcia It is not possible to login in a terminal without payment methods defined 
depends on backport 0033110RR16Q2 closedjorge-garcia [SERQA 861] JS Error when you do an initial count without Cash payment method 
depends on backport 0033111RR16Q1.3 closedjorge-garcia [SERQA 861] JS Error when you do an initial count without Cash payment method 
caused by defect 0029463RR15Q4 closedjorge-garcia It is possible to give change or pay a return ticket if there is no cash available 

-  Notes
(0085478)
hgbot (developer)
2016-04-07 10:51

Repository: tools/automation/pi-mobile
Changeset: 0678bad9c1358943f0f1e86d1092d7fb71ec6e07
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Thu Apr 07 14:20:14 2016 +0530
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/0678bad9c1358943f0f1e86d1092d7fb71ec6e07 [^]

Verifies issue 32563 : Added automated test 'I32563_CheckPaymentWhileLoading'

---
A src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/system/I32563_CheckPaymentWhileLoading.java
---
(0085479)
hgbot (developer)
2016-04-07 10:51

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 24f900d3a01c8e8c0a790cff7ce1af6d2048e078
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Thu Apr 07 14:20:43 2016 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/24f900d3a01c8e8c0a790cff7ce1af6d2048e078 [^]

Fixes issue 32563 : Validating payment while checking Valid Payments

---
M web/org.openbravo.retail.posterminal/js/pointofsale/view/payment.js
---
(0085760)
ranjith_qualiantech_com (developer)
2016-04-20 08:08

Reg. fix,
in payment.js, checkValidPayments fn(), return variable "returnCheck" has been added. This variable is used to find whether validation (checkValidCashOverpayment, checkEnoughCashAvailable, checkValidPaymentMethod) are completed or not
(0085775)
migueldejuana (developer)
2016-04-20 12:18

Tested and reviewed
(0086912)
jorge-garcia (developer)
2016-06-02 12:42

Reopened because this is finally a regression. Must be created backports
(0086913)
jorge-garcia (developer)
2016-06-02 12:45

Backports had been created. Closing this issue

- Issue History
Date Modified Username Field Change
2016-03-31 12:40 xabiermerino New Issue
2016-03-31 12:40 xabiermerino Assigned To => Retail
2016-03-31 12:40 xabiermerino Resolution time => 1460671200
2016-03-31 12:40 xabiermerino Triggers an Emergency Pack => No
2016-03-31 12:41 xabiermerino Tag Attached: SER-QA
2016-03-31 13:43 agete Summary JS Error when you do an initial count without Cash payment method => [SERQA 861] JS Error when you do an initial count without Cash payment method
2016-04-04 14:36 Orekaria Status new => acknowledged
2016-04-05 12:27 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2016-04-05 12:27 ranjith_qualiantech_com Status acknowledged => scheduled
2016-04-07 10:51 hgbot Checkin
2016-04-07 10:51 hgbot Note Added: 0085478
2016-04-07 10:51 hgbot Checkin
2016-04-07 10:51 hgbot Note Added: 0085479
2016-04-07 10:51 hgbot Status scheduled => resolved
2016-04-07 10:51 hgbot Resolution open => fixed
2016-04-07 10:51 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/24f900d3a01c8e8c0a790cff7ce1af6d2048e078 [^]
2016-04-20 08:08 ranjith_qualiantech_com Note Added: 0085760
2016-04-20 12:18 migueldejuana Review Assigned To => migueldejuana
2016-04-20 12:18 migueldejuana Note Added: 0085775
2016-04-20 12:18 migueldejuana Status resolved => closed
2016-06-02 10:00 guillermogil Relationship added related to 0030551
2016-06-02 12:42 jorge-garcia Note Added: 0086912
2016-06-02 12:42 jorge-garcia Status closed => new
2016-06-02 12:42 jorge-garcia Resolution fixed => open
2016-06-02 12:43 jorge-garcia Regression level => Production - Confirmed Stable
2016-06-02 12:43 jorge-garcia Regression date => 2015-07-03
2016-06-02 12:43 jorge-garcia Regression introduced in release => RR15Q4
2016-06-02 12:43 jorge-garcia Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/464633dd387fd0cd4fb468d2bd62b368f5170b34 [^]
2016-06-02 12:44 jorge-garcia Status new => scheduled
2016-06-02 12:45 jorge-garcia Status scheduled => resolved
2016-06-02 12:45 jorge-garcia Fixed in Version => RR16Q3
2016-06-02 12:45 jorge-garcia Resolution open => fixed
2016-06-02 12:45 jorge-garcia Note Added: 0086913
2016-06-02 12:45 jorge-garcia Status resolved => closed
2016-06-02 12:58 dmitry_mezentsev Relationship added caused by 0029463
2016-06-04 11:48 dmitry_mezentsev Severity major => minor


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker