Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032292
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2016-02-19 13:152016-03-17 10:56
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR16Q2
StatusclosedFix in branchFixed in SCM revisione408f8f90401
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032292: "OBSERDS_RoleHasNoFieldAccess" error thrown with specific role definition in Field tab

DescriptionIf you define a role with NO access to the Field tab (in Windows, Tabs and Field window) but access to an specific field, the following error is thrown when trying to save the edition:
"Saving failed. ***role*** does not have access to the field Creation Date"
Steps To Reproduce1. Create a System Admin manual role
2. Give read only access to Windows Tabs And Fields > Field
3. Give edit access to Description field
4. Using that role
5. Open any existing Window
6. Edit description for any field where Record Sort No. is empty and save
Proposed SolutionThe problem is caused because the Field tab has a field for the Creation audit column. This field should be removed as audit columns should not have a field in the AD. They are generated automatically.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00322313.0PR16Q2 closedcaristu "OBSERDS_RoleHasNoFieldAccess" error thrown with specific role definition and Total Gross Amount with no decimals 
related to defect 0032354 closedalostale field edit access doesn't allow to save if tab contains audit fields in its AD definition 

-  Notes
(0084369)
hgbot (developer)
2016-02-19 13:23

Repository: erp/devel/pi
Changeset: e408f8f90401413e81fc2e1be92a997d189deffc
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Feb 19 13:22:52 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e408f8f90401413e81fc2e1be92a997d189deffc [^]

fixes issue 32292: access error in Field tab with specific role when saving

The problem is caused because the Field tab has a field for the Creation audit column. This field should be removed as audit columns should not have a field in the AD. They are generated automatically.

---
M src-db/database/sourcedata/AD_FIELD.xml
---
(0084375)
hgbot (developer)
2016-02-19 14:34

Repository: erp/devel/api-checks
Changeset: deb4aa37c11c54741b5e91e0b69d9e7d40dc9c93
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Feb 19 14:32:15 2016 +0100
URL: http://code.openbravo.com/erp/devel/api-checks/rev/deb4aa37c11c54741b5e91e0b69d9e7d40dc9c93 [^]

related to issue 32292: remove 'Creation Date' field of 'Field' tab

---
M model/src-db/database/sourcedata/AD_FIELD.xml
---
(0084540)
alostale (developer)
2016-02-26 09:07

code reviewed


Though the changeset is correct and it's not necessary to explicitly define audit fields in tabs because they are generated in any case and it fix the described problem for this concrete window, a more generic fix has also been implemented in 0032354 to prevent this error to be thrown for any tab in this situation without the need of removing audit fields from AD nor granting edit access to them.
(0084990)
hgbot (developer)
2016-03-15 15:52

Repository: erp/devel/api-checks
Changeset: c87271eab9e7d697c09182f58490b8ee34843833
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Mar 15 15:51:28 2016 +0100
URL: http://code.openbravo.com/erp/devel/api-checks/rev/c87271eab9e7d697c09182f58490b8ee34843833 [^]

related to issue 32292: remove 'Creation Date' field of 'Field' tab

---
M model/src-db/database/sourcedata/AD_FIELD.xml
---
(0085158)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-02-19 13:15 caristu New Issue
2016-02-19 13:15 caristu Assigned To => caristu
2016-02-19 13:15 caristu Modules => Core
2016-02-19 13:15 caristu Triggers an Emergency Pack => No
2016-02-19 13:16 caristu Relationship added related to 0032231
2016-02-19 13:23 hgbot Checkin
2016-02-19 13:23 hgbot Note Added: 0084369
2016-02-19 13:23 hgbot Status new => resolved
2016-02-19 13:23 hgbot Resolution open => fixed
2016-02-19 13:23 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e408f8f90401413e81fc2e1be92a997d189deffc [^]
2016-02-19 13:24 caristu Review Assigned To => alostale
2016-02-19 13:24 caristu Issue Monitored: alostale
2016-02-19 14:34 hgbot Checkin
2016-02-19 14:34 hgbot Note Added: 0084375
2016-02-26 08:54 alostale Relationship added related to 0032354
2016-02-26 09:07 alostale Note Added: 0084540
2016-02-26 09:07 alostale Status resolved => closed
2016-02-26 09:07 alostale Fixed in Version => 3.0PR16Q2
2016-03-15 15:52 hgbot Checkin
2016-03-15 15:52 hgbot Note Added: 0084990
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085158


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker