Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032287
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2016-02-19 10:562016-03-17 10:56
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR16Q2
StatusclosedFix in branchFixed in SCM revision02db9cb1d672
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032287: Selection can be lost in P&E grids having an amount of data higher than the page size

DescriptionSelection can be lost in P&E grids having an amount of data higher than the page size.

Smartclient has an internal mechanism that tries to retrieve the records surrounding the last clicked record, when the grid is refreshed.

This affects pick and edit grids which should always return all the selected records after every refresh.
Steps To Reproduce1) Using an environment with big amount of data. Go to the [Payment In] window and launch Add Details process.
2) Select the first record
3) Scroll down to request a new page and select a record of the new page.
4) Enter a filter criteria to refresh the grid. Notice that the request is using a startRow different from 0. This is because the mechanism mentioned in Description. Notice that the selection of the first selected record is lost.

This also can cause the filtering criteria to return not expected records.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0032193 closedcaristu Selection is not working properly in P&E grids having filter on change option set to N 
related to design defect 0036140 newplatform Pick/edit grid is not compatible with high volumes: number of selected records is limited by MAX_PAGE_SIZE_INCREASE 

-  Notes
(0084352)
hgbot (developer)
2016-02-19 11:23

Repository: erp/devel/pi
Changeset: 02db9cb1d67259dd5da09cfa754d9f8f2406ce2f
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Feb 19 11:21:21 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/02db9cb1d67259dd5da09cfa754d9f8f2406ce2f [^]

fixes issue 32287: Selection can be lost in P&E grids under some circumstances

If we refresh the grid, after selecting a record in a page different from the first one, Smartclient internally prepares the request to retrieve the records surrounding the selected one, in order to try to keep the position of the scroll.

This behavior in P&E can cause the losing of the selected records, because they are always loaded on the first page. In order to prevent this, we detect this situation in P&E grids before performing the request, and in that case we adapt it to force the retrieval of the first page which contains all the selected records.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-pick-and-execute-grid.js
---
(0084547)
alostale (developer)
2016-02-26 09:43

code reviewed + tested
(0085152)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-02-19 10:56 caristu New Issue
2016-02-19 10:56 caristu Assigned To => caristu
2016-02-19 10:56 caristu Modules => Core
2016-02-19 10:56 caristu Triggers an Emergency Pack => No
2016-02-19 11:12 caristu Steps to Reproduce Updated View Revisions
2016-02-19 11:23 hgbot Checkin
2016-02-19 11:23 hgbot Note Added: 0084352
2016-02-19 11:23 hgbot Status new => resolved
2016-02-19 11:23 hgbot Resolution open => fixed
2016-02-19 11:23 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/02db9cb1d67259dd5da09cfa754d9f8f2406ce2f [^]
2016-02-19 11:23 caristu Relationship added related to 0032193
2016-02-19 11:28 caristu Review Assigned To => alostale
2016-02-19 11:28 caristu Issue Monitored: alostale
2016-02-26 09:43 alostale Note Added: 0084547
2016-02-26 09:43 alostale Status resolved => closed
2016-02-26 09:43 alostale Fixed in Version => 3.0PR16Q2
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085152
2017-05-30 17:07 maite Relationship added related to 0036140


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker