Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032243
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSminoralways2016-02-15 22:042019-02-06 15:35
ReporterageteView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityhighResolutionfixedFixed in VersionRR16Q2
StatusclosedFix in branchFixed in SCM revisiondadadb16b004
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032243: [SERQA 692] Javscript error when adding a manual discount

Description"Promotion and Discount: If we insert a manual amount discount without pressing ENTER or Discount, WE get a javascript error.

Steps To Reproduce1. In backend create a Discount and promotion woth the following information:
- Org: *
- Discount/promotion type: User Defined Amount
- Name: Amount discount
- Starting date: 1/2/2016
Leave the other fields as thy are by default
2. In web POS create a receipt and add the product "headlamp ultralight"
3. In menu select the option Receipt discounts
4. In payment pannel select the option Amount discount
5. Check both options,
Override existing promotions
Apply to all lines
6. Click amount 12 (without pressing the button DISCOUNT or ENTER)
7. Click the button APPLY
ERROR--> a javascript error appears
Proposed SolutionInstead of the javascript error, we should have a Error message saying por example: "you must click enter or DISCOUNT before APPLY button in order to add the discount to the receipt"
TagsSER-QA
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0032325RR16Q1 closedranjith_qualiantech_com [SERQA 692] Javscript error when adding a manual discount 
depends on backport 0032326RR15Q4.5 closedjorge-garcia [SERQA 692] Javscript error when adding a manual discount 
has duplicate defect 0032303 closedRetail Variable discretionary discounts with no defined percent raise an error to the user 

-  Notes
(0084365)
hgbot (developer)
2016-02-19 12:59

Repository: tools/automation/pi-mobile
Changeset: 14eb69c3773ce1c4af87e497761c4fd219f8f7b1
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Fri Feb 19 17:28:45 2016 +0530
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/14eb69c3773ce1c4af87e497761c4fd219f8f7b1 [^]

Verifies issue 32243: Added automated test 'I32243_VerifyProductDiscountWithVariableAmount'

---
M src-test/org/openbravo/test/mobile/common/selenium/javascript/TestId.java
A src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/discountsandpromotions/I32243_VerifyProductDiscountWithVariableAmount.java
---
(0084366)
hgbot (developer)
2016-02-19 12:59

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 94638e56e37bc53643b40c083e5866b59792139b
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Fri Feb 19 17:29:02 2016 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/94638e56e37bc53643b40c083e5866b59792139b [^]

Fixes issue 32243 : Validating Variable Discount Amount before applying to receipt

---
M web/org.openbravo.retail.posterminal/js/pointofsale/view/ticketdiscount.js
---
(0084481)
guillermogil (manager)
2016-02-25 08:09

requiresQty property is set to true only on variable discounts.
Instead of removing it on the if filter it is needed to review why it is set to false on those cases.
(0084521)
ranjith_qualiantech_com (developer)
2016-02-25 17:26

Fix Not correct, Discount attribute has to be changed from "requiredQty" to "requiresQty"
(0084578)
hgbot (developer)
2016-02-28 15:12

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: dadadb16b004a0cbe512c3e29f40efd96d6755bf
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Sun Feb 28 19:42:07 2016 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/dadadb16b004a0cbe512c3e29f40efd96d6755bf [^]

Fixes issue 32243 : Validating Variable Discount Amount before applying to receipt

---
M web/org.openbravo.retail.posterminal/js/pointofsale/view/ticketdiscount.js
---
(0084790)
hgbot (developer)
2016-03-07 17:27

Repository: retail/backports/3.0RR15Q4.5/org.openbravo.retail.posterminal
Changeset: 19b4aa74a36b056d20bab44f85cc6cab883da2a4
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Mon Mar 07 17:26:46 2016 +0100
URL: http://code.openbravo.com/retail/backports/3.0RR15Q4.5/org.openbravo.retail.posterminal/rev/19b4aa74a36b056d20bab44f85cc6cab883da2a4 [^]

Fixed issue 32326: [SERQA 692] Javscript error when adding a manual discount

Backport of issue 32243 for 3.0RR15Q4.5

---
M web/org.openbravo.retail.posterminal/js/pointofsale/view/ticketdiscount.js
---
(0093352)
hgbot (developer)
2017-01-11 13:01

Repository: tools/automation/pi-mobile
Changeset: 771e7c08bc4523341c24f2d201d7fdc1e958d639
Author: Guillermo Gil <guillermo.gil <at> openbravo.com>
Date: Wed Jan 11 09:11:42 2017 +0100
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/771e7c08bc4523341c24f2d201d7fdc1e958d639 [^]

Related to issue 32243: Uncommented finally

---
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/discountsandpromotions/I32243_VerifyProductDiscountWithVariableAmount.java
---
(0109644)
hgbot (developer)
2019-02-06 15:35

Repository: tools/automation/pi-mobile
Changeset: d006a56d606db488cab2bbff4adf4e2a73154444
Author: Alejandro <alekosmp86 <at> gmail.com>
Date: Thu Jan 31 11:05:00 2019 -0500
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/d006a56d606db488cab2bbff4adf4e2a73154444 [^]

Related to issue 32243: test has been refactored due to it no longer creates its
own sampledata

---
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/discountsandpromotions/I32243_VerifyProductDiscountWithVariableAmount.java
---
(0109648)
hgbot (developer)
2019-02-06 15:35

Repository: erp/pmods/org.openbravo.retail.sampledata
Changeset: 39ce8fca8a68292a62f4ae161421e9e34391aba0
Author: Alejandro <alekosmp86 <at> gmail.com>
Date: Sat Jan 26 12:31:55 2019 -0500
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.sampledata/rev/39ce8fca8a68292a62f4ae161421e9e34391aba0 [^]

Related to issue 32243: added sampledata for testing purposes

---
M referencedata/sampledata/The_White_Valley_Group/M_OFFER.xml
M referencedata/sampledata/The_White_Valley_Group/M_OFFER_PRODUCT.xml
---

- Issue History
Date Modified Username Field Change
2016-02-15 22:04 agete New Issue
2016-02-15 22:04 agete Assigned To => Retail
2016-02-15 22:04 agete Triggers an Emergency Pack => No
2016-02-15 22:04 agete Tag Attached: SER-QA
2016-02-16 15:15 Orekaria Status new => acknowledged
2016-02-18 10:31 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2016-02-18 10:31 ranjith_qualiantech_com Status acknowledged => scheduled
2016-02-18 12:42 agete Summary [SERQA 692] Javscript error when adding a manual discount greater than the amount => [SERQA 692] Javscript error when adding a manual discount
2016-02-18 12:42 agete Description Updated View Revisions
2016-02-18 12:42 agete Steps to Reproduce Updated View Revisions
2016-02-18 12:42 agete Proposed Solution updated
2016-02-19 12:59 hgbot Checkin
2016-02-19 12:59 hgbot Note Added: 0084365
2016-02-19 12:59 hgbot Checkin
2016-02-19 12:59 hgbot Note Added: 0084366
2016-02-19 12:59 hgbot Status scheduled => resolved
2016-02-19 12:59 hgbot Resolution open => fixed
2016-02-19 12:59 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/94638e56e37bc53643b40c083e5866b59792139b [^]
2016-02-24 14:14 Orekaria Relationship added related to 0032303
2016-02-24 14:16 Orekaria Relationship replaced has duplicate 0032303
2016-02-24 14:19 Orekaria Status resolved => new
2016-02-24 14:19 Orekaria Resolution fixed => open
2016-02-24 14:19 Orekaria Status new => scheduled
2016-02-24 14:19 Orekaria Status scheduled => resolved
2016-02-24 14:19 Orekaria Fixed in Version => RR16Q2
2016-02-24 14:19 Orekaria Resolution open => fixed
2016-02-25 08:09 guillermogil Note Added: 0084481
2016-02-25 17:26 ranjith_qualiantech_com Note Added: 0084521
2016-02-25 17:26 ranjith_qualiantech_com Status resolved => new
2016-02-25 17:26 ranjith_qualiantech_com Resolution fixed => open
2016-02-25 17:26 ranjith_qualiantech_com Fixed in Version RR16Q2 =>
2016-02-25 17:26 ranjith_qualiantech_com Status new => scheduled
2016-02-28 15:12 hgbot Checkin
2016-02-28 15:12 hgbot Note Added: 0084578
2016-02-28 15:12 hgbot Status scheduled => resolved
2016-02-28 15:12 hgbot Resolution open => fixed
2016-02-28 15:12 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/94638e56e37bc53643b40c083e5866b59792139b [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/dadadb16b004a0cbe512c3e29f40efd96d6755bf [^]
2016-02-29 09:36 marvintm Review Assigned To => marvintm
2016-02-29 09:36 marvintm Status resolved => closed
2016-02-29 09:36 marvintm Fixed in Version => RR16Q2
2016-02-29 18:15 marvintm Severity major => minor
2016-03-07 17:27 hgbot Checkin
2016-03-07 17:27 hgbot Note Added: 0084790
2017-01-11 13:01 hgbot Checkin
2017-01-11 13:01 hgbot Note Added: 0093352
2019-02-06 15:35 hgbot Checkin
2019-02-06 15:35 hgbot Note Added: 0109644
2019-02-06 15:35 hgbot Checkin
2019-02-06 15:35 hgbot Note Added: 0109648


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker