Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032203
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2016-02-11 12:582016-03-17 10:56
ReporterpsanjuanView Statuspublic 
Assigned Tovmromanos 
PriorityurgentResolutionfixedFixed in Version3.0PR16Q2
StatusclosedFix in branchFixed in SCM revision5cca1c6b5780
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionProfessional ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2015-12-01
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/217fb3a426febf71995fa1394dac159afa49b44f#l2.7 [^]
Triggers an Emergency PackNo
Summary

0032203: Not possible to post a remittance as well as the settlement of that remittance.

DescriptionNot possible to post a remittance as well as the settlement of that remittance.
Steps To ReproduceIn pi, install remittance infrastructure module 16Q2 branch.

Create a remittance of any type, select some invoices and process.

Try to post the remittance.

A Java Lang Null Pointer exception is shown. See files attached.

Same applies in the case of posting remittance settlement.

Remittance Protest Post works OK:
Proposed SolutionIt should be possible to post a remittance as well as all remittance steps without any problem.
TagsNo tags attached.
Attached Filespng file icon Issue31419_JavaLang_1.png [^] (117,123 bytes) 2016-02-11 12:59


png file icon Issue31419_JavaLang_2.png [^] (274,275 bytes) 2016-02-11 12:59

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 0031580 closedvmromanos Java Heap Space error when posting payment with huge amount of details 
related to defect 0033508 closedmarkmm82 Cannot post a Cash VAT payment that pays more than one invoice, Process failed during execution error is shown 
related to defect 0033688 closedrqueralta Cannot post a financial account transaction if the invoice is partially paid by using credit 

-  Notes
(0084114)
vmromanos (developer)
2016-02-11 16:32
edited on: 2016-02-11 16:33

Test plan:

In a recent PI, install any version of the Remittance module

Create a remittance of any type, select some invoices and process.
Try to post the remittance.
Verify you can post it successfully.

(0084124)
hgbot (developer)
2016-02-11 17:11

Repository: erp/devel/pi
Changeset: 5cca1c6b5780268e71104a6352ffb9c99bf1a782
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Thu Feb 11 16:31:20 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/5cca1c6b5780268e71104a6352ffb9c99bf1a782 [^]

Fixed bug 32203: Not possible to post a remittance and the settlement of that remittance

The way to retrieve the payment detail object was wrong. Instead we can take it directly from the paymentDetails list

---
M src/org/openbravo/erpCommon/ad_forms/AcctServer.java
---
(0084125)
aferraz (developer)
2016-02-11 17:11

Code review OK
(0085130)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-02-11 12:58 psanjuan New Issue
2016-02-11 12:58 psanjuan Assigned To => Triage Finance
2016-02-11 12:58 psanjuan Modules => Core
2016-02-11 12:58 psanjuan Regression level => Coding ( Testing )
2016-02-11 12:58 psanjuan Triggers an Emergency Pack => No
2016-02-11 12:59 psanjuan File Added: Issue31419_JavaLang_1.png
2016-02-11 12:59 psanjuan File Added: Issue31419_JavaLang_2.png
2016-02-11 13:04 vmromanos Review Assigned To => aferraz
2016-02-11 13:04 vmromanos Regression level Coding ( Testing ) => Pre packaging ( pi )
2016-02-11 13:04 vmromanos Regression date => 2015-12-01
2016-02-11 13:04 vmromanos Regression introduced in release => pi
2016-02-11 13:04 vmromanos Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/217fb3a426febf71995fa1394dac159afa49b44f#l2.7 [^]
2016-02-11 13:04 vmromanos Assigned To Triage Finance => vmromanos
2016-02-11 13:05 vmromanos Status new => scheduled
2016-02-11 13:07 vmromanos Relationship added caused by 0031580
2016-02-11 16:32 vmromanos Note Added: 0084114
2016-02-11 16:33 vmromanos Note Edited: 0084114 View Revisions
2016-02-11 17:11 hgbot Checkin
2016-02-11 17:11 hgbot Note Added: 0084124
2016-02-11 17:11 hgbot Status scheduled => resolved
2016-02-11 17:11 hgbot Resolution open => fixed
2016-02-11 17:11 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/5cca1c6b5780268e71104a6352ffb9c99bf1a782 [^]
2016-02-11 17:11 aferraz Note Added: 0084125
2016-02-11 17:11 aferraz Status resolved => closed
2016-02-11 17:11 aferraz Fixed in Version => 3.0PR16Q2
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085130
2016-07-26 12:15 aferraz Relationship added related to 0033508
2016-08-12 11:42 aferraz Relationship added related to 0033688


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker