Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032190
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2016-02-10 13:202016-07-20 11:34
ReporteregoitzView Statuspublic 
Assigned Toaferraz 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q2
StatusclosedFix in branchFixed in SCM revisionca36991325a4
ProjectionnoneETAnoneTarget Version3.0PR16Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032190: Performance problems on the PriceDifferenceBackground process

DescriptionThe process is taking long to calculate the differences on 7000 transactions.
Steps To ReproduceExecute the process on an environment with big amount of data having 7000 transactions to be corrected.

ask ECA for an enviroment.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00320233.0PR16Q2 closedaferraz CostingUtils.getCurrentValuedStock method consumes unneeded memory 
related to defect 00334113.0PR17Q1 closeddmiguelez Bad performance Costing Background process using 3 types of adjustments 
related to defect 0035959 closedmarkmm82 Performance problem in Costing Migration Process with high volume of records in m_transaction table 

-  Notes
(0084362)
hgbot (developer)
2016-02-19 12:39

Repository: erp/devel/pi
Changeset: ca36991325a4e9680fbbb9fd36c755ae3f5500de
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Mon Feb 15 19:53:12 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/ca36991325a4e9680fbbb9fd36c755ae3f5500de [^]

Fixes issue 32023 & Fixes issue 32190: Improve PriceDifference performance

Some improvements have been done in CostingUtils.getCurrentValuedStock, CostAdjustmentUtils.getValuedStockOnMovementDateByAttrAndLocator, CostAdjustmentUtils.getValuedStockOnTransactionDate and CostingMigrationProcess.getCurrentValuedStock methods:
- Use TransactionCost.PROPERTY_ACCOUNTINGDATE field instead of coalesce(ShipmentInOut.PROPERTY_ACCOUNTINGDATE, MaterialTransaction.PROPERTY_MOVEMENTDATE) to avoid join with ShipmentInOutLine and ShipmentInOut tables.
- Use a scroll instead of looping through a list.
- Loop can not be avoid due to the need of calculate conversion rate recursively.
- Clear every 100 loops will not be done as DAL objects will not be loaded in memory and to avoid session cleared errors.
Retrieve only one or two results in some queries where more results were not needed.
Use isEmpty() instead of size().
Retrieve only lineno field instead of full object in CostAdjustmentUtils.getNewLineNo method.
Improve CostAdjustmentUtils.getTrxCost method.
Do a clear every 100 loops in PriceDifferenceProcess.processPriceDifference method to improve performance.

---
M src/org/openbravo/costing/AverageAlgorithm.java
M src/org/openbravo/costing/AverageCostAdjustment.java
M src/org/openbravo/costing/CostAdjustmentUtils.java
M src/org/openbravo/costing/CostingMigrationProcess.java
M src/org/openbravo/costing/CostingUtils.java
M src/org/openbravo/costing/PriceDifferenceProcess.java
---
(0084364)
dmiguelez (developer)
2016-02-19 12:39

Code Review + Testing Ok
(0085156)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-02-10 13:20 egoitz New Issue
2016-02-10 13:20 egoitz Assigned To => Triage Finance
2016-02-10 13:20 egoitz Modules => Core
2016-02-10 13:20 egoitz Triggers an Emergency Pack => No
2016-02-11 17:40 aferraz Status new => scheduled
2016-02-11 17:40 aferraz Assigned To Triage Finance => aferraz
2016-02-12 13:53 aferraz Relationship added related to 0032023
2016-02-16 10:01 aferraz Summary Problemas performen on the PriceDifferenceBackground process => Performance problems on the PriceDifferenceBackground process
2016-02-19 12:39 hgbot Checkin
2016-02-19 12:39 hgbot Note Added: 0084362
2016-02-19 12:39 hgbot Status scheduled => resolved
2016-02-19 12:39 hgbot Resolution open => fixed
2016-02-19 12:39 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ca36991325a4e9680fbbb9fd36c755ae3f5500de [^]
2016-02-19 12:39 dmiguelez Review Assigned To => dmiguelez
2016-02-19 12:39 dmiguelez Note Added: 0084364
2016-02-19 12:39 dmiguelez Status resolved => closed
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085156
2016-07-20 11:32 aferraz Relationship added related to 0033411
2016-07-20 11:33 aferraz Fixed in Version => 3.0PR16Q2
2016-07-20 11:34 aferraz Target Version => 3.0PR16Q2
2017-05-09 12:31 aferraz Relationship added related to 0035959


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker