Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032110
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Openbravo ERP] A. Platformminoralways2016-02-03 19:032016-03-17 10:56
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR16Q2
StatusclosedFix in branchFixed in SCM revision42872a897da5
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032110: Upgrade FOP library

DescriptionUpgrade FOP library from version 1.0 to version 1.1. This is a must for the Mondrian-Saiku upgrade project.
Steps To ReproduceIn description
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0032123 closedcaristu Openbravo ERP API Change Required for FOP library upgrade 
related to feature request 0032149 closedcaristu Openbravo ERP Upgrade Jackson libraries 
related to feature request 0037880 closedshuehner Openbravo ERP Remove broken report "Settlement", used in print button of old-flow window "Settlement" (pre-aprm), as uses obsolete fop 
related to feature request 0037874 closedalostale Openbravo ERP Remove support for fop rendering from core product as very nearly not used 
blocks feature request 0032215 closedcaristu Modules upgrade analytics stack 

-  Notes
(0083952)
caristu (developer)
2016-02-05 10:00
edited on: 2016-02-05 10:44

To validate the upgrade the following reports have been tested before and after the upgrade:

- Price List Report
- Sales Order Returns Dimensional Report
- Quality Control Point window (print from the toolbar)
- Quality Control Report (print from the toolbar)

After the upgrade, some of the .fo reports required a minor change to be generated properly because the fo:region-body must be declared before fo:region-before. More details can be found here[1].

It is possible to print a fop report including a barcode. An example can be found here[2].

It has been verified that FOP report configuration is still working. This is used, for example, to customize the fonts used in the report. The documentation regarding this topic has been updated properly[3].

Now the renderFO() method uses a different API to generate the report. Because of this change, the following warnings are displayed in the log:

Warning: org.apache.xerces.parsers.SAXParser: Feature 'http://javax.xml.XMLConstants/feature/secure-processing' [^] is not recognized.
Warning: org.apache.xerces.parsers.SAXParser: Property 'http://www.oracle.com/xml/jaxp/properties/entityExpansionLimit' [^] is not recognized.

They seems to be related with the version of the xercesImpl library we are currently using. As they are just warning messages and the reports are generated properly, I think is better to upgrade the minimum amount of required libraries. So for the moment this library has not been upgraded.

[1] http://wiki.apache.org/xmlgraphics-fop/Troubleshooting/CommonLogMessages [^]
[2] https://code.openbravo.com/erp/mods/org.openbravo.platform.features/rev/1ac981742501 [^]
[3] http://wiki.openbravo.com/wiki/How_to_Change_Fonts_in_Openbravo_Reports#Changing_the_font_in_FOP_Reports [^]

(0083954)
hgbot (developer)
2016-02-05 10:08

Repository: erp/devel/pi
Changeset: 42872a897da5b5ca9436de049142716969777b62
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Feb 05 10:04:46 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/42872a897da5b5ca9436de049142716969777b62 [^]

fixes issue 32110: Upgrade FOP library

---
M legal/Licensing.txt
M lib/runtime/fop.jar
M src-core/src/org/openbravo/base/ConfigParameters.java
M src-core/src/org/openbravo/base/HttpBaseServlet.java
A lib/runtime/barcode4j-fop-ext-complete.jar
A lib/runtime/xmlgraphics-commons-1.5.jar
R lib/runtime/barcode4j-fop-ext-0.20.5-complete.jar
---
(0083955)
hgbot (developer)
2016-02-05 10:08

Repository: erp/devel/pi
Changeset: dc0fe14356ec219530a288097c33623827f8acd0
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Feb 05 10:05:58 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/dc0fe14356ec219530a288097c33623827f8acd0 [^]

related to issue 32110: fixes for .fo reports

---
M src/org/openbravo/erpCommon/ad_reports/ReportPricelist.fo
M src/org/openbravo/erpCommon/ad_reports/ReportRefundSalesDimensionalAnalyses.fo
M src/org/openbravo/erpReports/RptMA_CCP_Group.fo
M src/org/openbravo/erpReports/RptMA_CCP_Measures.fo
M src/org/openbravo/erpReports/RptM_Inout.fo
---
(0084148)
hgbot (developer)
2016-02-12 11:06

Repository: erp/devel/pi
Changeset: 43feadf21bf741b28b50fdbb05d51beb4895bc1b
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Feb 12 11:04:34 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/43feadf21bf741b28b50fdbb05d51beb4895bc1b [^]

related to issue 32110: include version in fop library name

---
M legal/Licensing.txt
M src-core/.classpath
A lib/runtime/fop-1.1.jar
R lib/runtime/fop.jar
---
(0084158)
alostale (developer)
2016-02-12 14:47

code reviewed
(0085106)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test
(0085107)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test
(0085135)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-02-03 19:03 caristu New Issue
2016-02-03 19:03 caristu Assigned To => caristu
2016-02-03 19:03 caristu Modules => Core
2016-02-03 19:03 caristu Triggers an Emergency Pack => No
2016-02-03 19:04 caristu Status new => scheduled
2016-02-04 13:08 caristu Relationship added related to 0032123
2016-02-05 10:00 caristu Note Added: 0083952
2016-02-05 10:01 caristu Note Edited: 0083952 View Revisions
2016-02-05 10:01 caristu Note Edited: 0083952 View Revisions
2016-02-05 10:08 hgbot Checkin
2016-02-05 10:08 hgbot Note Added: 0083954
2016-02-05 10:08 hgbot Status scheduled => resolved
2016-02-05 10:08 hgbot Resolution open => fixed
2016-02-05 10:08 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/42872a897da5b5ca9436de049142716969777b62 [^]
2016-02-05 10:08 hgbot Checkin
2016-02-05 10:08 hgbot Note Added: 0083955
2016-02-05 10:10 caristu Review Assigned To => alostale
2016-02-05 10:10 caristu Issue Monitored: alostale
2016-02-05 10:44 caristu Note Edited: 0083952 View Revisions
2016-02-05 14:41 caristu Relationship added related to 0032149
2016-02-12 08:29 alostale Relationship added blocks 0032215
2016-02-12 11:06 hgbot Checkin
2016-02-12 11:06 hgbot Note Added: 0084148
2016-02-12 14:47 alostale Note Added: 0084158
2016-02-12 14:47 alostale Status resolved => closed
2016-02-12 14:47 alostale Fixed in Version => 3.0PR16Q2
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085106
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085107
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085135
2018-02-11 12:53 shuehner Relationship added related to 0037880
2019-01-31 10:15 caristu Relationship added related to 0037874


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker