Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032060
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 03. Procurement managementmajoralways2016-01-29 14:502016-03-17 10:56
ReporterVictorVillarView Statuspublic 
Assigned Tomarkmm82 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision7410454ae6c6
ProjectionnoneETAnoneTarget Version3.0PR16Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032060: Wrong Goods Receipt button status under some circumstances

DescriptionWrong Goods Receipt button status under some circumstances. It shows Close when it should be 'Complete'
Steps To ReproduceAs group admin role,
 Go to Purchase Order window,
    create a new one for España.
      Product: Zumo de Naranja Bio
Complete it.

Go to Pending Goods Receipts and select the order created before: today and any bin.

Process it.

Warning message: Goods Receipt 10000331: The goods receipt was created but couldn't be processed because one line has no attribute set

If you go to Goods Receipt window you will see that the button shows: 'close' but should be 'Complete'
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0084298)
markmm82 (developer)
2016-02-17 18:01
edited on: 2016-02-17 18:17

Test plan

-As group admin role,
 Go to Purchase Order window,
    create a new one for España.
      Product: Zumo de Naranja Bio
 Complete it.

-Go to Pending Goods Receipts and select the order created before: today and any bin.

-Process it.
Warning message: Goods Receipt 10000331: The goods receipt was created but couldn't be processed because one line has no attribute set

-If you go to Goods Receipt window you will see that the button shows: 'Complete'!

(0084353)
hgbot (developer)
2016-02-19 11:32

Repository: erp/devel/pi
Changeset: 7410454ae6c6b48cb01899763820f86ffd466d86
Author: Mark <m.molina <at> nectus.com>
Date: Wed Feb 17 11:03:01 2016 -0500
URL: http://code.openbravo.com/erp/devel/pi/rev/7410454ae6c6b48cb01899763820f86ffd466d86 [^]

Fixes issue 32060: Wrong Goods Receipt button status under some circumstances

Column process_goods_java inside M_INOUT table was updated correctly inside the process of a Pending Goods Receipts.
The button show the expected text.

---
M src/org/openbravo/erpCommon/ad_forms/MaterialReceiptPending.html
M src/org/openbravo/erpCommon/ad_forms/MaterialReceiptPending.java
M src/org/openbravo/erpCommon/ad_forms/MaterialReceiptPending_data.xsql
---
(0084354)
hgbot (developer)
2016-02-19 11:32

Repository: erp/devel/pi
Changeset: 815ba738d4dc322b67ef54ff35900c7188b13c86
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Fri Feb 19 11:31:51 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/815ba738d4dc322b67ef54ff35900c7188b13c86 [^]

Related to Issue 32060: Updated year in copyright.

---
M src/org/openbravo/erpCommon/ad_forms/MaterialReceiptPending_data.xsql
---
(0084355)
dmiguelez (developer)
2016-02-19 11:33

Code Review + Testing Ok
(0085153)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test
(0085154)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-01-29 14:50 VictorVillar New Issue
2016-01-29 14:50 VictorVillar Assigned To => Triage Finance
2016-01-29 14:50 VictorVillar Modules => Core
2016-01-29 14:50 VictorVillar Triggers an Emergency Pack => No
2016-01-29 14:51 VictorVillar Issue Monitored: networkb
2016-02-01 17:24 nonofrancisco Assigned To Triage Finance => markmm82
2016-02-01 17:25 nonofrancisco Status new => scheduled
2016-02-02 17:31 markmm82 Note Added: 0083859
2016-02-17 18:01 markmm82 Note Deleted: 0083859
2016-02-17 18:01 markmm82 Note Added: 0084298
2016-02-17 18:17 markmm82 Note Edited: 0084298 View Revisions
2016-02-19 11:32 hgbot Checkin
2016-02-19 11:32 hgbot Note Added: 0084353
2016-02-19 11:32 hgbot Status scheduled => resolved
2016-02-19 11:32 hgbot Resolution open => fixed
2016-02-19 11:32 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/7410454ae6c6b48cb01899763820f86ffd466d86 [^]
2016-02-19 11:32 hgbot Checkin
2016-02-19 11:32 hgbot Note Added: 0084354
2016-02-19 11:33 dmiguelez Review Assigned To => dmiguelez
2016-02-19 11:33 dmiguelez Note Added: 0084355
2016-02-19 11:33 dmiguelez Status resolved => closed
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085153
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085154


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker