Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031956
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2016-01-19 18:152016-04-08 11:00
ReporteraferrazView Statuspublic 
Assigned Toaferraz 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisiond2a064ba6376
ProjectionnoneETAnoneTarget Version3.0PR16Q2
OSLinux 64 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionProfessional ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2015-06-22
Regression introduced in release3.0PR15Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/e03c1808e1952c20ef838c8a8b976cff802d5156 [^]
Triggers an Emergency PackNo
Summary

0031956: Cannot void a goods shipment if it has related reservation under some circumstances

DescriptionCannot void a goods shipment if it has related reservation under some circumstances
Steps To ReproduceAs group admin role:
   Create the Enable Stock Reservations preference
   Log out and log in
   Create a product for España and add a price list for "Tarifa de Bebidas Alegres" and "Tarifa de ventas" .
   Create a receipt for created product, qty=25 in RN-0-0-0 locator.
   Create a sales order, add the previously created product and qty=25. Complete it.
   Add a complete reservation to it (qty=25 in RN-0-0-0).
   Create a shipment from sales order with qty=20 in RN-0-0-0. Complete it.
   Create another shipment from sales order with qty=5 in RN-0-0-0. Complete it.
   Try to void the second shipment. An empty error message is shown.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00318763.0PR16Q2 closedaferraz Cannot void a goods shipment if two lines are related with the same sales order line which is reserved and released 
related to defect 00317993.0PR16Q2 closedaferraz Cannot void a goods shipment if it has more than one closed reservation associated 
related to defect 00319023.0PR16Q2 closedaferraz Cannot void a goods shipment if it has related reservation and there is less stock than double of shipment quantity 
depends on backport 00319573.0PR16Q1 closedaferraz Cannot void a goods shipment if it has related reservation under some circumstances 
depends on backport 00319583.0PR15Q4.3 closedaferraz Cannot void a goods shipment if it has related reservation under some circumstances 
caused by defect 0028645 closedvmromanos It would be nice to be able to reserve more qty than the qty of the order if you have defined the 'is qty variable' 
related to defect 0033752 closedmarkmm82 Cannot close an order if the stock was reserved and the associated goods shipment is voided 

-  Notes
(0083453)
aferraz (developer)
2016-01-20 13:08
edited on: 2016-02-04 09:39

Test plan I:

As group admin role:
   Create the Enable Stock Reservations preference
   Log out and log in
   Create a product for España and add a price list for "Tarifa de Bebidas Alegres" and "Tarifa de ventas" .
   Create a receipt for created product, qty=25 in RN-0-0-0 locator.
   Create a sales order, add the previously created product and qty=25. Complete it.
   Add a complete reservation to it (qty=25 in RN-0-0-0).
   Realize a stock reservation has been created with qty=25, reserved qty=25, released=0 and a line with qty=25 released=0 in RN-0-0-0.
   Create a shipment from sales order with qty=20 in RN-0-0-0. Complete it.
   Realize stock reservation has been updated with qty=25, reserved qty=25, released=20 and line with qty=25 released=20 in RN-0-0-0.
   Create another shipment from sales order with qty=5 in RN-0-0-0. Complete it.
   Realize stock reservation has been closed with qty=25, reserved qty=25, released=25 and line with qty=25 released=25 in RN-0-0-0.
   Void second shipment.
   Realize a new stock reservation has been created in completed status with qty=25, reserved qty=5, released=0 and line with qty=5 released=0 in RN-0-0-0.

   Create another shipment from sales order, there are only 5 unit left to deliver from storage bin RN-0-0-0. Complete it.
   Realize that the new stock reservation created in the step above is now set as closed with below data: Qty = 25, Reserved Qty = 5, Released = 5

(0083457)
aferraz (developer)
2016-01-20 13:49
edited on: 2016-02-04 09:55

Test plan II:

As group admin role:
   Create the Enable Stock Reservations preference
   Log out and log in
   Create a product for España and add a price list for "Tarifa de Bebidas Alegres" and "Tarifa de ventas" .
   Create a receipt for created product, qty=25 in RN-0-0-0 locator.
   Create a sales order, add the previously created product and qty=25. Complete it.
   Add a complete reservation to it (qty=25 in RN-0-0-0).
   Realize a stock reservation has been created with qty=25, reserved qty=25, released=0 and a line with qty=25 released=0 in RN-0-0-0.
   Create a shipment from sales order with one line with qty=20 in RN-0-0-0 and a second line with qty=5 in RN-0-0-0. Complete it.
   Realize stock reservation has been closed with qty=25, reserved qty=25, released=25 and line with qty=25 released=25 in RN-0-0-0.
   Void the shipment.
   Realize a new stock reservation has been created in completed status with qty=25, reserved qty=25, released=0 and line with qty=25 released=0 in RN-0-0-0.

(0083504)
psanjuan (manager)
2016-01-21 15:49
edited on: 2016-02-04 09:58

Test plan III:

As group admin role:
   Create the Enable Stock Reservations preference
   Log out and log in
   Create a product for España and add a price list for "Tarifa de Bebidas Alegres" and "Tarifa de ventas" .
   Create a receipt for created product, qty=25 in RN-0-0-0 locator.
   Create another receipt for created product, qty= 25 in RN-1-0-0 locator.
   Create a sales order, add the previously created product and qty=50. Complete it.
   Add a complete reservation to it (qty=25 in RN-0-0-0 and qty = 25 in RN-1-0-0).
   Realize a stock reservation has been created with qty=50, reserved qty=50, released=0 and two lines one per each locator with qty=25 released=0
   Create a shipment from sales order with two lines one per each locator, qty=25 each. Complete it.
   Realize stock reservation has been closed with qty=50, reserved qty=50, released=505 and two lines one per each locator with qty=25 released=25
   Void the shipment.
   Realize a new stock reservation has been created in completed status with qty=50, reserved qty=50, released=0 and two lines one per each locator with qty=25 released=0

(0083915)
psanjuan (manager)
2016-02-04 10:02
edited on: 2016-02-04 10:08

Test plan IV:

As group admin role:
   Create the Enable Stock Reservations preference
   Log out and log in
   Create a product for España and add a price list for "Tarifa de Bebidas Alegres" and "Tarifa de ventas" .
   Create a receipt for created product, qty=25 in RN-0-0-0 locator.
   Create another receipt for created product, qty= 25 in RN-1-0-0 locator.
   Create a sales order, add the previously created product and qty=50. Complete it.
   Add a complete reservation to it (qty=25 in RN-0-0-0 and qty = 25 in RN-1-0-0).
   Realize a stock reservation has been created with qty=50, reserved qty=50, released=0 and two lines one per each locator with qty=25 released=0
   Create a shipment from sales order with two lines:
   Qty = 20 from RN-0-0-0
   Qty = 20 from Rn-1-0-0
Complete it.

   Check that the stock reservation has been updated with qty=50, reserved qty=50, released=40 and two lines one per each locator with qty=25 released=20

Create another shipment from sales order with two lines:
   Qty = 5 from RN-0-0-0
   Qty = 5 from Rn-1-0-0
Complete it.

   Check that the stock reservation has been updated to Closed with qty=50, reserved qty=50, released=50 and two lines one per each locator with qty=25 released=25

   Void the second shipment.

   Realize a new stock reservation has been created in completed status with qty=50, reserved qty=10, released=0 and two lines one per each locator with qty=5 released=0

(0083916)
psanjuan (manager)
2016-02-04 10:09

Test Plan above verified.
Issue can be code reviewed and closed.
(0084047)
hgbot (developer)
2016-02-09 10:26

Repository: erp/devel/pi
Changeset: d2a064ba63767e527efb2777e849702f98c06a45
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Mon Feb 01 18:49:06 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/d2a064ba63767e527efb2777e849702f98c06a45 [^]

Fixes issue 31876 & Fixes issue 31902 & Fixes issue 31956: Cannot void shipment

Cannot void shipment related to reservation.
New reservation to replace the closed related one when voiding a shipment will be done after update m_storage_detail, in order to have voided shipment quantity available.
Reservation stock lines will be created with related shipment line movement quantity in case this quantity is less than pending order quantity.
Reservation will be created with the least quantity between ordered quantity and movement quantity.

---
M src-db/database/model/functions/M_INOUT_POST.xml
---
(0084048)
dmiguelez (developer)
2016-02-09 10:28

Code Review + Testing Ok
(0084372)
aferraz (developer)
2016-02-19 13:35

Test plan: https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-9998 [^]
(0085120)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test
(0085520)
hgbot (developer)
2016-04-08 11:00

Repository: tools/automation/int
Changeset: ce33be0195500e4c9f15e707b68f8c8c685bfec0
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Wed Feb 24 10:05:56 2016 +0100
URL: http://code.openbravo.com/tools/automation/int/rev/ce33be0195500e4c9f15e707b68f8c8c685bfec0 [^]

Related to issue 31876 & Related to issue 31902 & Related to issue 31956: Add an automated test

---
M src-test/com/openbravo/test/integration/erp/modules/client/application/gui/FormInputFieldFactory.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/reservation/testsuites/RES_Regressions/RES_RegressionSuite.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/reservation/testsuites/RES_Regressions/build.xml
M src-test/com/openbravo/test/integration/erp/testscripts/SmokeTabScript.java
A src-test/com/openbravo/test/integration/erp/modules/client/application/gui/searchitems/OrderSearchItem.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/reservation/testsuites/RES_Regressions/RESRegression31876R31902R31956.java
---

- Issue History
Date Modified Username Field Change
2016-01-19 18:15 aferraz New Issue
2016-01-19 18:15 aferraz Assigned To => aferraz
2016-01-19 18:15 aferraz Modules => Core
2016-01-19 18:15 aferraz Regression level => Production - QA Approved
2016-01-19 18:15 aferraz Regression date => 2015-06-22
2016-01-19 18:15 aferraz Regression introduced in release => 3.0PR15Q4
2016-01-19 18:15 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/e03c1808e1952c20ef838c8a8b976cff802d5156 [^]
2016-01-19 18:15 aferraz Triggers an Emergency Pack => No
2016-01-19 18:16 aferraz Relationship added caused by 0028645
2016-01-19 18:16 aferraz Relationship added related to 0031876
2016-01-19 18:16 aferraz Relationship added related to 0031799
2016-01-19 18:17 aferraz Relationship added related to 0031902
2016-01-19 18:17 aferraz Status new => scheduled
2016-01-20 13:08 aferraz Note Added: 0083453
2016-01-20 13:49 aferraz Note Added: 0083457
2016-01-21 15:49 psanjuan Note Added: 0083504
2016-02-04 09:36 psanjuan Note Edited: 0083453 View Revisions
2016-02-04 09:39 psanjuan Note Edited: 0083453 View Revisions
2016-02-04 09:55 psanjuan Note Edited: 0083457 View Revisions
2016-02-04 09:58 psanjuan Note Edited: 0083504 View Revisions
2016-02-04 10:02 psanjuan Note Added: 0083915
2016-02-04 10:06 psanjuan Note Edited: 0083915 View Revisions
2016-02-04 10:08 psanjuan Note Edited: 0083915 View Revisions
2016-02-04 10:08 psanjuan Note Edited: 0083915 View Revisions
2016-02-04 10:09 psanjuan Note Added: 0083916
2016-02-09 10:26 hgbot Checkin
2016-02-09 10:26 hgbot Note Added: 0084047
2016-02-09 10:26 hgbot Status scheduled => resolved
2016-02-09 10:26 hgbot Resolution open => fixed
2016-02-09 10:26 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d2a064ba63767e527efb2777e849702f98c06a45 [^]
2016-02-09 10:28 dmiguelez Review Assigned To => dmiguelez
2016-02-09 10:28 dmiguelez Note Added: 0084048
2016-02-09 10:28 dmiguelez Status resolved => closed
2016-02-19 13:35 aferraz Note Added: 0084372
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085120
2016-04-08 11:00 hgbot Checkin
2016-04-08 11:00 hgbot Note Added: 0085520
2016-08-20 21:54 aferraz Relationship added related to 0033752


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker