Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031902
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2016-01-15 11:102016-04-08 11:00
ReporteraferrazView Statuspublic 
Assigned Toaferraz 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisiond2a064ba6376
ProjectionnoneETAnoneTarget Version3.0PR16Q2
OSLinux 64 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionProfessional ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2015-06-22
Regression introduced in release3.0PR15Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/e03c1808e1952c20ef838c8a8b976cff802d5156 [^]
Triggers an Emergency PackNo
Summary

0031902: Cannot void a goods shipment if it has related reservation and there is less stock than double of shipment quantity

DescriptionCannot void a goods shipment if it has related reservation and there is less stock than double of shipment quantity
Steps To ReproduceAs group admin role:
   Create the Enable Stock Reservations preference
   Log out and log in
   Create a product for España and add a price list for "Tarifa de Bebidas Alegres" and "Tarifa de ventas" .
   Create a receipt for created product, qty=29 in RN-0-0-0 locator.
   Create a sales order, add the previously created product and qty=15. Complete it.
   Add a complete reservation to it (qty=15 in RN-0-0-0).
   Create a shipment from sales order with qty=15 in RN-0-0-0. Complete it.
   Try to void the shipment. An empty error message is shown.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00318763.0PR16Q2 closedaferraz Cannot void a goods shipment if two lines are related with the same sales order line which is reserved and released 
related to defect 00317993.0PR16Q2 closedaferraz Cannot void a goods shipment if it has more than one closed reservation associated 
depends on backport 00319073.0PR16Q1 closedaferraz Cannot void a goods shipment if it has related reservation and there is less stock than double of shipment quantity 
depends on backport 00319083.0PR15Q4.3 closedaferraz Cannot void a goods shipment if it has related reservation and there is less stock than double of shipment quantity 
caused by defect 0028645 closedvmromanos It would be nice to be able to reserve more qty than the qty of the order if you have defined the 'is qty variable' 
related to defect 00319563.0PR16Q2 closedaferraz Cannot void a goods shipment if it has related reservation under some circumstances 
related to defect 0033752 closedmarkmm82 Cannot close an order if the stock was reserved and the associated goods shipment is voided 

-  Notes
(0083353)
aferraz (developer)
2016-01-15 14:43
edited on: 2016-01-20 13:50

Test plan I:

As group admin role:
   Create the Enable Stock Reservations preference
   Log out and log in
   Create a product for España and add a price list for "Tarifa de Bebidas Alegres" and "Tarifa de ventas" .
   Create a receipt for created product, qty=29 in RN-0-0-0 locator.
   Create a sales order, add the previously created product and qty=15. Complete it.
   Add a complete reservation to it (qty=15 in RN-0-0-0).
   Realize a stock reservation has been created with qty=15, reserved qty=15, released=0 and a line with qty=15 released=0 in RN-0-0-0.
   Create a shipment from sales order with qty=15 in RN-0-0-0. Complete it.
   Realize stock reservation has been closed with qty=15, reserved qty=15, released=15 and line with qty=15 released=15 in RN-0-0-0.
   Void shipment.
   Realize a new stock reservation has been created in completed status with qty=15, reserved qty=15, released=0 and line with qty=15 released=0 in RN-0-0-0.

(0083386)
psanjuan (manager)
2016-01-18 18:19

Issue verified
(0083394)
psanjuan (manager)
2016-01-19 10:10
edited on: 2016-02-04 11:04

Test Plan I above verified.

Test plan II:

- Create a product named "31902 I" for F&B España and add a price list for "Tarifa de Bebidas Alegres" and "Tarifa de ventas" .

- Create another product named "31902 II" for F&B España and add a price list for "Tarifa de Bebidas Alegres" and "Tarifa de ventas" .

- Create a purchase order for F&B España with below data:
Product "31902 I", qty ordered = 40
Product "31902 II", qty ordered = 60
Book the order.

- Create a receipt for created products:
Product "31902 I", qty received = 15 in RN-0-0-0
Product "31902 II", qty received = 20 in RN-1-0-0
Book the receipt.

- Create a sales order, add the previously created products:
Product "31902 I", qty ordered = 15
Product "31902 II", qty ordered = 20

- Add a complete reservation of each line
Product "31902 I", qty reserved = 15 in RN-0-0-0
Product "31902 II", qty reserved = 20 in RN-1-0-0

- Check that two stock reservations, one for each product, have been created:
For the first product "31902 I", qty= 15, Reserved Qty=15, Released = 0
For the second product "31902 II", qty=20, Reserved Qty=20, Released = 0

- Create a shipment from sales order for both products, full quantity each. Complete it.

- Check that stock reservations have changed its status to "Closed" with below data:
For the first product "31902 I", qty= 15, Reserved Qty=15, Released = 15
For the second product "31902 II", qty=20, Reserved Qty=20, Released = 20

- Void shipment.

- Check that two new stock reservations have been created in status "Completed" with below data:
For the first product "31902 I", qty= 15, Reserved Qty=15, Released = 0
For the second product "31902 II", qty=20, Reserved Qty=20, Released = 0

Test plan III:

Repeat Test Plan II above until
- Create a shipment from sales order for both products, but this time do not ship the full quantity but part of it, therefore:
Product "31902 I", qty shipped = 5 from RN-0-0-0
Product "31902 II", qty shipped = 10 from RN-1-0-0

- Check that the two stock reservations have been updated therefore release qty shown is no longer 0 units but the corresponding qty (5 and 10)

- Create a new shipment for part of qty:
Product "31902 I", qty shipped = 7 from RN-0-0-0
Product "31902 II", qty shipped = 3f rom RN-1-0-0
Complete it.

- Check that stock reservations have been updated therefore release qty shown now is (5+7=12 and 10+3=13)

- Void second shipment, no error is shown.

- Check that stock reservation is still on "Completed" status and released qty is now back to 5 and 10

Test plan VI:

Repeat test plan III until

- Create a new shipment for part of qty, but this time ship all remaining quantity.
Product "31902 I", qty shipped = 10 from RN-0-0-0
Product "31902 II", qty shipped = 10 from RN-1-0-0
Complete it.

- Check that stock reservations have been updated therefore release qty shown is (5+10= 15 and 10+10= 20); full quantity of the sales order. Check also that the status of the stock reservation is now "Closed"

- Void second shipment

- Check that two new stock reservations have been created in status "Completed" with below information:
Stock Reservation 1 for Product "31902 I", qty= 15, reserved qty= 10, released=0
Stock Reservation 2 for Product "31902 II", qty= 20, reserved qty= 10, released=0

(0083920)
psanjuan (manager)
2016-02-04 11:05

Test Plan above verified.
Issue can be code reviewed and closed.
(0084046)
hgbot (developer)
2016-02-09 10:26

Repository: erp/devel/pi
Changeset: d2a064ba63767e527efb2777e849702f98c06a45
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Mon Feb 01 18:49:06 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/d2a064ba63767e527efb2777e849702f98c06a45 [^]

Fixes issue 31876 & Fixes issue 31902 & Fixes issue 31956: Cannot void shipment

Cannot void shipment related to reservation.
New reservation to replace the closed related one when voiding a shipment will be done after update m_storage_detail, in order to have voided shipment quantity available.
Reservation stock lines will be created with related shipment line movement quantity in case this quantity is less than pending order quantity.
Reservation will be created with the least quantity between ordered quantity and movement quantity.

---
M src-db/database/model/functions/M_INOUT_POST.xml
---
(0084049)
dmiguelez (developer)
2016-02-09 10:28

Code Review + Testing Ok
(0084371)
aferraz (developer)
2016-02-19 13:35

Test plan: https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-9998 [^]
(0085119)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test
(0085519)
hgbot (developer)
2016-04-08 11:00

Repository: tools/automation/int
Changeset: ce33be0195500e4c9f15e707b68f8c8c685bfec0
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Wed Feb 24 10:05:56 2016 +0100
URL: http://code.openbravo.com/tools/automation/int/rev/ce33be0195500e4c9f15e707b68f8c8c685bfec0 [^]

Related to issue 31876 & Related to issue 31902 & Related to issue 31956: Add an automated test

---
M src-test/com/openbravo/test/integration/erp/modules/client/application/gui/FormInputFieldFactory.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/reservation/testsuites/RES_Regressions/RES_RegressionSuite.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/reservation/testsuites/RES_Regressions/build.xml
M src-test/com/openbravo/test/integration/erp/testscripts/SmokeTabScript.java
A src-test/com/openbravo/test/integration/erp/modules/client/application/gui/searchitems/OrderSearchItem.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/reservation/testsuites/RES_Regressions/RESRegression31876R31902R31956.java
---

- Issue History
Date Modified Username Field Change
2016-01-15 11:10 aferraz New Issue
2016-01-15 11:10 aferraz Assigned To => Triage Finance
2016-01-15 11:10 aferraz Modules => Core
2016-01-15 11:10 aferraz Regression level => Production - QA Approved
2016-01-15 11:10 aferraz Regression date => 2015-06-22
2016-01-15 11:10 aferraz Regression introduced in release => 3.0PR15Q4
2016-01-15 11:10 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/e03c1808e1952c20ef838c8a8b976cff802d5156 [^]
2016-01-15 11:10 aferraz Triggers an Emergency Pack => No
2016-01-15 11:10 aferraz Relationship added caused by 0028645
2016-01-15 11:11 aferraz Relationship added related to 0031876
2016-01-15 12:42 aferraz Status new => scheduled
2016-01-15 12:42 aferraz Assigned To Triage Finance => aferraz
2016-01-15 14:43 aferraz Note Added: 0083353
2016-01-15 14:50 aferraz Relationship added related to 0031799
2016-01-18 18:19 psanjuan Note Added: 0083386
2016-01-19 10:10 psanjuan Note Added: 0083394
2016-01-19 10:10 psanjuan Note Edited: 0083353 View Revisions
2016-01-19 10:33 psanjuan Note Edited: 0083394 View Revisions
2016-01-19 10:33 psanjuan Note Edited: 0083394 View Revisions
2016-01-19 10:48 psanjuan Note Edited: 0083394 View Revisions
2016-01-19 10:50 psanjuan Note Edited: 0083394 View Revisions
2016-01-19 10:53 psanjuan Note Edited: 0083394 View Revisions
2016-01-19 18:17 aferraz Relationship added related to 0031956
2016-01-20 13:50 aferraz Note Edited: 0083353 View Revisions
2016-02-04 10:24 psanjuan Note Edited: 0083394 View Revisions
2016-02-04 10:32 psanjuan Note Edited: 0083394 View Revisions
2016-02-04 10:58 psanjuan Note Edited: 0083394 View Revisions
2016-02-04 11:04 psanjuan Note Edited: 0083394 View Revisions
2016-02-04 11:05 psanjuan Note Added: 0083920
2016-02-09 10:26 hgbot Checkin
2016-02-09 10:26 hgbot Note Added: 0084046
2016-02-09 10:26 hgbot Status scheduled => resolved
2016-02-09 10:26 hgbot Resolution open => fixed
2016-02-09 10:26 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d2a064ba63767e527efb2777e849702f98c06a45 [^]
2016-02-09 10:28 dmiguelez Review Assigned To => dmiguelez
2016-02-09 10:28 dmiguelez Note Added: 0084049
2016-02-09 10:28 dmiguelez Status resolved => closed
2016-02-19 13:35 aferraz Note Added: 0084371
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085119
2016-04-08 11:00 hgbot Checkin
2016-04-08 11:00 hgbot Note Added: 0085519
2016-08-20 21:54 aferraz Relationship added related to 0033752


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker