Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031867
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2016-01-12 18:502017-09-14 13:32
ReportermalsasuaView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR16Q2
StatusclosedFix in branchFixed in SCM revisione913a860b967
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-03-05
Regression introduced in release3.0PR14Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/a652f7e46643 [^]
Triggers an Emergency PackNo
Summary

0031867: the trees in the application can not be updated when preference "Use classic popup tree" is enabled

Descriptionwhen a tree is displayed in classic mode (adding the preference "Use classic popup tree"), it can not be modified: if you move one element from one parent to other parent, and you close and open again the tree, the change has not been applied
Steps To Reproduce. configure the preference "Use classic popup tree"
. go to window "product category"
. create new record:
  . name: test
  . is summary: Y
. click in tree button
. move the product category "Bio" inside of "test" node
. close the popup
. open tree again
the element "Bio" is not displayed inside of "test" node
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00318843.0PR16Q1 closedcaristu the trees in the application can not be updated when preference "Use classic popup tree" is enabled 
depends on backport 00318853.0PR15Q4.2 closedcaristu the trees in the application can not be updated when preference "Use classic popup tree" is enabled 
depends on backport 00318863.0PR15Q3.5 closedcaristu the trees in the application can not be updated when preference "Use classic popup tree" is enabled 
caused by feature request 00259063.0PR14Q2 closedAugustoMauch Tree Extension Project 

-  Notes
(0083270)
caristu (developer)
2016-01-13 18:49

The following error is displayed in the log after trying to move a node in "classic mode":

ERROR org.openbravo.base.exception.OBSecurityException - Entity ADTable is not directly readable, only id and identifier properties are readable, property ADTable.treeType is neither of these.
org.openbravo.base.exception.OBSecurityException: Entity ADTable is not directly readable, only id and identifier properties are readable, property ADTable.treeType is neither of these.

The problem is that some part of the code requires to be executed in admin mode. Attached the patch with the fix.
(0083280)
hgbot (developer)
2016-01-14 10:55

Repository: erp/devel/pi
Changeset: e913a860b967fdafd039d5299335b12d25dc2010
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Jan 14 10:49:51 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e913a860b967fdafd039d5299335b12d25dc2010 [^]

fixes issue 31867: can not move tree nodes in classic mode

When moving tree nodes using the classic mode there is a point where the process tries to recover the tree type. This information is stored in the ADTable entity which can not be accessed by non system roles. To prevent this error now the part where the tree type is recovered is executed using the DAL admin mode.

---
M src/org/openbravo/erpCommon/utility/WindowTree.java
---
(0083328)
hgbot (developer)
2016-01-15 09:54

Repository: erp/devel/pi
Changeset: a1e778618363e55a966e2305b5b65da03948d9b9
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Jan 15 09:53:17 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/a1e778618363e55a966e2305b5b65da03948d9b9 [^]

related to issue 31867: code review improvement

---
M src/org/openbravo/erpCommon/utility/WindowTree.java
---
(0083332)
caristu (developer)
2016-01-15 10:23
edited on: 2016-01-15 10:23

In this case an automated test case has not been created, taking into account that the classic mode uses old technology and that the new tree view is also available and it is most commonly used.

However a new test case has been created into TestLink: https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-9983 [^]

(0083334)
alostale (developer)
2016-01-15 11:19

code reviewed + tested
(0085044)
hudsonbot (developer)
2016-03-17 10:54

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test
(0085048)
hudsonbot (developer)
2016-03-17 10:54

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-01-12 18:50 malsasua New Issue
2016-01-12 18:50 malsasua Assigned To => platform
2016-01-12 18:50 malsasua Modules => Core
2016-01-12 18:50 malsasua Triggers an Emergency Pack => No
2016-01-13 15:26 alostale Relationship added related to 0031870
2016-01-13 15:26 alostale Status new => acknowledged
2016-01-13 18:33 caristu Regression level => Production - Confirmed Stable
2016-01-13 18:33 caristu Regression date => 2014-03-05
2016-01-13 18:33 caristu Regression introduced in release => 3.0PR14Q2
2016-01-13 18:33 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/a652f7e46643 [^]
2016-01-13 18:35 caristu Assigned To platform => caristu
2016-01-13 18:49 caristu Note Added: 0083270
2016-01-13 18:49 caristu File Added: issue31870.diff
2016-01-14 10:26 caristu Status acknowledged => scheduled
2016-01-14 10:50 caristu File Deleted: issue31870.diff
2016-01-14 10:55 hgbot Checkin
2016-01-14 10:55 hgbot Note Added: 0083280
2016-01-14 10:55 hgbot Status scheduled => resolved
2016-01-14 10:55 hgbot Resolution open => fixed
2016-01-14 10:55 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e913a860b967fdafd039d5299335b12d25dc2010 [^]
2016-01-15 08:29 alostale Relationship added caused by 0025906
2016-01-15 09:54 hgbot Checkin
2016-01-15 09:54 hgbot Note Added: 0083328
2016-01-15 10:23 caristu Note Added: 0083332
2016-01-15 10:23 caristu Note Edited: 0083332 View Revisions
2016-01-15 11:19 alostale Review Assigned To => alostale
2016-01-15 11:19 alostale Note Added: 0083334
2016-01-15 11:19 alostale Status resolved => closed
2016-01-15 11:19 alostale Fixed in Version => 3.0PR16Q2
2016-03-17 10:54 hudsonbot Checkin
2016-03-17 10:54 hudsonbot Note Added: 0085044
2016-03-17 10:54 hudsonbot Checkin
2016-03-17 10:54 hudsonbot Note Added: 0085048
2017-09-14 13:32 caristu Relationship deleted related to 0031870


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker