Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031695
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 03. Procurement managementmajoralways2015-12-10 18:242015-12-17 17:49
ReporterVictorVillarView Statuspublic 
Assigned Tovmromanos 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q1
StatusclosedFix in branchFixed in SCM revision653ed78431dc
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-02-20
Regression introduced in release3.0PR14Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/2fc504a99106068f4d0dcd5af1f1c8bbf70721c3#l1.6 [^]
Triggers an Emergency PackNo
Summary

0031695: Return to vendor shipments appear in the pick and edit lines of the return to vendor

DescriptionReturn to vendor shipments appear in the pick and edit lines of the return to vendor
Steps To ReproduceCreate a Return To Vendor and select a Goods Receipt: one line, entire quantity. Process it
Create a Return To vendor shipment and select the return to vendor created before. Process it.
Create a new Return To Vendor - P&Edit lines. Realise that the return to vendor shipment appear.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00317233.0PR15Q4.2 closedvmromanos Return to vendor shipments appear in the pick and edit lines of the return to vendor 
depends on backport 00317243.0PR15Q3.5 closedvmromanos Return to vendor shipments appear in the pick and edit lines of the return to vendor 
caused by feature request 0025814 closedSandrahuguet Create a new return to vendor pick and edit with manual datasource 

-  Notes
(0082755)
AtulOpenbravo (developer)
2015-12-15 10:24

Test Plan
- Login as F&B International Group Admin.
- Create a Return To Vendor and select a Goods Receipt: one line, entire quantity. Process it.
- Create a Return To vendor shipment and select the return to vendor created in previous step. Process it.
- Create a new Return To Vendor and add P&Edit lines. Check that previous Return To Vendor Shipment line record does not appear anymore in the selection.
(0082794)
psanjuan (manager)
2015-12-16 09:41

Issue verified.
(0082795)
psanjuan (manager)
2015-12-16 10:09
edited on: 2015-12-16 11:13

Test Plan:

- Login as F&B International Group Admin.
- Create a Goods Receipt for F&B España org and BP "Bebidas Alegres", dated on today's date.
- Go to lines tab and select the product "Aguas sin Gas 1L". Enter a movement quantity = 222. Select any storage bien.
- Complete it.
- Go to Return to Vendor window and create a new one for same org and BP, dated on today's date.
- Click on Pick/Edit Lines button.
- Select the receipt previously created for a movement quantity = 222 unit. Enter a returned quantity of 222. Press Done
- Book the document.
- Go to Return to Vendor Shipment and create a new one for same org and BP, dated on today's date.
- Click on Pick/Edit Lines button.
- Select the return to vendor just created for a quantity = 222. Ship Qty = 222. Press Done
- Complete it
- Go to Return to Vendor window and create a new one for the same Org and BP, dated on today's date.
- Click on Pick/Edit Lines button.
- Verify that return to vendor shipment for -222 is not shown.

Repeat same steps for partial returns, for instance a goods receipt of 15 units, after that a return to vendor & return to vendor shipment of 7 units. Then a return to vendor & return to vendor shipment of 8 units.
Once second return to vendor shipment is complete, that goods receipt (shipment) is not longer show in pick/edit lines window of the return to vendor window.

Issue can be code reviewed and closed.

(0082798)
hgbot (developer)
2015-12-16 12:52

Repository: erp/devel/pi
Changeset: 653ed78431dce51f1e58ba4354dddab4641bd356
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Tue Dec 15 14:54:22 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/653ed78431dce51f1e58ba4354dddab4641bd356 [^]

Fixed bug 31695: Return to vendor shipments can be selected in return to vendor

The HQL query in charge of getting the shipment lines was wrongly including all the shipment documents. Instead it should be taking only the lines belonging to a non-return shipment document.

This feature was lost during the refactor to a manual datasource P&E

---
M src-db/database/sourcedata/AD_TABLE.xml
---
(0082799)
aferraz (developer)
2015-12-16 12:53

Code review OK
(0082847)
hudsonbot (developer)
2015-12-17 17:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7bb1cbcee3ce [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-12-10 18:24 VictorVillar New Issue
2015-12-10 18:24 VictorVillar Assigned To => Triage Finance
2015-12-10 18:24 VictorVillar Modules => Core
2015-12-10 18:24 VictorVillar Regression level => Production - QA Approved
2015-12-10 18:24 VictorVillar Regression introduced in release => 3.0PR15Q4
2015-12-10 18:24 VictorVillar Triggers an Emergency Pack => No
2015-12-10 18:25 VictorVillar Issue Monitored: networkb
2015-12-13 19:34 AtulOpenbravo Assigned To Triage Finance => AtulOpenbravo
2015-12-13 19:34 AtulOpenbravo Status new => scheduled
2015-12-15 10:24 AtulOpenbravo Note Added: 0082755
2015-12-15 14:56 vmromanos Regression level Production - QA Approved => Production - Confirmed Stable
2015-12-15 14:56 vmromanos Regression date => 2014-02-20
2015-12-15 14:56 vmromanos Regression introduced in release 3.0PR15Q4 => 3.0PR14Q2
2015-12-15 14:56 vmromanos Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/2fc504a99106068f4d0dcd5af1f1c8bbf70721c3#l1.6 [^]
2015-12-15 14:56 vmromanos Steps to Reproduce Updated View Revisions
2015-12-15 14:57 vmromanos Assigned To AtulOpenbravo => vmromanos
2015-12-15 14:57 vmromanos Status scheduled => acknowledged
2015-12-15 14:58 vmromanos Status acknowledged => scheduled
2015-12-15 16:22 vmromanos Relationship added caused by 0025814
2015-12-16 09:41 psanjuan Note Added: 0082794
2015-12-16 10:09 psanjuan Note Added: 0082795
2015-12-16 10:56 psanjuan Note Edited: 0082795 View Revisions
2015-12-16 10:57 psanjuan Note Edited: 0082795 View Revisions
2015-12-16 11:13 psanjuan Note Edited: 0082795 View Revisions
2015-12-16 12:52 hgbot Checkin
2015-12-16 12:52 hgbot Note Added: 0082798
2015-12-16 12:52 hgbot Status scheduled => resolved
2015-12-16 12:52 hgbot Resolution open => fixed
2015-12-16 12:52 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/653ed78431dce51f1e58ba4354dddab4641bd356 [^]
2015-12-16 12:53 aferraz Review Assigned To => aferraz
2015-12-16 12:53 aferraz Note Added: 0082799
2015-12-16 12:53 aferraz Status resolved => closed
2015-12-16 12:53 aferraz Fixed in Version => 3.0PR16Q1
2015-12-17 17:49 hudsonbot Checkin
2015-12-17 17:49 hudsonbot Note Added: 0082847


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker