Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031566
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2015-11-24 18:332015-11-30 10:46
ReportermaiteView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR16Q1
StatusclosedFix in branchFixed in SCM revision71227823d930
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0031566: Error when closing window where view personalization and grid configuration are defined

DescriptionError when closing window where view personalization and grid configuration are defined
Steps To Reproduce1. Ensure that instance is active
2. Access Producto window, filter by Active=Yes and save view as "active products"
3. Move Active column to be the first one of the grid
4. Close window
5. Access Product window again (NOT by clicking on Recent Views by searching it) and try to close window. Realize that tab is left blank and following javascript error is raised "Uncaught TypeError: Cannot read property 'dataPath' of null"

NOTE: if you select any product record then you will be able to close the window
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0082415)
caristu (developer)
2015-11-27 11:11

This can be reproduced also when closing any tab having the focus on the filter of a yes/no field.
(0082423)
hgbot (developer)
2015-11-27 12:29

Repository: erp/devel/pi
Changeset: 71227823d93070ee91799425511be0bd8a0de7b0
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Nov 27 12:19:15 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/71227823d93070ee91799425511be0bd8a0de7b0 [^]

fixes issue 31566: Error when closing window having focus on a yes/no filter

When closing the tab having the focus on a OBYesNoItem, the handleEditorExit() method of this class is executed, causing an unexpected javascript error on the getCriteriaFieldName() method, because is not possible to reference the form as it is being destroyed.

It does not make sense to execute handleEditorExit() when closing (destroying) the window. So to avoid this execution we introduce a new flag for the items (isBeingDestroyed) to mark that they are being destroyed. Thus, it is used for OBYesNoItem to identify whether standard handleEditorExit() flow must be executed or not.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-yesno.js
M modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/js/ob-smartclient.js
---
(0082450)
hudsonbot (developer)
2015-11-28 15:24

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a30fd74371da [^]
Maturity status: Test
(0082464)
alostale (developer)
2015-11-30 10:46

code reviewed + tested

- Issue History
Date Modified Username Field Change
2015-11-24 18:33 maite New Issue
2015-11-24 18:33 maite Assigned To => platform
2015-11-24 18:33 maite Modules => Core
2015-11-24 18:33 maite Triggers an Emergency Pack => No
2015-11-24 18:33 maite Issue Monitored: networkb
2015-11-27 11:11 caristu Severity minor => major
2015-11-27 11:11 caristu Note Added: 0082415
2015-11-27 11:11 caristu Assigned To platform => caristu
2015-11-27 11:11 caristu Status new => scheduled
2015-11-27 12:29 caristu Review Assigned To => alostale
2015-11-27 12:29 caristu Issue Monitored: alostale
2015-11-27 12:29 hgbot Checkin
2015-11-27 12:29 hgbot Note Added: 0082423
2015-11-27 12:29 hgbot Status scheduled => resolved
2015-11-27 12:29 hgbot Resolution open => fixed
2015-11-27 12:29 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/71227823d93070ee91799425511be0bd8a0de7b0 [^]
2015-11-28 15:24 hudsonbot Checkin
2015-11-28 15:24 hudsonbot Note Added: 0082450
2015-11-30 10:46 alostale Note Added: 0082464
2015-11-30 10:46 alostale Status resolved => closed
2015-11-30 10:46 alostale Fixed in Version => 3.0PR16Q1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker