Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031462
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajorhave not tried2015-11-13 11:342016-02-03 13:26
ReporteramayavicenteView Statuspublic 
Assigned Tomario_castello 
PriorityimmediateResolutionfixedFixed in VersionRR16Q1
StatusclosedFix in branchFixed in SCM revision93edf52d7cd7
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression levelProduction - QA Approved
Regression date
Regression introduced in releasemain
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/dfc486fb9f9a [^]
Triggers an Emergency PackNo
Summary

0031462: [RR15Q4] The status of a layaway does not change after 'Void this layaway'

DescriptionThe status of a layaway does not change after 'Void this layaway'. It is still 'Booked' instead 'Closed'.
Steps To Reproduce1. Log into the webpos.
2. Create Layaway without payments.
3. Select 'Layaways' in the menu and load the layaway created previously.
4. Select 'Void this Layaway'in the menu and click the button 'Done'.
5. Select 'Layaways' in the menu again ERROR: check that the previous layaway can be selected again and it shouldn't.
6. Log into the backend, the status of the layaway is 'Booked' instead 'Closed.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0031469RR15Q4 closedRetail [RR15Q4] The status of a layaway does not change after 'Void this layaway' 
caused by defect 0031150 closedmarvintm Triggers stay disabled when a layaway is voided with pending payments 
has duplicate defect 0031520 closedRetail Voiding a Layaway without payments is not working 
related to defect 0031471 closedguilleaer Issue when paying in WEB POS a layaway that was invoiced in backend. The sales order is invoiced again. 
related to defect 0032464RR16Q2 closedmarvintm When using Void Layaway, it's possible that triggers in the application may be disabled 

-  Notes
(0081828)
hgbot (developer)
2015-11-13 15:10

Repository: tools/automation/pi-mobile
Changeset: c7df9a6c8166f77e296fb88b9638c50f1e0b5fd4
Author: Rafa Alonso <ral <at> openbravo.com>
Date: Fri Nov 13 15:06:58 2015 +0100
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/c7df9a6c8166f77e296fb88b9638c50f1e0b5fd4 [^]

Verifies issue 31462: Added automation test

---
A src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/layaway/I31462_VoidLayaway.java
---
(0081930)
hgbot (developer)
2015-11-17 15:40

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 429cc02b982d2bed0d21cc2b8d2360de41f7936d
Author: Mario Castello <mario.castello <at> peoplewalking.com>
Date: Tue Nov 17 08:39:32 2015 -0600
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/429cc02b982d2bed0d21cc2b8d2360de41f7936d [^]

Fixed issue 31462: Added commit to final code

---
M src/org/openbravo/retail/posterminal/ProcessVoidLayaway.java
---
(0082028)
hgbot (developer)
2015-11-20 15:06

Repository: tools/automation/pi-mobile
Changeset: 93edf52d7cd7f6cac57c26530f0986e03891556d
Author: Mario Castello <mario.castello <at> peoplewalking.com>
Date: Fri Nov 20 08:05:55 2015 -0600
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/93edf52d7cd7f6cac57c26530f0986e03891556d [^]

Fixed issue 31462: Fixed automated test

---
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/layaway/I31462_VoidLayaway.java
---
(0083894)
hgbot (developer)
2016-02-03 13:26

Repository: tools/automation/pi-mobile
Changeset: a738f2675f29aa45ffdc15d7c7d79494ed3ae81e
Author: Rafa Alonso <ral <at> openbravo.com>
Date: Wed Feb 03 11:50:51 2016 +0100
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/a738f2675f29aa45ffdc15d7c7d79494ed3ae81e [^]

Verifies issue 31462: Added automation test

---
A src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/layaway/I31462_VoidLayaway.java
---

- Issue History
Date Modified Username Field Change
2015-11-13 11:34 amayavicente New Issue
2015-11-13 11:34 amayavicente Assigned To => Retail
2015-11-13 11:34 amayavicente Regression level => Production - QA Approved
2015-11-13 11:34 amayavicente Triggers an Emergency Pack => No
2015-11-13 11:54 Orekaria Severity critical => major
2015-11-13 11:54 Orekaria Status new => acknowledged
2015-11-13 13:54 Orekaria Regression introduced in release => main
2015-11-13 13:54 Orekaria Summary The status of a layaway does not change after 'Void this layaway' => [RR15Q4] The status of a layaway does not change after 'Void this layaway'
2015-11-13 14:14 Orekaria Target Version => RR15Q4.1
2015-11-13 14:14 Orekaria Target Version RR15Q4.1 =>
2015-11-13 14:14 Orekaria Status acknowledged => scheduled
2015-11-13 14:14 Orekaria Status scheduled => acknowledged
2015-11-13 15:10 hgbot Checkin
2015-11-13 15:10 hgbot Note Added: 0081828
2015-11-13 15:26 Orekaria Relationship added related to 0031471
2015-11-16 15:47 mario_castello Assigned To Retail => mario_castello
2015-11-16 15:48 mario_castello Status acknowledged => scheduled
2015-11-16 16:21 Orekaria Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/dfc486fb9f9a [^]
2015-11-16 16:22 Orekaria Relationship added caused by 0031150
2015-11-17 15:40 hgbot Checkin
2015-11-17 15:40 hgbot Note Added: 0081930
2015-11-17 15:40 hgbot Status scheduled => resolved
2015-11-17 15:40 hgbot Resolution open => fixed
2015-11-17 15:40 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/429cc02b982d2bed0d21cc2b8d2360de41f7936d [^]
2015-11-17 15:49 Orekaria Review Assigned To => marvintm
2015-11-18 09:29 migueldejuana Relationship added has duplicate 0031520
2015-11-18 10:04 jorge-garcia Status resolved => new
2015-11-18 10:04 jorge-garcia Resolution fixed => open
2015-11-18 10:04 jorge-garcia Status new => scheduled
2015-11-20 15:06 hgbot Checkin
2015-11-20 15:06 hgbot Note Added: 0082028
2015-11-20 15:06 hgbot Status scheduled => resolved
2015-11-20 15:06 hgbot Resolution open => fixed
2015-11-20 15:06 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/429cc02b982d2bed0d21cc2b8d2360de41f7936d [^] => http://code.openbravo.com/tools/automation/pi-mobile/rev/93edf52d7cd7f6cac57c26530f0986e03891556d [^]
2015-12-04 12:55 marvintm Status resolved => closed
2015-12-04 12:55 marvintm Fixed in Version => RR16Q1
2016-02-03 13:26 hgbot Checkin
2016-02-03 13:26 hgbot Note Added: 0083894
2016-03-11 16:27 marvintm Relationship added related to 0032464


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker