Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031389
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersminoralways2015-11-06 10:502015-11-23 21:17
ReportermaiteView Statuspublic 
Assigned Toaferraz 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionfcda68dddca6
ProjectionnoneETAnoneTarget Version3.0PR16Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesAdvanced Payables and Receivables Mngmt
Regression levelProduction - Confirmed Stable
Regression date2014-09-23
Regression introduced in release3.0PR14Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/179d97ee602d [^]
Triggers an Emergency PackNo
Summary

0031389: Hover over Matched Document does not show document details information as before, in Match Statement pop-up

DescriptionBefore Match Statement refactor, if you hover over "Matched document" field document details information was shown: invoice/order documentno or gl item information
Steps To Reproduce1. Access Cuenta de Banco financial account, create new Bank Statement record and line with amount in=15 and process bank statement.
2. Register Sales Invoice with total gross =15. Process invoice
3. Register payment related with the invoice.
4. Run "Match Statement" process and match bank statement line with previous payment.
5. Hover over "Matched Document" field and realize that no information abut invoice appear

If you follow similar process in version prior to refactor (for example MP30.3) you can verify that invoice's document number appears
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00314423.0PR15Q4 closedaferraz Hover over Matched Document does not show document details information as before, in Match Statement pop-up 
depends on backport 00314433.0PR15Q3.4 closedaferraz Hover over Matched Document does not show document details information as before, in Match Statement pop-up 
caused by feature request 00293903.0PR14Q4 closedSandrahuguet Reconciliation refactor project 
causes defect 00315153.0PR16Q1 closedaferraz Empty matched document when running Match Statement pocess 

-  Notes
(0081725)
aferraz (manager)
2015-11-11 18:17

Test plan:

As F&B Admin:

- Create a Sales Invoice for Alimentos y Supermercados.
  Add a line with Agua sin gas product and quantity 10.
  Process it. Let's say it has document number: 1000160.
  Click on Add Payment and process and deposit it.

- Access Cuenta de Banco Financial Account.
  Create new Bank Statement record.
  Create new line with amount in 18.51 (invoice gross amount), business partner Alimentos y Supermercados, business partner name "name of my bp" and description "bsl description".
  Process bank statement.

- Run "Match Statement" process.
  Select Ok when asking for automatic matching.
  Clear filter.
  Show Business Partner Name, Description and Transaction Description columns.
  Realize your bank statement line is shown as matched with the following information:
  Sender: "Alimentos y Supermercados", Business Partner Name: "name of my bp", Description: "bsl description", Transaction Description: "Invoice No.: 1000160".

As System Admin:

- Go to Match Statement P&E window, select Match Statement tab and check show in grid view flag for the following fields: Business Partner Name, Description and Transaction Description.
  
As F&B Admin:

- Access Cuenta de Banco Financial Account.
  Click on Match Statement.
  Clear filter.
  Realize your matched bank statement line is shown with the same information and Business Partner Name, Description and Transaction Description columns are shown by default.
(0081782)
hgbot (developer)
2015-11-12 19:20

Repository: erp/devel/pi
Changeset: fe7e7c17712bcf75d97d44bc313b0d3e6e5d6377
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Wed Nov 11 20:01:21 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/fe7e7c17712bcf75d97d44bc313b0d3e6e5d6377 [^]

Fixes issue 31387 & Fixes issue 31389: Add two new columns in Match Statement

Added Business Partner Name and Transaction Description as new fields in Match Statement P&E window. They will not be shown in grid by default.
HQL Query in aprm_matchstatement table has been modified to retrieve this two new columns from FIN_BankStatementLine and FIN_Finacc_Transaction tables, and to retrieve bp.name as businessPartner also in case it is null.

---
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/AD_FIELD.xml
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/AD_TABLE.xml
---
(0081784)
hgbot (developer)
2015-11-12 19:20

Repository: erp/devel/pi
Changeset: fcda68dddca6df0c946d754ec956f7635ce0fe9c
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Thu Nov 12 18:42:04 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/fcda68dddca6df0c946d754ec956f7635ce0fe9c [^]

Fixes issue 31387 & Fixes issue 31389: code review improvements

Reverted back the behavior of the Sender field. It shows the Business Partner Name (from the OB object) or the Business Partner Name string as it was doing before.

---
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/AD_TABLE.xml
---
(0081796)
vmromanos (developer)
2015-11-12 19:27

Code review + testing OK
(0082031)
aferraz (manager)
2015-11-20 15:12

https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-8627 [^]
(0082218)
hudsonbot (developer)
2015-11-23 21:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test
(0082220)
hudsonbot (developer)
2015-11-23 21:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-11-06 10:50 maite New Issue
2015-11-06 10:50 maite Assigned To => Triage Finance
2015-11-06 10:50 maite Modules => Advanced Payables and Receivables Mngmt
2015-11-06 10:50 maite Resolution time => 1449702000
2015-11-06 10:50 maite Triggers an Emergency Pack => No
2015-11-06 10:52 maite Summary Hover over Matched Document does not show Invoice/Order information as before, in Match Statement pop-up => Hover over Matched Document does not show document details information as before, in Match Statement pop-up
2015-11-06 10:52 maite Description Updated View Revisions
2015-11-06 10:52 maite Issue Monitored: networkb
2015-11-10 12:33 hgbot Checkin
2015-11-10 12:33 hgbot Note Added: 0081643
2015-11-10 13:48 aferraz Assigned To Triage Finance => aferraz
2015-11-10 13:55 aferraz Relationship added caused by 0029390
2015-11-10 13:58 aferraz Regression level => Production - Confirmed Stable
2015-11-10 13:58 aferraz Regression date => 2014-09-23
2015-11-10 13:58 aferraz Regression introduced in release => 3.0PR14Q4
2015-11-10 13:58 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/179d97ee602d [^]
2015-11-11 18:17 aferraz Note Added: 0081725
2015-11-12 10:14 aferraz Status new => scheduled
2015-11-12 17:39 vmromanos Note Deleted: 0081643
2015-11-12 19:20 hgbot Checkin
2015-11-12 19:20 hgbot Note Added: 0081782
2015-11-12 19:20 hgbot Status scheduled => resolved
2015-11-12 19:20 hgbot Resolution open => fixed
2015-11-12 19:20 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/fe7e7c17712bcf75d97d44bc313b0d3e6e5d6377 [^]
2015-11-12 19:20 hgbot Checkin
2015-11-12 19:20 hgbot Note Added: 0081784
2015-11-12 19:20 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/fe7e7c17712bcf75d97d44bc313b0d3e6e5d6377 [^] => http://code.openbravo.com/erp/devel/pi/rev/fcda68dddca6df0c946d754ec956f7635ce0fe9c [^]
2015-11-12 19:27 vmromanos Review Assigned To => vmromanos
2015-11-12 19:27 vmromanos Note Added: 0081796
2015-11-12 19:27 vmromanos Status resolved => closed
2015-11-17 15:23 aferraz Relationship added causes 0031515
2015-11-20 15:12 aferraz Note Added: 0082031
2015-11-23 21:17 hudsonbot Checkin
2015-11-23 21:17 hudsonbot Note Added: 0082218
2015-11-23 21:17 hudsonbot Checkin
2015-11-23 21:17 hudsonbot Note Added: 0082220


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker