Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031382
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 03. Procurement managementmajoralways2015-11-05 18:572015-11-23 21:17
ReporterngarciaView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision10ff05690b1a
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0031382: Purchase Order and Goods Receipt not shown in Invoice's Create Lines From if the Customer Invoice Terms are Do Not Invoice

DescriptionPurchase Order and the related Goods Receipt not shown in Invoice's Create Lines From if the Customer Invoice Terms are Do Not Invoice. The problem is that the Invoice Terms (invoicerule) are set with the customer's default in purchase order window and the field is not shown
Steps To ReproduceAs group admin role:
   Create a Business Partner and add a location to it
   Set it as Customer and define its default Invoice Terms as Do Not Invoice
   Set it as Vendor too
   Create a Purchase Order to that BP
   Create a Purchase Invoice header for the same BP and check the order is not shown in the Create Lines combo
   Create a Goods Receipt from the order
   Go to the previously created invoice and check the receipt is not shown in the Create Lines combo
Proposed SolutionDo not set the invoicerule in the SE_Order_BPartner callout for purchase orders, but default the field to I (Immediate)
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00314023.0PR15Q4 closedAtulOpenbravo Purchase Order and Goods Receipt not shown in Invoice's Create Lines From if the Customer Invoice Terms are Do Not Invoice 
depends on backport 00314033.0PR15Q3.4 closedAtulOpenbravo Purchase Order and Goods Receipt not shown in Invoice's Create Lines From if the Customer Invoice Terms are Do Not Invoice 
caused by defect 00275743.0PR15Q1 closedreinaldoguerra Invoice rule - Do not invoice not working in create lines from in purchase flow 

-  Notes
(0081566)
AtulOpenbravo (developer)
2015-11-06 13:19

Test Plan
- Login as Group admin role.
- Create a Business Partner and add a location to it.
- Set it as Customer and define its default Invoice Terms as Do Not Invoice.
- Set it as Vendor too.
- Create a Purchase Order to that BP
- Create a Purchase Invoice header for the same BP and check the order is shown in the Create Lines combo.
- Create a Goods Receipt from the order.
- Go to the previously created invoice and check the receipt is shown in the Create Lines combo.
(0081600)
hgbot (developer)
2015-11-09 09:09

Repository: erp/devel/pi
Changeset: 10ff05690b1ab1db8e89a6b388ee38b2c0c2e689
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Fri Nov 06 16:42:23 2015 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/10ff05690b1ab1db8e89a6b388ee38b2c0c2e689 [^]

Fixes Issue 31382:Purchase Order and Goods Receipt not shown in Invoice's
Create Lines From if the Customer Invoice Terms are Do Not Invoice

In case of purchase flow Immediate (I) is set as default value for
Invoice Rule.

---
M src/org/openbravo/erpCommon/ad_callouts/SE_Order_BPartner.java
---
(0081603)
vmromanos (developer)
2015-11-09 09:09

Code review + testing OK
(0082188)
hudsonbot (developer)
2015-11-23 21:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-11-05 18:57 ngarcia New Issue
2015-11-05 18:57 ngarcia Assigned To => Triage Finance
2015-11-05 18:57 ngarcia Modules => Core
2015-11-05 18:57 ngarcia Triggers an Emergency Pack => No
2015-11-05 18:58 ngarcia Issue Monitored: networkb
2015-11-05 18:58 ngarcia Relationship added related to 0027574
2015-11-05 19:09 ngarcia Relationship replaced caused by 0027574
2015-11-06 13:17 AtulOpenbravo Assigned To Triage Finance => AtulOpenbravo
2015-11-06 13:19 AtulOpenbravo Status new => scheduled
2015-11-06 13:19 AtulOpenbravo Note Added: 0081566
2015-11-09 09:05 vmromanos Status scheduled => acknowledged
2015-11-09 09:05 vmromanos Status acknowledged => scheduled
2015-11-09 09:09 hgbot Checkin
2015-11-09 09:09 hgbot Note Added: 0081600
2015-11-09 09:09 hgbot Status scheduled => resolved
2015-11-09 09:09 hgbot Resolution open => fixed
2015-11-09 09:09 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/10ff05690b1ab1db8e89a6b388ee38b2c0c2e689 [^]
2015-11-09 09:09 vmromanos Review Assigned To => vmromanos
2015-11-09 09:09 vmromanos Note Added: 0081603
2015-11-09 09:09 vmromanos Status resolved => closed
2015-11-23 21:17 hudsonbot Checkin
2015-11-23 21:17 hudsonbot Note Added: 0082188


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker