Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031225
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] B. User interfacemajoralways2015-10-22 14:082015-10-23 09:13
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR15Q3.2
StatusclosedFix in branchFixed in SCM revision787c27938a67
ProjectionnoneETAnoneTarget Version3.0PR15Q3.2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelPackaging and release
Regression date2015-10-13
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/da1f8f6d7339b4f799da52ec735f3fcb5b97a636 [^]
Triggers an Emergency PackNo
Summary

0031225: Toolbar disappears under some circumnstances

DescriptionToolbar disappears (see attached) under some circumnstances.
Steps To Reproduce1) Go to the [Goods Shipments] window
2) Create a new record in the header
3) Navigate to the [Lines] tab
4) Create a new record
5) Without saving the record, click on the header tab (on the top, in the green part where the name of the header is placed). Notice that the toolbar is gone.

The following error appears on the client console: Uncaught TypeError: Cannot read property 'parameters' of null
Proposed SolutionThe problem is on ob-standard-window.js file at this point:

dirtyEditForm.autoSave(action.parameters);

it shoulr be checked if action is null.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0031217 closedplatform Toolbar disappears under some circumnstances 

-  Notes
(0081237)
hgbot (developer)
2015-10-22 18:28

Repository: erp/backports/3.0PR15Q3.2
Changeset: 787c27938a6786208620f81e98b0f7e10197cbc4
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Oct 22 18:28:21 2015 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR15Q3.2/rev/787c27938a6786208620f81e98b0f7e10197cbc4 [^]

fixes issue 31225: Toolbar disappears under some circumnstances

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-window.js
---
(0081243)
AugustoMauch (developer)
2015-10-23 09:13

Code reviewed and verified in [1]@787c27938a67

[1] https://code.openbravo.com/erp/backports/3.0PR15Q3.2 [^]

- Issue History
Date Modified Username Field Change
2015-10-22 16:28 caristu Type defect => backport
2015-10-22 16:28 caristu Target Version => 3.0PR15Q3.2
2015-10-22 18:28 hgbot Checkin
2015-10-22 18:28 hgbot Note Added: 0081237
2015-10-22 18:28 hgbot Status scheduled => resolved
2015-10-22 18:28 hgbot Resolution open => fixed
2015-10-22 18:28 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q3.2/rev/787c27938a6786208620f81e98b0f7e10197cbc4 [^]
2015-10-22 18:29 caristu Review Assigned To => AugustoMauch
2015-10-22 18:29 caristu Assigned To platform => caristu
2015-10-23 09:13 AugustoMauch Note Added: 0081243
2015-10-23 09:13 AugustoMauch Status resolved => closed
2015-10-23 09:13 AugustoMauch Fixed in Version => 3.0PR15Q3.2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker