Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031169
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 05. Production managementmajoralways2015-10-09 12:272015-10-20 12:04
ReporterngarciaView Statuspublic 
Assigned ToTriage Finance 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionccad7ba6fe49
ProjectionnoneETAnoneTarget Version3.0PR15Q2.6
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-04-24
Regression introduced in release3.0PR14Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/b856094303a9c6daff6db1d67e29563d273d512a [^]
Triggers an Emergency PackNo
Summary

0031169: Copy Version process in Process Plan window is not working in Oracle

DescriptionCopy Version process in Process Plan window is not working in Oracle
Steps To ReproduceAs group admin role:
   Create a Process Plan, Version, Operation...
   Click on the Copy Version and select the already created version
   Check no new version is created and the logs shows:
      ERROR org.openbravo.base.exception.OBException - java.sql.SQLSyntaxErrorException: ORA-00904: "AD_SEQUENCE_DOC": invalid identifier

java.lang.IllegalStateException: java.sql.SQLSyntaxErrorException: ORA-00904: "AD_SEQUENCE_DOC": invalid identifier

    at org.openbravo.service.db.CallStoredProcedure.call(CallStoredProcedure.java:142)
    at org.openbravo.common.actionhandler.CopyProcessPlanVersion.callAdSequenceDoc(CopyProcessPlanVersion.java:188)
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0031121 closedvmromanos Copy Version process in Process Plan window is not working in Oracle 

-  Notes
(0081122)
hgbot (developer)
2015-10-20 12:04

Repository: erp/backports/3.0PR15Q2.6
Changeset: ccad7ba6fe495d7da569f6765cd52a52d8a83a7f
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Mon Oct 19 12:38:32 2015 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR15Q2.6/rev/ccad7ba6fe495d7da569f6765cd52a52d8a83a7f [^]

Fixed bug 31169: Copy Version process in Process Plan window is not working in Oracle

Ad_Sequence_Doc is a stored procedure that returns the next sequence number using an "out" parameter. The CallStoredProcedure.call() used to call that procedure doesn't currently support parameters of type "out", creating an exception in Oracle only (and not in PostgreSQL because the procedure is declared as a function returning the value).

Instead of calling the procedure using CallStoredProcedure.call(), we use Utility.getDocumentNo() method instead, which is a more standard way to get the next sequence no. from Java, and supports Oracle procedures with "out" parameters.

Besides the class has been modified to properly show an error message in the UI in case an exception is raised, which is something not working before neither.

---
M src/org/openbravo/common/actionhandler/CopyProcessPlanVersion.java
---
(0081123)
dmiguelez (developer)
2015-10-20 12:04

Code Review + Testing Ok

- Issue History
Date Modified Username Field Change
2015-10-19 12:18 vmromanos Type defect => backport
2015-10-19 12:18 vmromanos Target Version => 3.0PR15Q2.6
2015-10-19 12:19 vmromanos Tag Attached: Approved
2015-10-20 12:04 hgbot Checkin
2015-10-20 12:04 hgbot Note Added: 0081122
2015-10-20 12:04 hgbot Status scheduled => resolved
2015-10-20 12:04 hgbot Resolution open => fixed
2015-10-20 12:04 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q2.6/rev/ccad7ba6fe495d7da569f6765cd52a52d8a83a7f [^]
2015-10-20 12:04 dmiguelez Review Assigned To => dmiguelez
2015-10-20 12:04 dmiguelez Note Added: 0081123
2015-10-20 12:04 dmiguelez Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker