Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031070
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2015-10-06 17:012015-11-23 21:17
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityurgentResolutionfixedFixed in Version3.0PR16Q1
StatusclosedFix in branchFixed in SCM revisionb59a2f4e4a11
ProjectionnoneETAnoneTarget Version3.0PR16Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0031070: Deleting pop-up is never closed under some circumnstances

DescriptionDeleting pop-up is never closed if we click on edit record and then we click on the delete button of the toolbar.
Steps To Reproduce1) Go to the Sales Invoice window
2) Create a new record in the header
3) Go to the Lines tab, and create a new record
4) Still on the Lines tab, in grid view, click on the edit icon
5) Without saving the record, click directly on the delete button of the toolbar

Notice that the record is deleted but the deleting pop-up is not closed
TagsNo tags attached.
Attached Filespng file icon popUpNotHidden.png [^] (46,669 bytes) 2015-10-06 17:02

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0081719)
hgbot (developer)
2015-11-11 16:44

Repository: erp/devel/pi
Changeset: b59a2f4e4a114754328a34722d4f7c64c56ade2e
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Nov 11 16:42:20 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/b59a2f4e4a114754328a34722d4f7c64c56ade2e [^]

fixes issue 31070: Deleting pop-up is never closed under some circumnstances

The problem was that when removing a record that is being editing, the updateTabTitle function was crashing when trying to access to this.viewGrid.getEditForm().isNew because this.viewGrid.getEditForm() is undefined at that point.

Apart from this, the isEditingGrid is not restored to false when removing a record which is being edited. This caused new errors after removing, because the view is not marked as in non-editing state. For this reason, now the isEditingGrid value is set to false for this case also.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0081867)
alostale (developer)
2015-11-16 12:02

code reviewed

tested:
- Deletion in grid while editing without saving
- Deletion in grid not editing
- Deletion in grid multiple record
- Deletion in form
(0082198)
hudsonbot (developer)
2015-11-23 21:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-10-06 17:01 caristu New Issue
2015-10-06 17:01 caristu Assigned To => platform
2015-10-06 17:01 caristu Modules => Core
2015-10-06 17:01 caristu Triggers an Emergency Pack => No
2015-10-06 17:02 caristu File Added: popUpNotHidden.png
2015-10-06 17:02 caristu Issue Monitored: networkb
2015-10-07 08:31 alostale Status new => acknowledged
2015-10-07 08:31 alostale Target Version => 3.0PR16Q1
2015-11-11 11:33 alostale Priority high => urgent
2015-11-11 12:26 caristu Assigned To platform => caristu
2015-11-11 12:26 caristu Status acknowledged => scheduled
2015-11-11 16:43 caristu Review Assigned To => alostale
2015-11-11 16:43 caristu Issue Monitored: alostale
2015-11-11 16:44 hgbot Checkin
2015-11-11 16:44 hgbot Note Added: 0081719
2015-11-11 16:44 hgbot Status scheduled => resolved
2015-11-11 16:44 hgbot Resolution open => fixed
2015-11-11 16:44 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b59a2f4e4a114754328a34722d4f7c64c56ade2e [^]
2015-11-16 12:02 alostale Note Added: 0081867
2015-11-16 12:02 alostale Status resolved => closed
2015-11-16 12:02 alostale Fixed in Version => 3.0PR16Q1
2015-11-23 21:17 hudsonbot Checkin
2015-11-23 21:17 hudsonbot Note Added: 0082198


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker