Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031038
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2015-10-05 09:512015-10-05 10:05
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q1
StatusclosedFix in branchFixed in SCM revision241c38dab7ce
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0031038: API change: default value defined as preference will prevail over default defined in column

DescriptionSo far default values defined as a preference were not taken into account in case the column that should be applied to had a default value.

Being preference more explicit, they should prevail over column's default overwriting it.
Steps To ReproduceSee 0030993
Proposed SolutionAccept this behavioral API change.

Checking in a clean distribution + retail instance.

There are 11 [1] cases where a preference is used to define default value for a field. None of these cases are affected by this change because in all the cases the column associated with the field defaulted by the preference has no default value [2].

[1]
select *
  from ad_preference p
  where exists (select 1 from ad_column where columnname ilike p.attribute)

[2]
  select p.attribute, p.value, w.name, t.name
  from ad_preference p, ad_column c, ad_field f, ad_tab t, ad_window w
  where c.columnname ilike p.attribute
  and f.ad_column_id = c.ad_column_id
  and f.ad_tab_id = t.ad_tab_id
  and t.ad_window_id = p.ad_window_id
  and w.ad_window_id = t.ad_window_id
  and c.defaultvalue is not null
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00309933.0PR16Q1 closedalostale It is not possible to define a preference as default value when column has a default defined in ad_column 

-  Notes
(0080808)
alostale (developer)
2015-10-05 09:53

Approved after discussion with DME

- Issue History
Date Modified Username Field Change
2015-10-05 09:51 alostale New Issue
2015-10-05 09:51 alostale Assigned To => alostale
2015-10-05 09:51 alostale Modules => Core
2015-10-05 09:51 alostale Triggers an Emergency Pack => No
2015-10-05 09:51 alostale Relationship added blocks 0030993
2015-10-05 09:53 alostale Tag Attached: Approved
2015-10-05 09:53 alostale Note Added: 0080808
2015-10-05 10:04 alostale Status new => scheduled
2015-10-05 10:04 alostale Status scheduled => resolved
2015-10-05 10:04 alostale Fixed in SCM revision => -
2015-10-05 10:04 alostale Resolution open => fixed
2015-10-05 10:05 alostale Fixed in Version => 3.0PR16Q1
2015-10-05 10:05 alostale Fixed in SCM revision - => http://code.openbravo.com/erp/devel/pi/rev/241c38dab7cedb1e44d3d130d73315dcb7caf479 [^]
2015-10-05 10:05 alostale Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker