Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030931
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Openbravo ERP] A. PlatformminorN/A2015-09-25 11:112015-11-23 21:16
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR16Q1
StatusclosedFix in branchFixed in SCM revision6a34fdef3d70
ProjectionnoneETAnoneTarget Version3.0PR16Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030931: Add ability to inherit role permissions

DescriptionIt would be nice to have the ability of inheriting permissions automatically for new roles. New roles would take their permissions from other already existing roles.

More information here: http://wiki.openbravo.com/wiki/Projects:Role_Inheritance [^]
Steps To Reproduce.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0031559 closedcaristu Add missing Inherited From field on Role Access subtab of Tables and Columns windows 
related to defect 0032627 closedcaristu template role cannot be used as session role 
related to defect 0032626 closedcaristu cannot propagate privileges if a template role has been used in a session 
related to defect 00327563.0PR16Q3 closedcaristu Hide the "Recalculate Permissions" button 

-  Notes
(0081106)
hgbot (developer)
2015-10-20 09:35

Repository: erp/devel/api-checks
Changeset: c5f09df216ff998ee1bb137097adc30ca8daf233
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Oct 20 09:29:31 2015 +0200
URL: http://code.openbravo.com/erp/devel/api-checks/rev/c5f09df216ff998ee1bb137097adc30ca8daf233 [^]

Related to issue 30931: fixes api change in AD_ROLE

---
M model/src-db/database/model/tables/AD_ROLE.xml
---
(0081107)
hgbot (developer)
2015-10-20 09:44

Repository: erp/devel/pi
Changeset: 6a34fdef3d70f568fa7e88928fe3c7890d6b8bed
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Oct 20 09:14:00 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/6a34fdef3d70f568fa7e88928fe3c7890d6b8bed [^]

fixes issue 30931: Add ability to inherit role permissions

---
M modules/org.openbravo.client.application/src-db/database/model/tables/OBUIAPP_PROCESS_ACCESS.xml
M modules/org.openbravo.client.application/src-db/database/model/tables/OBUIAPP_VIEW_ROLE_ACCESS.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_FIELD.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_MESSAGE.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_PREFERENCE.xml
M modules/org.openbravo.client.application/src/org/openbravo/client/application/ApplicationComponentProvider.java
M modules/org.openbravo.client.myob/src-db/database/model/tables/OBKMO_WIDGET_CLASS_ACCESS.xml
M modules/org.openbravo.client.myob/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.client.myob/src-db/database/sourcedata/AD_FIELD.xml
M modules/org.openbravo.client.myob/src-db/database/sourcedata/AD_MESSAGE.xml
M src-db/database/model/tables/AD_ALERTRECIPIENT.xml
M src-db/database/model/tables/AD_FIELD_ACCESS.xml
M src-db/database/model/tables/AD_FORM_ACCESS.xml
M src-db/database/model/tables/AD_PREFERENCE.xml
M src-db/database/model/tables/AD_PROCESS_ACCESS.xml
M src-db/database/model/tables/AD_ROLE.xml
M src-db/database/model/tables/AD_ROLE_ORGACCESS.xml
M src-db/database/model/tables/AD_TABLE_ACCESS.xml
M src-db/database/model/tables/AD_TAB_ACCESS.xml
M src-db/database/model/tables/AD_WINDOW_ACCESS.xml
M src-db/database/model/triggers/AD_ALERTRECIPIENT_TRG.xml
M src-db/database/model/triggers/AD_PREFERENCE_MOD_TRG.xml
M src-db/database/model/triggers/AD_ROLE_CHECK_TRG.xml
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_ELEMENT.xml
M src-db/database/sourcedata/AD_FIELD.xml
M src-db/database/sourcedata/AD_MESSAGE.xml
M src-db/database/sourcedata/AD_PREFERENCE.xml
M src-db/database/sourcedata/AD_TAB.xml
M src-db/database/sourcedata/AD_TABLE.xml
M src-db/database/sourcedata/AD_VAL_RULE.xml
M src-db/database/sourcedata/OBUIAPP_PROCESS.xml
M src-test/src/org/openbravo/test/AllAntTaskTests.java
M src/org/openbravo/base/model/Entity.java
M src/org/openbravo/base/model/Property.java
M src/org/openbravo/dal/core/DalUtil.java
M src/org/openbravo/erpCommon/ad_actionButton/InsertAcces.java
M src/org/openbravo/erpCommon/businessUtility/Preferences.java
M src/org/openbravo/erpCommon/utility/Utility.java
A src-db/database/model/tables/AD_ROLE_INHERITANCE.xml
A src-test/src/org/openbravo/test/role/inheritance/AccessPropagation.java
A src-test/src/org/openbravo/test/role/inheritance/AccessPropagationNotInherited.java
A src-test/src/org/openbravo/test/role/inheritance/DeletedAccessPropagation.java
A src-test/src/org/openbravo/test/role/inheritance/HorizontalInheritance.java
A src-test/src/org/openbravo/test/role/inheritance/RecalculatePermissions.java
A src-test/src/org/openbravo/test/role/inheritance/RoleInheritanceRestrictions.java
A src-test/src/org/openbravo/test/role/inheritance/RoleInheritanceTestSuite.java
A src-test/src/org/openbravo/test/role/inheritance/RoleInheritanceTestUtils.java
A src-test/src/org/openbravo/test/role/inheritance/VerticalInheritance.java
A src/org/openbravo/base/structure/InheritedAccessEnabled.java
A src/org/openbravo/role/inheritance/InheritedAccessEnabledEventHandler.java
A src/org/openbravo/role/inheritance/RecalculatePermissionsHandler.java
A src/org/openbravo/role/inheritance/RoleInheritanceEventHandler.java
A src/org/openbravo/role/inheritance/RoleInheritanceManager.java
A src/org/openbravo/role/inheritance/RoleInheritanceWarningFICExtension.java
A src/org/openbravo/role/inheritance/access/AccessTypeInjector.java
A src/org/openbravo/role/inheritance/access/AlertRecipientAccessInjector.java
A src/org/openbravo/role/inheritance/access/FieldAccessInjector.java
A src/org/openbravo/role/inheritance/access/FormAccessInjector.java
A src/org/openbravo/role/inheritance/access/OrgAccessInjector.java
A src/org/openbravo/role/inheritance/access/PreferenceAccessInjector.java
A src/org/openbravo/role/inheritance/access/ProcessDefinitionAccessInjector.java
A src/org/openbravo/role/inheritance/access/ReportAndProcessAccessInjector.java
A src/org/openbravo/role/inheritance/access/TabAccessInjector.java
A src/org/openbravo/role/inheritance/access/TableAccessInjector.java
A src/org/openbravo/role/inheritance/access/ViewImplementationAccessInjector.java
A src/org/openbravo/role/inheritance/access/WidgetClassAccessInjector.java
A src/org/openbravo/role/inheritance/access/WindowAccessInjector.java
A web/js/recalculatePermissionsProcess.js
---
(0081168)
hgbot (developer)
2015-10-21 10:22

Repository: erp/devel/pi
Changeset: ec1571c80cdb20067fa8a4173f8a7749f32e64a3
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Oct 21 10:21:13 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/ec1571c80cdb20067fa8a4173f8a7749f32e64a3 [^]

related to issue 30931: Add missing comment

---
M src/org/openbravo/role/inheritance/RoleInheritanceManager.java
---
(0081180)
hgbot (developer)
2015-10-21 19:29

Repository: erp/devel/pi
Changeset: dfe4b25757afbbcb9f15e1448de759965e80a354
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Oct 21 19:28:48 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/dfe4b25757afbbcb9f15e1448de759965e80a354 [^]

related to issue 30931: Improvement in warning message of FICExtension
The warning message was not being shown the first time a permission was created for a template role in use. The problem was that row does not contain the role information yet. For this reason, now we try to retrieve the information from the information provided by the FIC

---
M src/org/openbravo/role/inheritance/RoleInheritanceWarningFICExtension.java
---
(0081183)
alostale (developer)
2015-10-22 08:52

Code reviewed and tested as part of the project, for more info visit [1].

[1] http://wiki.openbravo.com/wiki/Projects:Role_Inheritance/QA [^]
(0081184)
hgbot (developer)
2015-10-22 09:01

Repository: erp/devel/pi
Changeset: d4b48ebb5167327f5cad93331ca2562503aaebf7
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Oct 22 09:00:46 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/d4b48ebb5167327f5cad93331ca2562503aaebf7 [^]

related to issue 30931: added new method for RoleInheritanceWarningFICExtension

---
M src/org/openbravo/role/inheritance/RoleInheritanceWarningFICExtension.java
---
(0081185)
hgbot (developer)
2015-10-22 09:15

Repository: erp/devel/pi
Changeset: de5117f7de9811538024673d9211a08d0307aa95
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Oct 22 09:14:03 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/de5117f7de9811538024673d9211a08d0307aa95 [^]

related to issue 30931: RoleInheritanceWarningFICExtension, correct method name

---
M src/org/openbravo/role/inheritance/RoleInheritanceWarningFICExtension.java
---
(0081235)
hgbot (developer)
2015-10-22 18:05

Repository: erp/devel/pi
Changeset: 7afc66ef62b43e4ca0c74f41e86c5d6b11a6132b
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Oct 22 18:04:29 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/7afc66ef62b43e4ca0c74f41e86c5d6b11a6132b [^]

related to issue 30931: Add missing ancestor check

---
M src-test/src/org/openbravo/test/role/inheritance/RoleInheritanceRestrictions.java
M src/org/openbravo/role/inheritance/RoleInheritanceEventHandler.java
---
(0081263)
hgbot (developer)
2015-10-23 14:17

Repository: erp/devel/pi
Changeset: c761249a7ca3cb9da19a32f31c3aa4ab693f9ab1
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Oct 23 14:14:37 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/c761249a7ca3cb9da19a32f31c3aa4ab693f9ab1 [^]

related to issue 30931: recalculate child permissions with different parents
When recalculating all the permissions of a role, it was not being deleted the child permissions inherited from a role different than the one used to inherit the parent. This is not fixed. Note that this case only applies in Tab Access and Field Access.

---
M src/org/openbravo/role/inheritance/RoleInheritanceManager.java
M src/org/openbravo/role/inheritance/access/AccessTypeInjector.java
M src/org/openbravo/role/inheritance/access/TabAccessInjector.java
M src/org/openbravo/role/inheritance/access/WindowAccessInjector.java
---
(0082058)
hgbot (developer)
2015-11-23 09:27

Repository: erp/devel/api-checks
Changeset: 12377b89341b1d165fa1123c75d9d22b74b06899
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Nov 23 09:27:16 2015 +0100
URL: http://code.openbravo.com/erp/devel/api-checks/rev/12377b89341b1d165fa1123c75d9d22b74b06899 [^]

Related to issue 30931: fixes api change in AD_ROLE

---
M model/src-db/database/model/tables/AD_ROLE.xml
---
(0082134)
hudsonbot (developer)
2015-11-23 21:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test
(0082138)
hudsonbot (developer)
2015-11-23 21:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test
(0082139)
hudsonbot (developer)
2015-11-23 21:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test
(0082141)
hudsonbot (developer)
2015-11-23 21:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test
(0082142)
hudsonbot (developer)
2015-11-23 21:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test
(0082151)
hudsonbot (developer)
2015-11-23 21:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test
(0082155)
hudsonbot (developer)
2015-11-23 21:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-09-25 11:11 caristu New Issue
2015-09-25 11:11 caristu Assigned To => caristu
2015-09-25 11:11 caristu Modules => Core
2015-09-25 11:11 caristu Triggers an Emergency Pack => No
2015-10-20 09:35 hgbot Checkin
2015-10-20 09:35 hgbot Note Added: 0081106
2015-10-20 09:44 hgbot Checkin
2015-10-20 09:44 hgbot Note Added: 0081107
2015-10-20 09:44 hgbot Status new => resolved
2015-10-20 09:44 hgbot Resolution open => fixed
2015-10-20 09:44 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/6a34fdef3d70f568fa7e88928fe3c7890d6b8bed [^]
2015-10-20 10:22 caristu Review Assigned To => alostale
2015-10-20 10:22 caristu Issue Monitored: alostale
2015-10-21 10:22 hgbot Checkin
2015-10-21 10:22 hgbot Note Added: 0081168
2015-10-21 19:29 hgbot Checkin
2015-10-21 19:29 hgbot Note Added: 0081180
2015-10-21 19:31 caristu Target Version => 3.0PR16Q1
2015-10-22 08:52 alostale Note Added: 0081183
2015-10-22 08:52 alostale Status resolved => closed
2015-10-22 08:52 alostale Fixed in Version => 3.0PR16Q1
2015-10-22 09:01 hgbot Checkin
2015-10-22 09:01 hgbot Note Added: 0081184
2015-10-22 09:15 hgbot Checkin
2015-10-22 09:15 hgbot Note Added: 0081185
2015-10-22 18:05 hgbot Checkin
2015-10-22 18:05 hgbot Note Added: 0081235
2015-10-23 14:17 hgbot Checkin
2015-10-23 14:17 hgbot Note Added: 0081263
2015-11-23 09:27 hgbot Checkin
2015-11-23 09:27 hgbot Note Added: 0082058
2015-11-23 13:38 caristu Relationship added related to 0031559
2015-11-23 21:16 hudsonbot Checkin
2015-11-23 21:16 hudsonbot Note Added: 0082134
2015-11-23 21:16 hudsonbot Checkin
2015-11-23 21:16 hudsonbot Note Added: 0082138
2015-11-23 21:16 hudsonbot Checkin
2015-11-23 21:16 hudsonbot Note Added: 0082139
2015-11-23 21:16 hudsonbot Checkin
2015-11-23 21:16 hudsonbot Note Added: 0082141
2015-11-23 21:16 hudsonbot Checkin
2015-11-23 21:16 hudsonbot Note Added: 0082142
2015-11-23 21:16 hudsonbot Checkin
2015-11-23 21:16 hudsonbot Note Added: 0082151
2015-11-23 21:16 hudsonbot Checkin
2015-11-23 21:16 hudsonbot Note Added: 0082155
2016-04-08 12:23 alostale Relationship added related to 0032627
2016-04-08 12:24 alostale Relationship added related to 0032626
2016-04-21 17:53 caristu Relationship added related to 0032756


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker